Bug 321504 - kwin incorrectly determines compositing type resulting in a black screen with a cursor
Summary: kwin incorrectly determines compositing type resulting in a black screen with...
Status: RESOLVED DUPLICATE of bug 321217
Alias: None
Product: kwin
Classification: Plasma
Component: compositing (show other bugs)
Version: 4.10.80
Platform: Ubuntu Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-22 19:26 UTC by Olivier van der Toorn
Modified: 2013-06-22 19:50 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Output of qdbus org.kde.kwin /KWin supportInformation (3.72 KB, text/plain)
2013-06-22 19:43 UTC, Olivier van der Toorn
Details
Output of glxinfo -l (12.62 KB, text/plain)
2013-06-22 19:44 UTC, Olivier van der Toorn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier van der Toorn 2013-06-22 19:26:20 UTC
I updated to KDE SC 4.10.80 on Kubuntu Raring (13.04) today, after rebooting and logging in I was greeted by a black screen with only a cursor showing. After a bit of digging around I found that if I changed the compositor type from OpenGL2 to XRender and rebooted I could login like normal again. Afterwards trying to enable OpenGL2 again throws a message that OpenGL2 is not supported on this system. I think the fallback to XRender failed somewhere.

Reproducible: Didn't try




The system I'm using is a HP Compaq 6730s: http://www.hp.com/hpinfo/newsroom/press_kits/2008/connecting/ds_bn_6730s.pdf

It uses an Intel Integrated graphics chip.
Comment 1 Thomas Lübking 2013-06-22 19:29:22 UTC
Please attach the output of "qdbus org.kde.kwin /KWin supportInformation" and "glxinfo -l"
Comment 2 Olivier van der Toorn 2013-06-22 19:43:18 UTC
Created attachment 80718 [details]
Output of qdbus org.kde.kwin /KWin supportInformation
Comment 3 Olivier van der Toorn 2013-06-22 19:44:00 UTC
Created attachment 80719 [details]
Output of glxinfo -l
Comment 4 Thomas Lübking 2013-06-22 19:50:04 UTC
Disable color correction, it's what causes the black screen.
Nevertheless, on that chip the fixed function path (GL 1.3) or GLES (kwin_gles) will probably get you better performance on eg. blurring.

*** This bug has been marked as a duplicate of bug 321217 ***