Bug 321304 - Leave A Note widget: When note is delivered, blank note also appears
Summary: Leave A Note widget: When note is delivered, blank note also appears
Status: RESOLVED FIXED
Alias: None
Product: knotes
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-18 02:23 UTC by kdebugs
Modified: 2013-10-10 17:32 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.3


Attachments
screenshot (62.46 KB, image/png)
2013-06-18 02:26 UTC, kdebugs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kdebugs 2013-06-18 02:23:09 UTC
Observed on version 4.10.2 on an Ubuntu derivative.

Reproducible: Always

Steps to Reproduce:
1. Add "Leave A Note" widget to the desktop.
2. Type any message and press "Leave Note" button.
3. An empty but dated note will appear immediately.
4. After a few seconds, the message you typed will appear too.


Expected Results:  
Useless empty note should not appear.
Comment 1 kdebugs 2013-06-18 02:26:45 UTC
Created attachment 80599 [details]
screenshot

Message at top left comes up first, followed a few seconds later by message to its right.
HTML formatting of message is addressed in another bug 321303.
Comment 2 kdebugs 2013-06-20 08:25:11 UTC
Tried on 4.10.3 (raring), then added ppa and upgraded to 4.10.4.  Same problem reproduces on these versions.  To clarify: To reproduce, knotes must not be running when the message is sent.  Furthermore, knotes must not have any notes already.

If knotes is already running, it will deliver the message immediately and there is no extra blank note.  If knotes is not running and it has one or more previous notes, these will display immediately (if they were visible when knotes was last closed), and the sent message will come after the delay, and there will be no extra blank note.

(Incidentally, I'm not sure the reasoning on the delay, or if it's just a quirk of some underlying system.  If you're watching when knotes starts it at least gives you a better indication that this is a "new" note.  But in my mind, showing the newly delivered note(s) in a different style until clicked on would make it better.)
Comment 3 Laurent Montel 2013-10-10 17:31:06 UTC
Git commit c6933322d76b435bf2d59f0931adcd2e6ca1b630 by Montel Laurent.
Committed on 10/10/2013 at 17:30.
Pushed by mlaurent into branch 'KDE/4.11'.

Fix Bug 321304 - Leave A Note widget: When note is delivered, blank note also appears

FIXED-IN: 4.11.3

M  +1    -1    applets/leavenote/leavenote.cpp

http://commits.kde.org/kdeplasma-addons/c6933322d76b435bf2d59f0931adcd2e6ca1b630
Comment 4 Laurent Montel 2013-10-10 17:32:26 UTC
We can't show note directly
we must wait that knotes is registered.
I divided time by 2.
Now It will better.
Regards