Bug 321042 - "Report problems or whishes" does not work for KMail2
Summary: "Report problems or whishes" does not work for KMail2
Status: RESOLVED FIXED
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kbugreport (show other bugs)
Version: 4.10.4
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-11 19:46 UTC by Rolf Eike Beer
Modified: 2013-06-14 07:22 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rolf Eike Beer 2013-06-11 19:46:33 UTC
When I select e.g. kmail/composer as component I can't file a bug because b.k.o rejects that product. Those entries need to be fixed to kmail2/*.

Reproducible: Always
Comment 1 Laurent Montel 2013-06-11 21:13:40 UTC
kmail1 is obsolete and we can't enter bugs.
Use kmail2/*
So what is the probleme ?

If you want to report bugs use kmail2.
Comment 2 Rolf Eike Beer 2013-06-12 06:29:11 UTC
That kontact has the wrong component names hardcoded in it's "report problems and whishes" menu. This makes that menu entry useless for reporting KMail2 problems as it still tries to report them as KMail1 ones.
Comment 3 Laurent Montel 2013-06-12 07:02:04 UTC
in 4.11 when I start kontact -> kmail -> report bug it selects kmail2 there is not kmail1
Comment 4 Christophe Giboudeaux 2013-06-12 08:25:58 UTC
Having the kmail1 components listed is not exactly a bug.

The product is not closed but it also doesn't accept new reports: A specific ACL was added. Only a couple people can interact with the obsolete product in bugzilla.

Note that closing the product won't make it disappear from the drkonqi wizard (closed products such as 'adept' or 'atlantik' are still listed despite being closed since years.
Comment 5 Christophe Giboudeaux 2013-06-12 08:27:26 UTC
reassign to drkonqi. Kontact is not filling the products/components list itself
Comment 6 Laurent Montel 2013-06-12 11:17:15 UTC
Git commit 06299ba014634b34e269a2860c1d92e361378a87 by Montel Laurent.
Committed on 12/06/2013 at 13:17.
Pushed by mlaurent into branch 'KDE/4.10'.

Fix Bug 321042 - "Report problems or whishes" does not work for KMail2

FIXED-IN: 4.10.5

M  +14   -26   kdeui/kdepackages.h

http://commits.kde.org/kdelibs/06299ba014634b34e269a2860c1d92e361378a87
Comment 7 Jekyll Wu 2013-06-14 07:22:33 UTC
Just to make it clear:  this report has nothing to do with DrKonqi. 

What you are dealing with in this report is KBugReport from kdelibs, while DrKonqi lives in kde-runtime. They are not related with each other at all at this moment.