Bug 320823 - Inline renaming works incorrectly when there's a change in the view
Summary: Inline renaming works incorrectly when there's a change in the view
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Applications
Component: view-engine: general (show other bugs)
Version: 2.2
Platform: Arch Linux Linux
: NOR normal
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: investigated
Depends on:
Blocks:
 
Reported: 2013-06-06 15:56 UTC by Siddhartha
Modified: 2013-06-10 19:55 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.10.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Siddhartha 2013-06-06 15:56:57 UTC
Any change in the view when in inline renaming mode makes dolphin forget what original file was intended to be renamed and incorrectly renames a different file.

Reproducible: Always

Steps to Reproduce:
1) Open a folder (say x)
2) Expand a sub folder (say y)
3) Start inline renaming a file (say f2) below y
3) A new file appears in the y (eg: ongoing download list), and the view shifts down by one line
Actual Results:  
the file above f2 gets the new filename. So if there are files f1 and f2, try to rename f2 to g2, f1 is renamed to g2 while f2 remains unaffected.

Expected Results:  
f2 should be renamed to g2 and not f1
Comment 1 Frank Reininghaus 2013-06-07 09:47:05 UTC
Thanks for the bug report! Actually, it does not depend on the view mode at all if I'm not mistaken.

My way to reproduce (to make sure I don't forget it):

touch 2 && dolphin . &
sleep 5; touch 1

Then switch to Dolphin and try to rename '2'.

This needs to be fixed in KStandardItemListWidget. I guess we should not tell the role editor about the 'index' at all (because it might change). Better just get a signal without index from the editor and forward it then with the current (possibly modified) one.
Comment 2 Siddhartha 2013-06-07 10:40:55 UTC
Thanks again for looking into this.

And yes you're right. I can reproduce this bug in both detailed view with no expanded subfolder and in icons view.
Comment 3 Frank Reininghaus 2013-06-10 19:41:48 UTC
I've just fixed this for KDE 4.10.5 with commit

http://quickgit.kde.org/?p=kde-baseapps.git&a=commit&h=4de9a233642a62ee96bac6031340d3eea21f14f9

The commit message is wrong though - I've somehow messed up the local branches in my git repository. Sorry about the confusion!
Comment 4 Siddhartha 2013-06-10 19:55:38 UTC
Hey Frank, this was quick. I'll wait for the 4.10.5 release before I test it though. Thanks and keep up the great work!