Bug 320612 - shortcut containing "é" (e with acute) does not work
Summary: shortcut containing "é" (e with acute) does not work
Status: RESOLVED DUPLICATE of bug 375518
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_khotkeys (show other bugs)
Version: 4.10.3
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michael Jansen
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-06-02 12:18 UTC by Jany Belluz
Modified: 2021-03-26 16:11 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
What i can see on Task Switcher configuration screen when try to set Alt+dead_grave (9.64 KB, image/png)
2013-06-05 14:51 UTC, Renato Botelho
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jany Belluz 2013-06-02 12:18:30 UTC
I added shortcuts for virtual desktop switching, using the meta (Windows) key + number keys from my azerty keyboard:
Desktop 1: Meta + &
Desktop 2: Meta + é
Desktop 3: Meta + "
Desktop 4: Meta + '
(azerty layout : http://commons.wikimedia.org/wiki/File:Clavier-Azerty.svg)

They all work except number 2 with the "é". I tried using Ctrl + "é" instead, it does not work either.


Reproducible: Always

Steps to Reproduce:
1. Open systemsettings
2. Navigate to Shortcuts and gestures -> global keyboard shortcuts -> kwin (names may be inaccurate, I use it in French)  
3. Change shortcut for "Switch to desktop 2" to "Meta + é"
4. Apply
5. Trigger Meta + é
Actual Results:  
Nothing. Still on desktop whatever-but-not-2.

Expected Results:  
On desktop 2.

My "é" key works. For example, pressing "Meta + &" and then "Meta + é" gives the same kinds of results:
KeyPress event, serial 42, synthetic NO, window 0x4600001,
    root 0xa3, subw 0x4600002, time 9356138, (62,44), root:(1484,91),
    state 0x0, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

FocusOut event, serial 42, synthetic NO, window 0x4600001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 42, synthetic NO, window 0x4600001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 42, synthetic NO, window 0x0,
    keys:  4294967203 4   0   0   0   0   0   0   64  0   0   1   0   0   0   0   
           32  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

KeyRelease event, serial 42, synthetic NO, window 0x4600001,
    root 0xa3, subw 0x4600002, time 9356553, (62,44), root:(1484,91),
    state 0x40, keycode 10 (keysym 0x26, ampersand), same_screen YES,
    XLookupString gives 1 bytes: (26) "&"
    XFilterEvent returns: False

KeyRelease event, serial 42, synthetic NO, window 0x4600001,
    root 0xa3, subw 0x4600002, time 9356667, (62,44), root:(1484,91),
    state 0x40, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False

KeyPress event, serial 42, synthetic NO, window 0x4600001,
    root 0xa3, subw 0x4600002, time 9363655, (62,44), root:(1484,91),
    state 0x0, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XmbLookupString gives 0 bytes: 
    XFilterEvent returns: False

FocusOut event, serial 42, synthetic NO, window 0x4600001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 42, synthetic NO, window 0x4600001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 42, synthetic NO, window 0x0,
    keys:  4294967203 8   0   0   0   0   0   0   64  0   0   1   0   0   0   0   
           32  0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   

KeyRelease event, serial 42, synthetic NO, window 0x4600001,
    root 0xa3, subw 0x4600002, time 9364621, (62,44), root:(1484,91),
    state 0x40, keycode 11 (keysym 0xe9, eacute), same_screen YES,
    XLookupString gives 2 bytes: (c3 a9) "é"
    XFilterEvent returns: False

KeyRelease event, serial 42, synthetic NO, window 0x4600001,
    root 0xa3, subw 0x4600002, time 9364771, (62,44), root:(1484,91),
    state 0x40, keycode 133 (keysym 0xffeb, Super_L), same_screen YES,
    XLookupString gives 0 bytes: 
    XFilterEvent returns: False
Comment 1 Renato Botelho 2013-06-05 14:50:44 UTC
I'm having a similar issue here. My keyboard is configured as US international with deadkeys, and the default key for cycle through windows of the same group (Alt+`) doesn't work, when I try to set it again, and press the combination (Alt+dead_grave) it shows some garbage as you can see on attached image and the shortcut combination simply doesn't work.

I'm using KDE 4.10.3 on gentoo.
Comment 2 Renato Botelho 2013-06-05 14:51:30 UTC
Created attachment 80316 [details]
What i can see on Task Switcher configuration screen when try to set Alt+dead_grave
Comment 3 manulul.pubs 2013-12-15 19:12:57 UTC
I have the same problem.
Is there any workaround ?
Comment 4 Renato Botelho 2013-12-23 17:27:18 UTC
Sadly I couldn't find any workaround until now, I moved to gnome and keep checking this issue from time to time waiting for a solution. I just tested it again on a fedora 20 / kde 4.11 and it is still present.
Comment 5 arnco 2017-02-15 13:04:44 UTC
Hi,

Same problem here with the Ctrl+é shortcut, french azerty Keyboard on a 2012-MacBook Pro running Linux Mint 18 KDE.

Even when caps lock is on, the shortcut isn't recognzed.

this bug seems very close to this one https://bugs.kde.org/show_bug.cgi?id=342493
Comment 6 Damjan Georgievski 2017-11-06 17:04:01 UTC
I have a similar problem (so perhaps the same issue):
The layout of my keyboard is 'gb' (english uk), meaning the symbols above 123 are !"£. 

The layout of my keyboard is 'gb' (english uk), meaning the symbols above 123 are !"£.

I've set Kwin shortcuts, Meta + 1, Meta + 2 and Meta + 3 to switch to first,second,third virtual desktop (see image).
https://i.imgur.com/a53RHRG.png
I also wanted to set Meta+Shift+1,2,3 to move windows to the coresponding desktop.
When I enter those combinations I get Meta + !, Meta + " and Meta + £ (see second image)
https://i.imgur.com/RRnFO3d.png

The problem is, only Meta + ! (ie Meta+Shift+1) works. The other two don't.

Interestingly I *can* use Meta+$
Comment 7 Damjan Georgievski 2018-02-07 13:47:30 UTC
Bug is still here with Plasma 5.12 on X
Comment 8 Nate Graham 2018-11-04 13:57:41 UTC

*** This bug has been marked as a duplicate of bug 350816 ***
Comment 9 Damjan Georgievski 2018-11-04 18:36:41 UTC
bug 350816 fixes this in plasma 5.15, but in the meantime I can confirm that restarting kglobalaccel5 will work around the issue
Comment 10 Nate Graham 2021-03-26 16:11:08 UTC

*** This bug has been marked as a duplicate of bug 375518 ***