Bug 320398 - Select Album window should remember last used destination
Summary: Select Album window should remember last used destination
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-Albums (show other bugs)
Version: 3.2.0
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-28 20:29 UTC by DrSlony
Modified: 2017-08-16 09:33 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DrSlony 2013-05-28 20:29:45 UTC
I import photos using Import > USB Storage Devices > <Device>
The Import window pops up.
Next, I click on Image > Download/Delete All

My structure is like this:
‣ Collection 1
‣ Collection 2
‣ Collection 3
├2010-01-01
├2010-01-02
├2010-01-03
…
├2013-05-27
└2013-05-28
‣ Collection 4

I always click on "Collection 3" because I use "Auto creation of albums" > "Date-based sub-albums". Problem is that every time I want to import photos, I have to scroll all the way up to click on Collection 3. I wish it remembered this choice.

Reproducible: Always
Comment 1 caulier.gilles 2013-05-29 11:55:22 UTC
In Camera/Behavior setup page, you can set a default target album to download from camera. dialog will never appear at downloading process...

This will not solve your problem ?

Gilles Caulier
Comment 2 DrSlony 2013-08-28 21:48:09 UTC
Yes, this solves the issue, thank you.

One thing though - it would be good if I could still choose a different destination without having to go to Settings again. Currently (3.3.0) the destination panel is missing from the import window if I select a default target album in the Camera/Behavior setup page.
Comment 3 Teemu Rytilahti 2013-12-02 16:29:27 UTC
I agree that the last save folder should be used as a default for the new imports.
Comment 4 Teemu Rytilahti 2014-01-02 22:54:03 UTC
Git commit 98f335e08559342436bc158628cdd17ce03dc353 by Teemu Rytilahti.
Committed on 02/01/2014 at 22:53.
Pushed by rytilahti into branch 'master'.

ImportUI: If there's no default album selected, preselect the last used album for downloading.
FIXED-IN:4.0.0

M  +3    -1    utilities/importui/main/importui.cpp
M  +2    -0    utilities/importui/main/importui_p.h

http://commits.kde.org/digikam/98f335e08559342436bc158628cdd17ce03dc353