Bug 320359 - SCAN : digiKam should show which directories are scanned during start-up when adding collections after database deletion
Summary: SCAN : digiKam should show which directories are scanned during start-up when...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 4.2.0
Platform: Other Linux
: NOR normal with 5 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-27 18:13 UTC by DrSlony
Modified: 2016-07-19 19:35 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DrSlony 2013-05-27 18:13:11 UTC
Delete digikam4.db, run digiKam. It asks you to select collections, so do that and proceed. Now the splash screen is on screen, for a very....long....time..... I have no idea how far in the scanning process it is, or how much it has left. It should show me the full path relative to the collection of the file it's currently scanning, and, if possible, a % estimate.

Even worse, if you happen to click on the splash screen, it disappears! The only indication that digiKam is doing something is that the process is still running and the cache memory keeps increasing. All I wanted to do is to batch-resize some photos and to send them off to a client, but after waiting for 15 minutes I gave up and went outside.

Reproducible: Always
Comment 1 caulier.gilles 2013-11-25 12:59:41 UTC
Note :

On SplashScreen, we only report albums listing, not album item contents. This second stage is done in progress manager when digiKam main GUI appears.

Gilles Caulier
Comment 2 DrSlony 2013-11-25 15:06:17 UTC
I just reproduced on 3.5.0. The splash screen doesn't show me anything, not even albums:
http://i.imgur.com/Wwa3hfy.png
and as in my first post, if I click on it, it disappears, and the only indication that something's happening is if I use "ps" to find the digikam process, or listen to the disk grinding.
Comment 3 caulier.gilles 2014-08-21 21:54:29 UTC
It's simple : disable splashscreen from Setup/misc dialog, and you will see a progress dialog about album scan.

Gilles Caulier
Comment 4 caulier.gilles 2014-09-05 13:15:57 UTC
Marcel,

The problem is just reproducible with 4.2.0.

I just reproduce the way explained by DrSonly by deleteing database and restart digiKam. It ask to setup collection. Splash appear and no information are displayed about scanning operation until a while.

In the console, i can see that digiKam scan directories AND files, not only directories as expected. Files must be started when albums are parsed from collection, and main GUI must be show with a progress item indicating scan of items from directories.

Why this behavior is different here ?

Gilles
Comment 5 caulier.gilles 2015-05-10 18:46:46 UTC
Maik,

For this one i propose to drop DProgressDlg from scna at starup process and to remove MISC option about to show or not splascreen.

This want mean to always show splashscreen at startup and to patch it to show current album scanned (currently is show only a generic message).

Note : DProgressDlg still also used in AdvanceRename tool but this one must be ported to ProgressManager. After that, DProgressDlg can be definitively removed from digiKam core.

Gilles
Comment 6 swatilodha27 2016-07-17 13:44:23 UTC
With digiKam 5.0.0, if I UNSELECT "Show splash screen at startup" in Configure digiKam/Miscellaneous, there's no progress dialog visible. 
Only by looking at console, one can figure out that required files are loading. And after digiKam finally starts, there just appears a dialog, stating, "Process is done".
Comment 7 caulier.gilles 2016-07-17 15:19:16 UTC
Git commit 27a7e771060fa8f6d40461b9444bb4496487f102 by Gilles Caulier.
Committed on 17/07/2016 at 15:13.
Pushed by cgilles into branch 'master'.

Restore broken splashscreen animation while database process at startup.
Related: bug 281959

M  +20   -13   libs/widgets/common/dsplashscreen.cpp

http://commits.kde.org/digikam/27a7e771060fa8f6d40461b9444bb4496487f102
Comment 8 caulier.gilles 2016-07-18 12:56:24 UTC
Git commit 4047edd1532b129fe895a8c4b0f810adc92d2f7f by Gilles Caulier.
Committed on 18/07/2016 at 12:48.
Pushed by cgilles into branch 'master'.

Improve digiKam startup time :
------------------------------

- remove splashscreen from ScanController. Always use a progress dialog instead in all cases.

- We will always require a progress dialog at first init to scan albums.
All details are given in dialog about which album is scanned and how many items still in the queue to process.

- The splashscreen always arrive after the progress dialog. Splash show final stage to init GUI

- When GUI is displayed, always start a delayed find new item process through progress manager. This is done in background.
Progress info is given in progress manager as well. While scan for new item is running in a separated thread,
user can start to work with GUI, even if all items are not yet catalogued in database.
Related: bug 281959
FIXED-IN: 5.1.0

M  +18   -29   app/main/digikamapp.cpp
M  +9    -42   libs/database/utils/scancontroller.cpp
M  +2    -3    libs/database/utils/scancontroller.h
M  +4    -2    utilities/maintenance/maintenancetool.h

http://commits.kde.org/digikam/4047edd1532b129fe895a8c4b0f810adc92d2f7f
Comment 9 caulier.gilles 2016-07-19 19:35:07 UTC
Git commit 4f270e01d50f31a4a3990aa9b0ad12629374fb35 by Gilles Caulier.
Committed on 19/07/2016 at 19:34.
Pushed by cgilles into branch 'master'.

restore older scan for new items at startup option
Related: bug 281959

M  +6    -2    app/main/digikamapp.cpp
M  +2    -1    libs/settings/applicationsettings.cpp
M  +3    -0    libs/settings/applicationsettings.h
M  +10   -0    libs/settings/applicationsettings_miscs.cpp
M  +3    -0    libs/settings/applicationsettings_p.cpp
M  +1    -0    libs/settings/applicationsettings_p.h
M  +7    -0    utilities/setup/setupmisc.cpp

http://commits.kde.org/digikam/4f270e01d50f31a4a3990aa9b0ad12629374fb35