Bug 320358 - Files randomly fail to process
Summary: Files randomly fail to process
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: BatchQueueManager-Workflow (show other bugs)
Version: 3.2.0
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-27 18:07 UTC by DrSlony
Modified: 2019-12-29 22:22 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description DrSlony 2013-05-27 18:07:56 UTC
I added 42 JPEG files to the BQM. Workflow: resize to 1920, convert to JPEG q95 medium subsampling. Of the 42 files, 2 failed to process. I re-ran those two, and they processes fine.

Earlier today I tried processing the same files, some files also failed to process, but different ones to the ones that failed to process now. Some other things were wrong too. I think digiKam didn't show some images in the albums though they were there on disk, and they were not corrupt. Tools > Maintenance > Scan for new items didn't work, so I deleted digikam4.db and after restarting they appeared.

BQM should give me some more info as to why they failed to process. It is very frustrating to notice when I was about to send the photos off that some where missing and I already deleted the intermediate files so I had to re-develop the raws.

Reproducible: Sometimes
Comment 1 caulier.gilles 2013-07-27 09:19:26 UTC
Git commit dd3dc1cdd2292f2c12b2927250619ae4781f3a61 by Gilles Caulier.
Committed on 27/07/2013 at 09:10.
Pushed by cgilles into branch 'master'.

Batch Queue Manager : add new option to turn on/off multi-core support. This option is now turn off by default due to some dysfunctions under Windows, until it will be hack and fixed.
Note that problem are not reproducible under OSX and Linux here. Options is implemnted for digiKam 3.3.0 release.
Related: bug 315025, bug 318198, bug 318577

M  +13   -1    utilities/queuemanager/manager/actionthread.cpp
M  +1    -1    utilities/queuemanager/manager/actionthread.h
M  +4    -1    utilities/queuemanager/manager/queuesettings.h
M  +9    -1    utilities/queuemanager/manager/workflowmanager.cpp
M  +14   -2    utilities/queuemanager/views/queuesettingsview.cpp

http://commits.kde.org/digikam/dd3dc1cdd2292f2c12b2927250619ae4781f3a61
Comment 2 Eduard Huguet 2013-07-29 07:13:43 UTC
Hi, 
This seems very similar to the bug I reported some time ago, regarding batch RAW file conversion:

https://bugs.kde.org/show_bug.cgi?id=318577

Please, could you try if booting your system in single-core mode reproduces the problem?
Comment 3 caulier.gilles 2014-09-01 11:41:17 UTC

*** This bug has been marked as a duplicate of bug 318577 ***
Comment 4 DrSlony 2014-09-01 13:21:41 UTC
To be clear, the issue I reported happened under Gentoo Linux.
Comment 5 caulier.gilles 2019-12-29 22:22:56 UTC
Not reproducible with 7.0.0 beta 1.