Bug 320295 - Bad Exif orientation interpretation while importing
Summary: Bad Exif orientation interpretation while importing
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Import-PostProcessing (show other bugs)
Version: 3.2.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-26 09:36 UTC by Stephane MANKOWSKI
Modified: 2017-08-16 05:55 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.3.0


Attachments
Picture with exif orientation (1.45 MB, image/jpeg)
2013-05-26 09:37 UTC, Stephane MANKOWSKI
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stephane MANKOWSKI 2013-05-26 09:36:39 UTC
During the import, the exif orientation is not taking into account. This is disturbing for the following tasks.

Reproducible: Always

Steps to Reproduce:
1. Copy the attached picture on a usb key 
2. Import the picture from the usb key to your computer by using digikam.
The "rotation" option in the import panel can be selected on not. 
3. Visualize the picture in digikam
Actual Results:  
Due to the exif orientation, the visualization is good in digikam and all other tool managing this exif orientation (example: dolphin, gwenview, krita). 
But, on the hard disk, the orientation still wrong.
So, the file is not well oriented if: 
1-I push it on my web site 
2-I send it by email 
3-I replicate it to my drop box

Expected Results:  
Because I don't really understand why it could be interesting to have the wrong orientation on the hard disk, the import should: 
1-Use the exif orientation to apply the rotation of the picture 
2-Remove the exif orientation to avoid to use it twice (one during the import, the second one for visualization)
The "rotate" option seems to be done for that but does not work.

As work around, I use the rotate function but it's disturbing because: 
1-In digikam the orientation is good on the screen but bad on the file 
2-I click on the rotate icon ==> the orientation is bad on the screen and bad on the file 
3-I click on the rotate icon in the opposite direction==> the orientation is bad on the screen and bad on the file 
3-I click on the rotate icon in the opposite direction==> the orientation is good on the screen and good on the file 
 4-But now, how to know the pictures treated and the picture not treated?
Comment 1 Stephane MANKOWSKI 2013-05-26 09:37:19 UTC
Created attachment 80089 [details]
Picture with exif orientation
Comment 2 Stephane MANKOWSKI 2013-05-26 09:37:39 UTC
I opened the same bug on gwenview:
https://bugs.kde.org/show_bug.cgi?id=320293
Comment 3 caulier.gilles 2013-05-26 09:44:37 UTC
If Gwenview is touched, sound like a Exiv2 shared library problem...

- Which Exiv2 version you use ? Look in Help/Components Info dialog.

Can you try with Exiv2 command line tool if Exif orientation flag is displayed properly ?

Gilles Caulier
Comment 4 Stephane MANKOWSKI 2013-05-26 09:52:42 UTC
(In reply to comment #3)
> If Gwenview is touched, sound like a Exiv2 shared library problem...
> 
> - Which Exiv2 version you use ? Look in Help/Components Info dialog.
> 
> Can you try with Exiv2 command line tool if Exif orientation flag is
> displayed properly ?
> 
> Gilles Caulier

My version of Exiv2 is:
exiv2 0.23 001700 (64 bit build)

Here is the result of exiv2:
File name       : img_2013-05-26-10-07-57.jpg
File size       : 1519816 Bytes
MIME type       : image/jpeg
Image size      : 4000 x 3000
Camera make     : CASIO COMPUTER CO.,LTD.
Camera model    : EX-ZR100   
Image timestamp : 2013:05:26 10:07:57
Image number    : 
Exposure time   : 1/60 s
Aperture        : F3
Exposure bias   : 0 EV
Flash           : No, auto
Flash bias      : 
Focal length    : 4.2 mm (35 mm equivalent: 24.0 mm)
Subject distance: 
ISO speed       : 500
Exposure mode   : Auto
Metering mode   : Multi-segment
Macro mode      : 
Image quality   : 
Exif Resolution : 4000 x 3000
White balance   : Auto
Thumbnail       : image/jpeg, 7462 Bytes
Copyright       : 
Exif comment    : 

But, in digikam, the picture is well oriented. That's fine.
But, because the file is not really modified, the usage is complex and disturbing (example: when you want to send a picture by email, the picture is not well oriented in the mail).
Comment 5 Benni Hill 2013-05-28 18:15:21 UTC
@Stephane: In digikam "Auto Rotate/Flip using Exif Information" is under "Image".
Comment 6 Stephane MANKOWSKI 2013-05-28 19:04:00 UTC
(In reply to comment #5)
> @Stephane: In digikam "Auto Rotate/Flip using Exif Information" is under
> "Image".

Hi,

When I apply this function from digikam, nothing is done, my file is not modified.
When I apply the same function from gwenview, the file is rotated and modified.
Comment 7 Stephane MANKOWSKI 2013-05-28 19:10:48 UTC
I think this is a bug. At least with my pictures. (You can test it with that attached file).

Moreover, the "rotation" option in import panel does nothing.
Comment 8 caulier.gilles 2014-09-01 08:37:48 UTC
Stephane,

This file still valid using last digiKam 4.2.0 ?

Gilles Caulier
Comment 9 Stephane MANKOWSKI 2014-09-01 11:12:18 UTC
(In reply to Gilles Caulier from comment #8)
> Stephane,
> 
> This file still valid using last digiKam 4.2.0 ?
> 
> Gilles Caulier

I don't know if this bug is still valid on 4.2.0 because the version I have is 4.0.0
Comment 10 caulier.gilles 2014-09-01 11:19:01 UTC
And it's reproducible with 4.0.0 ?

Gilles Caulier
Comment 11 Stephane MANKOWSKI 2014-09-01 12:27:42 UTC
 "Auto Rotate/Flip using Exif Information" works well on 4.0.0