Bug 320233 - Present windows (or probably, All Windows) slightly broken
Summary: Present windows (or probably, All Windows) slightly broken
Status: RESOLVED DUPLICATE of bug 305044
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 4.10.3
Platform: Ubuntu Other
: NOR major (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-24 18:46 UTC by Nikita Zlobin
Modified: 2013-05-24 19:09 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nikita Zlobin 2013-05-24 18:46:01 UTC
This effect on russian is called as "All Windows" (like same plugin for desktop switching via grid), in english — probably, Present windows (i'm not sure, tried to change language of systemsettings, but effect settings dialog is not affected by it).

In short, some functions seems to be disabled or broken:
1. Disappeared window switcher mode — the closest things available are several downloadable plugins, probably implemented in javascript, which are too slow for me (comparing to this plugin) and are less convenient — more like a some overgrown variant of popup switchers with previews.
2. Plasma icon-only taskbar now can't use "Windows in button" function for left click on group, instead it just showes menu.
3. Yet Another Window Control applet, which for now is set for caption, just before menubar applet, doesn't nothing by left clict (before it used same "Scale" (sorry for using compiz terms) function for all windows (afaik, even from other desktops).

Reproducible: Always

Steps to Reproduce:
1. In systemsettings go to window behavior -> window selection and look to visualization. There i nothing to use necesary plugin.
2. Install and add plasma applet Yet Another Window Control and try to click. I did not see options to enable/disable this effect in applet's settings.
3. Install/add plasma applet taskbar (icons only), go to its settings/behavior section and set mouse click on tasks group to "Windows in button" (or how it is called on english, not sure) — again, just a menu instead of expected effect.



When i installed latest calculate disstro with kde 4.10.1 (now upgraded to 4.10.3), i casually found YAWC analog, which can display only full set of windows controls, including two buttons, but when clicked — it calls All Windows for curent desktop.

Forced to directly assigne Alt+Tab and Alt+` for selection from current desktop and application group respectively (same as if you assign them for corners actions).

Not sure, is it planned ot not, so please consider it and set proper severity. For now assuming it major :)
Comment 1 Thomas Lübking 2013-05-24 19:09:16 UTC
> Disappeared window switcher mode
bug #305044 (wontfix, it's not a bug)

> Plasma icon-only taskbar now can't use "Windows in button" function for left click on group, instead it just showes menu
I'd bet on #179042, see https://git.reviewboard.kde.org/r/107983/ - but that's the wrong component, please file a bug against the taskbar in doubt.

> Yet Another Window Control applet
Some external applet/plasmoid i presume which fails on calling the effect or runs into the above.
Also does not belong here, please contat the plasmoid author in case it's not #179042

In general, for the future and please, prettypleasewithsugarontop:
Do NOT collect bugs, makes them unmaintainable and instant "invalid" as far as i'm concerned - regardless that this bug actually describes no KWin bug.

Marking as dupe of first and only KWin related item.

*** This bug has been marked as a duplicate of bug 305044 ***