Bug 319795 - awaria plasmy
Summary: awaria plasmy
Status: RESOLVED DUPLICATE of bug 281035
Alias: None
Product: Active
Classification: Plasma
Component: General (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: unscheduled
Assignee: active
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-13 17:21 UTC by Piotrekw1
Modified: 2013-05-18 02:10 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Piotrekw1 2013-05-13 17:21:01 UTC
Application: plasma-device (1.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-41-generic-pae i686
Distribution: Ubuntu 12.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed: po uruchomieniu plasma nie reaguje w pasku bocznym

- Unusual behavior I noticed:
zainstalowane pakiety debugowania

-- Backtrace:
Application: Plasma Workspace (plasma-device), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb1c5e740 (LWP 1441))]

Thread 5 (Thread 0xb09cbb40 (LWP 1449)):
#0  0xb7757424 in __kernel_vsyscall ()
#1  0xb289f96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb764b6ec in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb3867029 in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#4  0xb386706f in ?? () from /usr/lib/i386-linux-gnu/libQtScript.so.4
#5  0xb289bd4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb763ddde in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xa74d2b40 (LWP 1473)):
#0  0xb7757424 in __kernel_vsyscall ()
#1  0xb289f96b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb764b6ec in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4b94263 in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#4  0xb4b9437f in ?? () from /usr/lib/i386-linux-gnu/libQtWebKit.so.4
#5  0xb289bd4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb763ddde in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa6bd1b40 (LWP 1474)):
#0  0xb7757424 in __kernel_vsyscall ()
#1  0xb762f690 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb27d7a7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb27ca0ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb27ca201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb55658e7 in QEventDispatcherGlib::processEvents (this=0xa6200468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb553150d in QEventLoop::processEvents (this=0xa6bd1270, flags=...) at kernel/qeventloop.cpp:149
#7  0xb55317a9 in QEventLoop::exec (this=0xa6bd1270, flags=...) at kernel/qeventloop.cpp:204
#8  0xb541a94c in QThread::exec (this=0x98f37f8) at thread/qthread.cpp:501
#9  0xb541aa3b in QThread::run (this=0x98f37f8) at thread/qthread.cpp:568
#10 0xb541dde0 in QThreadPrivate::start (arg=0x98f37f8) at thread/qthread_unix.cpp:298
#11 0xb289bd4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb763ddde in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xa4abfb40 (LWP 1475)):
#0  0xb2bd4dcd in clock_gettime () from /lib/i386-linux-gnu/librt.so.1
#1  0xb547c315 in do_gettime (frac=0xa4abefb0, sec=0xa4abefa8) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0xb5566226 in QTimerInfoList::updateCurrentTime (this=0xa4102074) at kernel/qeventdispatcher_unix.cpp:343
#4  0xb556657a in QTimerInfoList::timerWait (this=0xa4102074, tm=...) at kernel/qeventdispatcher_unix.cpp:450
#5  0xb5564e23 in timerSourcePrepareHelper (src=<optimized out>, timeout=0xa4abf0bc) at kernel/qeventdispatcher_glib.cpp:136
#6  0xb5564ebd in timerSourcePrepare (source=0xa4102040, timeout=<optimized out>) at kernel/qeventdispatcher_glib.cpp:169
#7  0xb27c9872 in g_main_context_prepare () from /lib/i386-linux-gnu/libglib-2.0.so.0
#8  0xb27c9faf in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#9  0xb27ca201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#10 0xb55658e7 in QEventDispatcherGlib::processEvents (this=0xa4100468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#11 0xb553150d in QEventLoop::processEvents (this=0xa4abf240, flags=...) at kernel/qeventloop.cpp:149
#12 0xb55317a9 in QEventLoop::exec (this=0xa4abf240, flags=...) at kernel/qeventloop.cpp:204
#13 0xb541a94c in QThread::exec (this=0x9c57110) at thread/qthread.cpp:501
#14 0xb550eb5d in QInotifyFileSystemWatcherEngine::run (this=0x9c57110) at io/qfilesystemwatcher_inotify.cpp:248
#15 0xb541dde0 in QThreadPrivate::start (arg=0x9c57110) at thread/qthread_unix.cpp:298
#16 0xb289bd4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#17 0xb763ddde in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb1c5e740 (LWP 1441)):
[KCrash Handler]
#7  0xa9760e7b in value (akey=<optimized out>, this=0x94341e8) at /usr/include/qt4/QtCore/qhash.h:609
#8  TaskManager::TaskManager::isOnTop (this=0x93eb9f0, task=0x9588568) at ../../../libs/taskmanager/taskmanager.cpp:483
#9  0xa974d634 in TaskManager::Task::isOnTop (this=0x9588568) at ../../../libs/taskmanager/task.cpp:231
#10 0xa9d49634 in TaskSource::updateTask (this=0xa294e30, taskChanges=...) at ../../../../../plasma/generic/dataengines/tasks/tasksource.cpp:97
#11 0xa9d4a890 in TaskSource::TaskSource (this=0xa294e30, task=0x9588568, parent=0x945a1e0) at ../../../../../plasma/generic/dataengines/tasks/tasksource.cpp:44
#12 0xa9d4759e in taskAdded (task=0x9588568, this=0x945a1e0) at ../../../../../plasma/generic/dataengines/tasks/tasksengine.cpp:109
#13 TasksEngine::taskAdded (this=0x945a1e0, task=0x9588568) at ../../../../../plasma/generic/dataengines/tasks/tasksengine.cpp:105
#14 0xb55496b1 in QMetaObject::activate (sender=0x93eb9f0, m=0xa977ea78, local_signal_index=0, argv=0xbff6b368) at kernel/qobject.cpp:3547
#15 0xa9760be5 in TaskManager::TaskManager::taskAdded (this=0x93eb9f0, _t1=0x9588568) at ./taskmanager.moc:187
#16 0xa9762001 in TaskManager::TaskManager::windowAdded (this=0x93eb9f0, w=44040218) at ../../../libs/taskmanager/taskmanager.cpp:298
#17 0xa9762cb1 in qt_static_metacall (_a=0xbff6b538, _id=7, _o=0x93eb9f0, _c=<optimized out>) at ./taskmanager.moc:103
#18 TaskManager::TaskManager::qt_static_metacall (_o=0x93eb9f0, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0xbff6b538) at ./taskmanager.moc:90
#19 0xb55496b1 in QMetaObject::activate (sender=0x870bf80, m=0xb7258178, local_signal_index=1, argv=0xbff6b538) at kernel/qobject.cpp:3547
#20 0xb716eb65 in KWindowSystem::windowAdded (this=0x870bf80, _t1=44040218) at ./kwindowsystem.moc:143
#21 0xb716f300 in KWindowSystemPrivate::addClient (this=0x8730310, w=44040218) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:269
#22 0xb717efbf in NETRootInfo::update (this=0x8730324, dirty_props=0xbff6b6bc) at ../../kdeui/windowmanagement/netwm.cpp:2227
#23 0xb717fb35 in NETRootInfo::event (this=0x8730324, event=0xbff6b83c, properties=0xbff6b744, properties_size=5) at ../../kdeui/windowmanagement/netwm.cpp:2099
#24 0xb717154b in KWindowSystemPrivate::x11Event (this=0x8730310, ev=0xbff6b83c) at ../../kdeui/windowmanagement/kwindowsystem_x11.cpp:172
#25 0xb703796b in publicX11Event (e=0xbff6b83c, this=<optimized out>) at ../../kdeui/kernel/ksystemeventfilter.cpp:43
#26 KSystemEventFilterPrivate::filterEvent (this=0x86fcf40, message=0xbff6b83c) at ../../kdeui/kernel/ksystemeventfilter.cpp:102
#27 0xb7037a06 in _k_eventFilter (message=0xbff6b83c) at ../../kdeui/kernel/ksystemeventfilter.cpp:91
#28 0xb5524a94 in QAbstractEventDispatcher::filterEvent (this=0x85d55c0, message=0xbff6b83c) at kernel/qabstracteventdispatcher.cpp:539
#29 0xb5bd8de1 in x11EventSourceDispatch (s=0x8600e68, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:143
#30 0xb27c9d86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#31 0xb27ca125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#32 0xb27ca201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#33 0xb5565887 in QEventDispatcherGlib::processEvents (this=0x85d55c0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#34 0xb5bd8aaa in QGuiEventDispatcherGlib::processEvents (this=0x85d55c0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0xb553150d in QEventLoop::processEvents (this=0xbff6bb34, flags=...) at kernel/qeventloop.cpp:149
#36 0xb55317a9 in QEventLoop::exec (this=0xbff6bb34, flags=...) at kernel/qeventloop.cpp:204
#37 0xb5536eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#38 0xb5b1da74 in QApplication::exec () at kernel/qapplication.cpp:3820
#39 0xb7724020 in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_plasma-device.so
#40 0x0804851b in ?? ()
#41 0xb75684d3 in __libc_start_main () from /lib/i386-linux-gnu/libc.so.6
#42 0x08048541 in _start ()

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-05-18 02:10:38 UTC

*** This bug has been marked as a duplicate of bug 281035 ***