Bug 319767 - Enable/Disable scripts in KCM does not (un)load the script in running KWin
Summary: Enable/Disable scripts in KCM does not (un)load the script in running KWin
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: scripting (show other bugs)
Version: 4.10.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: 4.10.4
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-13 06:22 UTC by Martin Flöser
Modified: 2013-05-13 06:25 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.10.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Flöser 2013-05-13 06:22:51 UTC
Steps to reproduce:

1. open KCM KWin Scripts
2. activate a script
3. click apply

Expected result:
Script gets loaded in running KWin

Actual result:
Nothing, one needs to restart KWin to see the changes
Comment 1 Martin Flöser 2013-05-13 06:23:51 UTC
Git commit dd5b4bdec8e24359d4715c078e2f442967a3f873 by Martin Gräßlin.
Committed on 08/05/2013 at 10:45.
Pushed by graesslin into branch 'KDE/4.10'.

Reparse configuration before (un)loading scripts

When the scripting KCM triggered a loading of a script it did not work
because the scripting code was operating on an old data set.

Reparsing the configuration before evaluating which scripts to (un)load
solves this problem.

REVIEW: 110357
FIXED-IN: 4.10.4

M  +6    -0    kwin/scripting/scripting.cpp

http://commits.kde.org/kde-workspace/dd5b4bdec8e24359d4715c078e2f442967a3f873
Comment 2 Martin Flöser 2013-05-13 06:25:52 UTC
Git commit 2af4011145a017bf2d5dd868a53d262f58385a52 by Martin Gräßlin.
Committed on 08/05/2013 at 10:45.
Pushed by graesslin into branch 'master'.

Reparse configuration before (un)loading scripts

When the scripting KCM triggered a loading of a script it did not work
because the scripting code was operating on an old data set.

Reparsing the configuration before evaluating which scripts to (un)load
solves this problem.

Cherry-picked from 4.10 branch: dd5b4bdec8e24359d4715c078e2f442967a3f873

M  +6    -0    kwin/scripting/scripting.cpp

http://commits.kde.org/kde-workspace/2af4011145a017bf2d5dd868a53d262f58385a52