Bug 319600 - KMix volume icon is unstale during playback
Summary: KMix volume icon is unstale during playback
Status: RESOLVED FIXED
Alias: None
Product: kmix
Classification: Unclassified
Component: Soundcard specific (show other bugs)
Version: 4.2
Platform: Ubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Christian Esken
URL: https://bugs.kde.org/
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-10 03:37 UTC by Dan Petrescu
Modified: 2013-12-20 10:26 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.11


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dan Petrescu 2013-05-10 03:37:27 UTC
KMix volume icon travels alone from left to right and right to left inside System Tray;


Reproducible: Sometimes

Steps to Reproduce:
1. play sound file, movie, clip, etc.
2. when opening some webpages, including Youtube.com
3.
Actual Results:  
KMix volume icon travels alone from left to right and right to left inside System Tray

Expected Results:  
normal sound, KMix icon should be stable inside System Tray

when the Kmix  icon is walking inside the System Tray area, sound becomes unclear with short interruptions and low intensity popping noise, or is a software bug or is a configuration mistake, or is a hardware problem, and it's bad soundcard Intel C210 HD Sound, and should have better one than Intel C210 HD.
Comment 1 Christian Esken 2013-12-18 13:26:57 UTC
Fixed in recent KDE version. At least since 4.11.
Comment 2 Christian Esken 2013-12-20 10:26:53 UTC
Git commit 0f7a603e1d327f76dbd6a62d08315b1956794d42 by Christian Esken.
Committed on 20/12/2013 at 10:17.
Pushed by esken into branch 'master'.

Configuration menu is now using Tabs to provide a more standard,
  convenient and pleasing layout
 Sound Menu: Play button reflects playback status and shows either
  "Play" or "Pause"
 Bugfixes and Features (CCBUGS, as most bugs are already closed). Hint: Some
bugs might have actually been alreay fixed ibn KDE4.11 or KDE4.12.

Bug ID	Severity	Summary
Related: bug 317926, bug 20, bug 315383, bug 299477, bug 256854, bug 304144, bug 296951, bug 303608, bug 214854
applet
volume control
position.

M  +9    -5    CMakeLists.txt
M  +41   -20   ChangeLog
M  +5    -1    apps/KMixApp.cpp
M  +167  -238  apps/kmix.cpp
M  +8    -13   apps/kmix.h
M  +3    -0    apps/kmixctrl.cpp
M  +3    -0    apps/kmixd.cpp
M  +18   -12   backends/mixer_backend.cpp
M  +1    -0    backends/mixer_backend.h
M  +229  -150  backends/mixer_mpris2.cpp
M  +23   -6    backends/mixer_mpris2.h
M  +8    -2    backends/mixer_oss.cpp
M  +1    -1    backends/mixer_pulse.cpp
M  +9    -9    core/ControlManager.cpp
M  +102  -15   core/GlobalConfig.cpp
M  +105  -47   core/GlobalConfig.h
M  +65   -31   core/kmixdevicemanager.cpp
M  +9    -4    core/mixdevice.cpp
M  +4    -12   core/mixdevice.h
M  +6    -4    core/mixer.cpp
M  +16   -10   core/mixertoolbox.cpp
M  +1    -1    core/version.h
M  +17   -3    core/volume.cpp
M  +9    -8    core/volume.h
M  +19   -6    gui/dialogchoosebackends.cpp
M  +1    -1    gui/dialogchoosebackends.h
M  +9    -2    gui/dialogviewconfiguration.cpp
M  +37   -10   gui/guiprofile.cpp
M  +27   -24   gui/guiprofile.h
M  +93   -118  gui/kmixdockwidget.cpp
M  +3    -4    gui/kmixdockwidget.h
M  +13   -11   gui/kmixerwidget.cpp
M  +296  -91   gui/kmixprefdlg.cpp
M  +82   -32   gui/kmixprefdlg.h
M  +87   -38   gui/mdwslider.cpp
M  +4    -2    gui/mdwslider.h
M  +69   -42   gui/viewbase.cpp
M  +1    -0    gui/viewbase.h
M  +25   -30   gui/viewdockareapopup.cpp
M  +1    -1    gui/viewdockareapopup.h
M  +4    -4    gui/viewsliders.cpp
M  +1    -1    gui/volumesliderextradata.h

http://commits.kde.org/kmix/0f7a603e1d327f76dbd6a62d08315b1956794d42