Bug 319583 - Lilypond syntax highlighting: 'q' (chord shortcut) is not recognized as note
Summary: Lilypond syntax highlighting: 'q' (chord shortcut) is not recognized as note
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Unclassified
Component: syntax (show other bugs)
Version: 3.10.2
Platform: openSUSE RPMs Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-09 18:44 UTC by Joachim Mairböck
Modified: 2013-08-10 19:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.1


Attachments
KatePart LilyPond highlighting: recognize q as a pitch (1.13 KB, patch)
2013-07-17 07:52 UTC, Wilbert Berendsen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joachim Mairböck 2013-05-09 18:44:20 UTC
The q character is not recognized as a note pitch in Lilypond syntax highlighting and therefore durations attached to it. It is used as a shortcut for recurring chords, see http://www.lilypond.org/doc/v2.16/Documentation/notation/single-voice#chord-repetition

Reproducible: Always

Steps to Reproduce:
Enter something like "<a c>2 q4" somewhere in a Lilypond file.
Actual Results:  
the duration of the repeated chord is not colored like the rest of the note durations (blue in my case), it remains black.

Expected Results:  
The duration value of the chord is colored, and 'q' is recognized like a pitch or 'r', 'R' or 's'.
Comment 1 Dominik Haumann 2013-07-16 21:58:43 UTC
Wilbert, can you have a look?
Comment 2 Wilbert Berendsen 2013-07-17 07:52:23 UTC
Created attachment 81152 [details]
KatePart LilyPond highlighting: recognize q as a pitch

This patch adds q to the list of recognized pitch names.
Comment 3 Christoph Feck 2013-08-10 19:36:41 UTC
This looks like a trivial patch, is it okay to get committed?
Comment 4 Dominik Haumann 2013-08-10 19:46:31 UTC
Git commit dc6882c30c7fc7737707bc6da38625e7404b06e0 by Dominik Haumann.
Committed on 10/08/2013 at 19:46.
Pushed by dhaumann into branch 'master'.

fix for Lilypond syntax highlighting

Lilypond syntax highlighting: 'q' (chord shortcut) is not recognized as note
Thanks to Wilbert for the patch!

FIXED-IN: 4.11.1

M  +2    -2    part/syntax/data/lilypond.xml

http://commits.kde.org/kate/dc6882c30c7fc7737707bc6da38625e7404b06e0
Comment 5 Dominik Haumann 2013-08-10 19:47:26 UTC
Git commit e78704d8ce29a9365e9b77d2d268740c5b3ef946 by Dominik Haumann.
Committed on 10/08/2013 at 19:46.
Pushed by dhaumann into branch 'KDE/4.11'.

fix for Lilypond syntax highlighting

Lilypond syntax highlighting: 'q' (chord shortcut) is not recognized as note
Thanks to Wilbert for the patch!

FIXED-IN: 4.11.1

M  +2    -2    part/syntax/data/lilypond.xml

http://commits.kde.org/kate/e78704d8ce29a9365e9b77d2d268740c5b3ef946