Bug 319573 - Facebook Application Authorization not working
Summary: Facebook Application Authorization not working
Status: RESOLVED DUPLICATE of bug 319252
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-WebService-Facebook (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal with 36 votes (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-09 13:56 UTC by Malin Krosby Bruland
Modified: 2018-01-30 21:21 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Malin Krosby Bruland 2013-05-09 13:56:42 UTC
export -> Export to facebook. 

The "Facebook Application Authorization" window appear and the browser opens up and I log into facebook.

Then I get this message in the browser:
Success
SECURITY WARNING: Please treat the URL above as you would your password and do not share it with anyone.

The URL l get looks like this: "https://www.facebook.com/connect/blank.html#_=_" Not looking very unik.

I paste the url into the "Facebook Application Authorization" window and get this message:

Facebook Call Failed: Canceled by user.
Comment 1 Malin Krosby Bruland 2013-05-09 20:36:33 UTC
after investigating furter. The problem is the browser redirect to https://www.facebook.com/connect/blank.html#_=_ makes you have to be very fast to copy the right url.
Comment 2 NQE37003 2013-05-26 03:42:08 UTC
I have the exactly same issue.
The kipi-plugin version is 4.2.5.0 though. I tried to upload images on Facebook through digikam on various linux distributions such as Ubuntu 12.04, Ubuntu 13.04, Kubuntu 13.04, and Fedora 18 (all 64bit), and found they all fail to upload.
Comment 3 Bill Prout 2013-05-26 12:08:08 UTC
I'm having this problem too on Linux Mint 14 KDE.   (digkam 2.8.0)

I do notice that if you mouse over the firefox tab, it appears to show the entire token! but I can't figure out how to copy it.    It is long, but I guess you could hand write it down and manually enter into the digikam input box.
Comment 4 Michał Borsuk 2013-05-26 15:17:23 UTC
Same with me, kipi 2.5.0, Linux
Comment 5 Jenske 2013-06-09 10:37:02 UTC
Have exactly the same problem.
I've tried to (manually!) copy the "url" in the tab of firefox (which reads like "https://www.f...s_in=513...) by hovering over the tab and using a notepad to save the full url, as an answer to the question by Digikam, but that didn't work.
Comment 6 Rick 2013-06-11 11:35:05 UTC
I too have this problem, 
Ubuntu 13.04 
KIPI plugin 4:3.1.0-0ubuntu1
Comment 7 Benjamin M 2013-06-11 22:34:37 UTC
Same here on openSUSE 12.3 with newest stable KDE.
Comment 8 karfiol 2013-06-17 09:22:28 UTC
I solved it on Kubuntu 13.04. 
i enabled the javascript blocking addon (notscripts) in chrome for facebook, and when the token url appeared, it did not revert to https://www.facebook.com/connect/blank.html#_=_ because javascript foe facebook was blocked.
then just copied the tiken url, and voila!
before all that i removed the kipi plugin app in facebook apps
Comment 9 Michał Borsuk 2013-06-17 10:36:11 UTC
Sorry, but this is not "solved", but "hacked" - does not solve the problem. 

Despite, any hints anybody, how this finding may help solve the issue?
Comment 10 Bill Prout 2013-06-28 14:10:03 UTC
I found another hack (this is using firefox):
Go to History >>> Show All History
The first facebook link you find will be the useless https://www.facebook.com/connect/blank.html#_=_
However click the second facebook link and in the location box in the lower part of the window will be the full long link with access token that when copied and pasted into the digikam window =  worked for me!
Comment 11 Christoph Feck 2013-07-21 12:05:14 UTC

*** This bug has been marked as a duplicate of bug 319252 ***