Bug 319543 - Serbian translations tarball contains extragear translations
Summary: Serbian translations tarball contains extragear translations
Status: RESOLVED INTENTIONAL
Alias: None
Product: i18n
Classification: Unclassified
Component: sr (show other bugs)
Version: 4.10
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KDE translation into Serbian
URL: https://bugs.archlinux.org/task/35161
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-08 20:21 UTC by Daimonion
Modified: 2013-05-29 22:08 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daimonion 2013-05-08 20:21:10 UTC
Serbian translations tarball contains some of the 'extragear-' files/folders, leading to packaging issues:
https://bugs.archlinux.org/task/35161
Affected are sr@ijekavian, sr@ijekavianlatin and sr@latin variants.



Reproducible: Always

Steps to Reproduce:
Try to install Arch Linux Serbian KDE translations package
Actual Results:  
Clean install.

Expected Results:  
Install fails because of the file conflicts caused by troublesome tarball.

Found these folders in affected variants:

extragear-base
extragear-games
extragear-multimedia
extragear-network
extragear-sysadmin
Comment 1 Daimonion 2013-05-08 20:22:12 UTC
Just to note, it is about KDE SC 4.10.3
Comment 2 Albert Astals Cid 2013-05-09 22:26:10 UTC
Torgny did you do any experiment regarding l10n packaging for 4.10.3?
Comment 3 Torgny Nyblom 2013-05-10 07:10:00 UTC
Albert: No haven't done the test packaging with release-buddy yet, didn't dare to use it on the live packaging yet.
4.10.3 was done with the old release-tools.
Comment 4 Chusslove Illich 2013-05-10 07:43:58 UTC
What has gone wrong is that this line from sysadmin/release-tools/pack

  cat */pack-with-variants subdirs | sort -u | while read lang; do

somehow failed to match */pack-with-variants subdirs, and hence did not
delete the aforementioned directories.

When I try to make language packs locally with

  cd $KDEGIT/sysadmin/release-tools
  version=4.10.3
  rm -rf sources sources-old dirty clean build
  mkdir -p clean/kde-l10n dirty sources sources-old
  cp -r $KDESVN/tags/KDE/$version/l10n-kde4/scripts clean/kde-l10n
  echo "sr" > clean/kde-l10n/subdirs
  for lang in sr sr@ijekavian sr@ijekavianlatin sr@latin; do \
      cp -r $KDESVN/tags/KDE/$version/l10n-kde4/$lang clean/kde-l10n; \
  done
  ./pack kde-l10n $version
  ls -lh sources/kde-l10n/

then it works fine. (Other than complaining about missing kdoctools, due to
kdelibs not being checked out into clean/ as well, but that is not relevant
to this problem.)
Comment 5 Chusslove Illich 2013-05-10 07:50:46 UTC
Correction: the cat ... while line above is in sysadmin/release-tools/removestuff.
Comment 6 Albert Astals Cid 2013-05-29 22:08:59 UTC
It is true the packages are wrong, we will make sure that 4.10.4 doesn't have this problem, it's a bit late to fix 4.10.3 packages now, sorry for the inconvenience