Bug 319486 - Muon updater 1.3.1 (up to date kubuntu) always enables dpms
Summary: Muon updater 1.3.1 (up to date kubuntu) always enables dpms
Status: RESOLVED DUPLICATE of bug 295164
Alias: None
Product: Discover
Classification: Unclassified
Component: Updates (interactive) (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-07 18:39 UTC by Stu
Modified: 2016-03-02 13:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stu 2013-05-07 18:39:56 UTC
Whenever I apply updates to my up to date kubuntu system (muon updater 1.3.1), all my screen power settings get cleared. For the past year or so, I've always been running a script:

#!/bin/sh

xset q
xset -dpms
xset s noblank 
xset s off

After every update to prevent my monitor from constantly turning off.

It doesn't matter what muon is updating - any completely unrelated system or package will do - it always clears my settings. It's very odd.

Reproducible: Always

Steps to Reproduce:
Latest Kubuntu, default settings:

1. Wait for little "you have updates" icon to appear
2. Apply updates
3. Wait a minute without keyboard or mouse input
4. Screen goes blank
Actual Results:  
Screen goes blank

Expected Results:  
updating unrelated components should not change display settings

While there are underlying issues with KDE not setting DPMS correctly - there are bug reports of all the various ways KDE messes this up - I don't see why muon should be exacerbating the problem.. and it does happen every update, even small ones that don't require a reboot or restart of services or whatever.
Comment 1 Jonathan Thomas 2013-05-07 18:51:56 UTC

*** This bug has been marked as a duplicate of bug 295164 ***