Bug 319458 - davresource with calendar and contactlist with same name not working
Summary: davresource with calendar and contactlist with same name not working
Status: RESOLVED DUPLICATE of bug 284783
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: DAV Resource (show other bugs)
Version: 1.9.1
Platform: Fedora RPMs Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-07 10:02 UTC by christian tacke
Modified: 2013-05-08 19:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description christian tacke 2013-05-07 10:02:40 UTC
I've an ownCloud server running at home and created some calendars and contactlists to seperate private and university stuff and imported them using DAVGroupware. So I have calendars (caldav) and contactlists (carddav) with the same name ("Allgemein", "Uni"). Until KDE SC 4.10.1 this was no problem, but with the last update Akonadi told me it couldn't create resource with id 38. Both calendars and contactlists vanished from kontact. When I removed the contacts from the devresource and created an extra resource for them it works. So I think this is a problem with the names.

Reproducible: Always

Steps to Reproduce:
1. Create DavGroupware with caldav and carddav sources which contain collections with the same name
2. wait till Akonadi complains and see it's not working
3. remove  carddav resource and create new DavGroupware 
4. see it's working now
Comment 1 Grégory Oestreicher 2013-05-08 19:45:23 UTC
Looks a lot like a duplicate of #284783, though I don't understand how it worked before.

*** This bug has been marked as a duplicate of bug 284783 ***