Bug 319422 - Segmentation fault
Summary: Segmentation fault
Status: RESOLVED DUPLICATE of bug 318936
Alias: None
Product: kdelibs
Classification: Frameworks and Libraries
Component: kded (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-06 18:20 UTC by jakub.buryan
Modified: 2013-05-31 10:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (10.34 KB, text/plain)
2013-05-31 10:25 UTC, drdrnewman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jakub.buryan 2013-05-06 18:20:52 UTC
Application: kded4 ($Id$)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-19-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
- What I was doing when the application crashed:  
Nothing. Coputer was not used for some time. Only Mozilla Thunderbird was running.

The crash can be reproduced sometimes.

-- Backtrace:
Application: KDE Daemon (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f8c941797c0 (LWP 2093))]

Thread 5 (Thread 0x7f8c6a428700 (LWP 2113)):
#0  0x00007f8c8f21007f in __pthread_mutex_unlock_usercnt (mutex=0x19c3310, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  0x00007f8c8eb775f1 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8c8eb380ac in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8c8eb386ba in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8c6b52f4f6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#5  0x00007f8c8eb5beb5 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#6  0x00007f8c8f20cf8e in start_thread (arg=0x7f8c6a428700) at pthread_create.c:311
#7  0x00007f8c919fce1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 4 (Thread 0x7f8c69c27700 (LWP 2115)):
#0  0x00007f8c8eb77359 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f8c8eb775e9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8c8eb37366 in g_main_context_acquire () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8c8eb380b4 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8c8eb38304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f8c92e22036 in QEventDispatcherGlib::processEvents (this=0x7f8c440008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f8c92df238f in QEventLoop::processEvents (this=this@entry=0x7f8c69c26d80, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f8c92df2618 in QEventLoop::exec (this=this@entry=0x7f8c69c26d80, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f8c92cf4410 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#9  0x00007f8c7668b6e5 in KCupsConnection::run() () from /usr/lib/libkcupslib.so
#10 0x00007f8c92cf6bec in QThreadPrivate::start (arg=0x191b330) at thread/qthread_unix.cpp:338
#11 0x00007f8c8f20cf8e in start_thread (arg=0x7f8c69c27700) at pthread_create.c:311
#12 0x00007f8c919fce1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 3 (Thread 0x7f8c69426700 (LWP 2116)):
#0  0x00007f8c919f03cd in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x00007f8c8eb381dc in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8c8eb38304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8c92e22036 in QEventDispatcherGlib::processEvents (this=0x7f8c500008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f8c92df238f in QEventLoop::processEvents (this=this@entry=0x7f8c69425dc0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007f8c92df2618 in QEventLoop::exec (this=this@entry=0x7f8c69425dc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007f8c92cf4410 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#7  0x00007f8c92cf6bec in QThreadPrivate::start (arg=0x18d1580) at thread/qthread_unix.cpp:338
#8  0x00007f8c8f20cf8e in start_thread (arg=0x7f8c69426700) at pthread_create.c:311
#9  0x00007f8c919fce1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7f8c68c25700 (LWP 2118)):
#0  0x00007f8c8eb77376 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f8c8eb775e9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f8c8eb381d1 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f8c8eb38304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f8c92e22036 in QEventDispatcherGlib::processEvents (this=0x7f8c480008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007f8c92df238f in QEventLoop::processEvents (this=this@entry=0x7f8c68c24d90, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007f8c92df2618 in QEventLoop::exec (this=this@entry=0x7f8c68c24d90, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007f8c92cf4410 in QThread::exec (this=this@entry=0x1905260) at thread/qthread.cpp:542
#8  0x00007f8c92dd3edf in QInotifyFileSystemWatcherEngine::run (this=0x1905260) at io/qfilesystemwatcher_inotify.cpp:256
#9  0x00007f8c92cf6bec in QThreadPrivate::start (arg=0x1905260) at thread/qthread_unix.cpp:338
#10 0x00007f8c8f20cf8e in start_thread (arg=0x7f8c68c25700) at pthread_create.c:311
#11 0x00007f8c919fce1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7f8c941797c0 (LWP 2093)):
[KCrash Handler]
#6  KScreen::Output::id (this=this@entry=0x0) at /build/buildd/libkscreen-0.0.81/src/output.cpp:104
#7  0x00007f8c78396fbc in Generator::extendToRight (this=this@entry=0x18c5840, outputs=...) at /build/buildd/kscreen-0.0.81/kded/generator.cpp:313
#8  0x00007f8c78398f94 in Generator::idealConfig (this=0x18c5840) at /build/buildd/kscreen-0.0.81/kded/generator.cpp:83
#9  0x00007f8c783914f6 in KScreenDaemon::applyIdealConfig (this=this@entry=0x1836060) at /build/buildd/kscreen-0.0.81/kded/daemon.cpp:110
#10 0x00007f8c7839177d in KScreenDaemon::applyConfig (this=0x1836060) at /build/buildd/kscreen-0.0.81/kded/daemon.cpp:90
#11 0x00007f8c92e080ef in QMetaObject::activate (sender=sender@entry=0x1868ab0, m=m@entry=0x7f8c78387b60 <KScreen::Output::staticMetaObject>, local_signal_index=local_signal_index@entry=4, argv=argv@entry=0x0) at kernel/qobject.cpp:3539
#12 0x00007f8c78181a83 in KScreen::Output::isConnectedChanged (this=this@entry=0x1868ab0) at /build/buildd/libkscreen-0.0.81/obj-x86_64-linux-gnu/src/output.moc:253
#13 0x00007f8c78181aa3 in KScreen::Output::setConnected (this=this@entry=0x1868ab0, connected=<optimized out>) at /build/buildd/libkscreen-0.0.81/src/output.cpp:308
#14 0x00007f8c77d4f4d2 in XRandROutput::updateKScreenOutput (this=this@entry=0x18dc2d0, output=0x1868ab0) at /build/buildd/libkscreen-0.0.81/backends/xrandr/xrandroutput.cpp:265
#15 0x00007f8c77d4a469 in XRandRConfig::updateKScreenConfig (this=0x186a960, config=0x18e9d30) at /build/buildd/libkscreen-0.0.81/backends/xrandr/xrandrconfig.cpp:107
#16 0x00007f8c78180d4c in KScreen::ConfigMonitor::Private::updateConfigs (this=0x18d7fc0) at /build/buildd/libkscreen-0.0.81/src/configmonitor.cpp:46
#17 0x00007f8c78180d9d in KScreen::ConfigMonitor::notifyUpdate (this=0x18d7f10) at /build/buildd/libkscreen-0.0.81/src/configmonitor.cpp:89
#18 0x00007f8c77d47f22 in XRandR::updateOutput (this=<optimized out>, output=82) at /build/buildd/libkscreen-0.0.81/backends/xrandr/xrandr.cpp:116
#19 0x00007f8c92e080ef in QMetaObject::activate (sender=sender@entry=0x18c40f0, m=m@entry=0x7f8c77f53980 <XRandRX11Helper::staticMetaObject>, local_signal_index=local_signal_index@entry=2, argv=argv@entry=0x7fff464d2070) at kernel/qobject.cpp:3539
#20 0x00007f8c77d48f52 in XRandRX11Helper::outputChanged (this=this@entry=0x18c40f0, _t1=82) at /build/buildd/libkscreen-0.0.81/obj-x86_64-linux-gnu/backends/xrandr/xrandrx11helper.moc:120
#21 0x00007f8c77d494d5 in XRandRX11Helper::x11Event (this=0x18c40f0, event=0x7fff464d21c0) at /build/buildd/libkscreen-0.0.81/backends/xrandr/xrandrx11helper.cpp:140
#22 0x00007f8c93b9b97d in publicX11Event (e=0x7fff464d21c0, this=<optimized out>) at ../../kdeui/kernel/ksystemeventfilter.cpp:43
#23 KSystemEventFilterPrivate::filterEvent (this=0x18dd3d0, message=0x7fff464d21c0) at ../../kdeui/kernel/ksystemeventfilter.cpp:102
#24 0x00007f8c92de611e in QAbstractEventDispatcher::filterEvent (this=0x0, message=0x0, message@entry=0x7fff464d21c0) at kernel/qabstracteventdispatcher.cpp:539
#25 0x00007f8c9223f028 in x11EventSourceDispatch (s=0x16baab0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:143
#26 0x00007f8c8eb37f05 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#27 0x00007f8c8eb38248 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#28 0x00007f8c8eb38304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#29 0x00007f8c92e22016 in QEventDispatcherGlib::processEvents (this=0x1621670, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#30 0x00007f8c9223f1ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#31 0x00007f8c92df238f in QEventLoop::processEvents (this=this@entry=0x7fff464d2590, flags=...) at kernel/qeventloop.cpp:149
#32 0x00007f8c92df2618 in QEventLoop::exec (this=this@entry=0x7fff464d2590, flags=...) at kernel/qeventloop.cpp:204
#33 0x00007f8c92df7cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#34 0x00007f8c92197ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#35 0x00007f8c7eb16050 in kdemain (argc=1, argv=0x166bb00) at ../../kded/kded.cpp:924
#36 0x00000000004084ea in launch (argc=argc@entry=1, _name=_name@entry=0x40b167 "kded4", args=args@entry=0x0, cwd=cwd@entry=0x0, envc=envc@entry=0, envs=<optimized out>, envs@entry=0x0, reset_env=reset_env@entry=false, tty=tty@entry=0x0, avoid_loops=avoid_loops@entry=false, startup_id_str=startup_id_str@entry=0x40aff6 "0") at ../../kinit/kinit.cpp:738
#37 0x0000000000405b69 in main (argc=4, argv=<optimized out>, envp=0x7fff464d3210) at ../../kinit/kinit.cpp:1853

Reported using DrKonqi
Comment 1 Christoph Feck 2013-05-06 22:44:25 UTC

*** This bug has been marked as a duplicate of bug 318936 ***
Comment 2 drdrnewman 2013-05-31 10:25:15 UTC
Created attachment 80210 [details]
New crash information added by DrKonqi

kded4 ($Id$) on KDE Platform 4.10.2 using Qt 4.8.4

I was doing nothing. This happens when the computer is running unattended for a long enough time that the monitor is dimmed by power saving software. My screensaver is off.

Not only does kdeinit crash, but so does kded, so I need to manually start it before reporting the bug.

The effect is consistent, over the last week.

-- Backtrace (Reduced):
#6  KScreen::Output::id (this=this@entry=0x0) at /build/buildd/libkscreen-0.0.92/src/output.cpp:104
#7  0x00007f14901e3afc in Generator::extendToRight (this=this@entry=0x229ba10, outputs=...) at /build/buildd/kscreen-0.0.92/kded/generator.cpp:322
#8  0x00007f14901e5c74 in Generator::idealConfig (this=0x229ba10) at /build/buildd/kscreen-0.0.92/kded/generator.cpp:83
#9  0x00007f14901de3f6 in KScreenDaemon::applyIdealConfig (this=this@entry=0x22e56f0) at /build/buildd/kscreen-0.0.92/kded/daemon.cpp:109
#10 0x00007f14901de67d in KScreenDaemon::applyConfig (this=0x22e56f0) at /build/buildd/kscreen-0.0.92/kded/daemon.cpp:89