Bug 319327 - Nepomuk crashed on KDE login
Summary: Nepomuk crashed on KDE login
Status: RESOLVED DUPLICATE of bug 312760
Alias: None
Product: nepomuk
Classification: Miscellaneous
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Nepomuk Bugs Coordination
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-04 17:36 UTC by Otso Helenius
Modified: 2013-05-05 03:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Otso Helenius 2013-05-04 17:36:07 UTC
Application: nepomukservicestub (0.1.0)
KDE Platform Version: 4.10.2
Qt Version: 4.8.4
Operating System: Linux 3.8.0-19-generic x86_64
Distribution: Ubuntu 13.04

-- Information about the crash:
I logged in, Nepomuk immediately crashed. Seems to happen randomly, not consistently.

The crash can be reproduced sometimes.

-- Backtrace:
Application: Nepomuk Service Stub (nepomukservicestub), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
[Current thread is 1 (Thread 0x7fa5c57937c0 (LWP 2156))]

Thread 3 (Thread 0x7fa5acd83700 (LWP 2363)):
#0  syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007fa5c5146694 in _q_futex (timeout=0x0, val=2, op=0, addr=0x7fa5a0002b80, addr2=<optimized out>, val2=<optimized out>) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=this@entry=0x7fa5a0002b80, timeout=timeout@entry=-1) at thread/qmutex_unix.cpp:113
#3  0x00007fa5c51428a5 in QMutex::lockInternal (this=this@entry=0x7fa5a0002b68) at thread/qmutex.cpp:450
#4  0x00007fa5c156cb50 in lockInline (this=0x7fa5a0002b68) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:190
#5  QMutexLocker (m=0x7fa5a0002b68, this=0x7fa5acd82bc0) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:109
#6  QSocketEngineHandler::~QSocketEngineHandler (this=0x7fa5a00013e0, __in_chrg=<optimized out>) at socket/qabstractsocketengine.cpp:75
#7  0x00007fa5c1576e23 in ~QSocks5SocketEngineHandler (this=0x7fa5a00013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#8  QSocks5SocketEngineHandler::~QSocks5SocketEngineHandler (this=0x7fa5a00013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#9  0x00007fa5c1562b35 in ~QGlobalNetworkProxy (this=0x7fa5a0002b00, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:265
#10 globalNetworkProxy () at kernel/qnetworkproxy.cpp:340
#11 0x00007fa5c156377d in QNetworkProxy::QNetworkProxy (this=0x7fa5a00029a8) at kernel/qnetworkproxy.cpp:445
#12 0x00007fa5c157966e in QAbstractSocketPrivate::QAbstractSocketPrivate (this=0x7fa5a0002860) at socket/qabstractsocket.cpp:489
#13 0x00007fa5c157eebe in QTcpSocketPrivate (this=0x7fa5a0002860) at socket/qtcpsocket_p.h:61
#14 QTcpSocket::QTcpSocket (this=0x7fa5a0002808, parent=0x0) at socket/qtcpsocket.cpp:94
#15 0x00007fa5c1587406 in QLocalUnixSocket (this=0x7fa5a0002808) at socket/qlocalsocket_p.h:83
#16 QLocalSocketPrivate::QLocalSocketPrivate (this=0x7fa5a0002720) at socket/qlocalsocket_unix.cpp:72
#17 0x00007fa5c158160e in QLocalSocket::QLocalSocket (this=0x7fa5a00013c0, parent=0x0) at socket/qlocalsocket.cpp:337
#18 0x00007fa5b41e84a8 in ?? () from /usr/lib/libsopranoserver.so.1
#19 0x00007fa5b41e4e87 in ?? () from /usr/lib/libsopranoserver.so.1
#20 0x00007fa5c5147bec in QThreadPrivate::start (arg=0x1b99410) at thread/qthread_unix.cpp:338
#21 0x00007fa5c2abff8e in start_thread (arg=0x7fa5acd83700) at pthread_create.c:311
#22 0x00007fa5c2dcee1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 2 (Thread 0x7fa5a7fff700 (LWP 2364)):
[KCrash Handler]
#6  0x00007fa5c2d0c037 in __GI_raise (sig=sig@entry=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:56
#7  0x00007fa5c2d0f698 in __GI_abort () at abort.c:90
#8  0x00007fa5c30fde8d in __gnu_cxx::__verbose_terminate_handler() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#9  0x00007fa5c30fbf76 in ?? () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#10 0x00007fa5c30fbfa3 in std::terminate() () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#11 0x00007fa5c30fcacf in __cxa_pure_virtual () from /usr/lib/x86_64-linux-gnu/libstdc++.so.6
#12 0x00007fa5c156c802 in QAbstractSocketEngine::createSocketEngine (socketDescripter=socketDescripter@entry=19, parent=parent@entry=0x7fa59c002a08) at socket/qabstractsocketengine.cpp:133
#13 0x00007fa5c1578ee3 in QAbstractSocket::setSocketDescriptor (this=this@entry=0x7fa59c002a08, socketDescriptor=socketDescriptor@entry=19, socketState=socketState@entry=QAbstractSocket::ConnectedState, openMode=...) at socket/qabstractsocket.cpp:1604
#14 0x00007fa5c15882e0 in QLocalSocket::setSocketDescriptor (this=<optimized out>, socketDescriptor=19, socketState=QLocalSocket::ConnectedState, openMode=...) at socket/qlocalsocket_unix.cpp:370
#15 0x00007fa5b41e84c3 in ?? () from /usr/lib/libsopranoserver.so.1
#16 0x00007fa5b41e4e87 in ?? () from /usr/lib/libsopranoserver.so.1
#17 0x00007fa5c5147bec in QThreadPrivate::start (arg=0x1e858e0) at thread/qthread_unix.cpp:338
#18 0x00007fa5c2abff8e in start_thread (arg=0x7fa5a7fff700) at pthread_create.c:311
#19 0x00007fa5c2dcee1d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:113

Thread 1 (Thread 0x7fa5c57937c0 (LWP 2156)):
#0  syscall () at ../sysdeps/unix/sysv/linux/x86_64/syscall.S:38
#1  0x00007fa5c5146694 in _q_futex (timeout=0x0, val=2, op=0, addr=0x7fa5a0002b80, addr2=<optimized out>, val2=<optimized out>) at thread/qmutex_unix.cpp:99
#2  QMutexPrivate::wait (this=this@entry=0x7fa5a0002b80, timeout=timeout@entry=-1) at thread/qmutex_unix.cpp:113
#3  0x00007fa5c51428a5 in QMutex::lockInternal (this=this@entry=0x7fa5a0002b68) at thread/qmutex.cpp:450
#4  0x00007fa5c156cb50 in lockInline (this=0x7fa5a0002b68) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:190
#5  QMutexLocker (m=0x7fa5a0002b68, this=0x7fff4ffc4ad0) at ../../include/QtCore/../../src/corelib/thread/qmutex.h:109
#6  QSocketEngineHandler::~QSocketEngineHandler (this=0x7fa59c0013e0, __in_chrg=<optimized out>) at socket/qabstractsocketengine.cpp:75
#7  0x00007fa5c1576e23 in ~QSocks5SocketEngineHandler (this=0x7fa59c0013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#8  QSocks5SocketEngineHandler::~QSocks5SocketEngineHandler (this=0x7fa59c0013e0, __in_chrg=<optimized out>) at socket/qsocks5socketengine_p.h:288
#9  0x00007fa5c1564aa8 in ~QGlobalNetworkProxy (this=0x7fa59c002d00, __in_chrg=<optimized out>) at kernel/qnetworkproxy.cpp:265
#10 QGlobalStaticDeleter<QGlobalNetworkProxy>::~QGlobalStaticDeleter (this=0x7fa5c17f7458 <globalNetworkProxy()::cleanup>, __in_chrg=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qglobal.h:1950
#11 0x00007fa5c2d11121 in __run_exit_handlers (status=1, listp=0x7fa5c30966a8 <__exit_funcs>, run_list_atexit=run_list_atexit@entry=true) at exit.c:77
#12 0x00007fa5c2d111a5 in __GI_exit (status=<optimized out>) at exit.c:99
#13 0x00007fa5c35d5348 in qt_xio_errhandler () at kernel/qapplication_x11.cpp:782
#14 0x00007fa5c4572888 in KApplication::xioErrhandler (this=0x7fff4ffc4ff0, dpy=0x196b390) at ../../kdeui/kernel/kapplication.cpp:419
#15 0x00007fa5c076a6de in _XIOError () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#16 0x00007fa5c076816d in _XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#17 0x00007fa5c075975b in XEventsQueued () from /usr/lib/x86_64-linux-gnu/libX11.so.6
#18 0x00007fa5c3610bdc in x11EventSourceCheck (s=0x19693c0) at kernel/qguieventdispatcher_glib.cpp:85
#19 0x00007fa5c23e9c69 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fa5c23ea175 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fa5c23ea304 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fa5c5273016 in QEventDispatcherGlib::processEvents (this=0x1963e20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007fa5c36111ae in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007fa5c524338f in QEventLoop::processEvents (this=this@entry=0x7fff4ffc4dd0, flags=...) at kernel/qeventloop.cpp:149
#25 0x00007fa5c5243618 in QEventLoop::exec (this=this@entry=0x7fff4ffc4dd0, flags=...) at kernel/qeventloop.cpp:204
#26 0x00007fa5c5248cf6 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#27 0x00007fa5c3569ffc in QApplication::exec () at kernel/qapplication.cpp:3828
#28 0x0000000000403e70 in main (argc=<optimized out>, argv=0x7fff4ffc5238) at ../../servicestub/main.cpp:180

Possible duplicates by query: bug 317383, bug 315713, bug 313033, bug 312760.

Reported using DrKonqi
Comment 1 Simeon Bird 2013-05-05 03:34:21 UTC

*** This bug has been marked as a duplicate of bug 312760 ***