Bug 319061 - Solarized color scheme is horrible
Summary: Solarized color scheme is horrible
Status: RESOLVED FIXED
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.10.2
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 323013 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-04-29 11:46 UTC by Jonathan Wakely
Modified: 2014-01-10 00:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 2.12


Attachments
Insane color scheme (28.98 KB, image/png)
2013-04-29 11:48 UTC, Jonathan Wakely
Details
Sane colour scheme (29.05 KB, image/png)
2013-04-29 11:49 UTC, Jonathan Wakely
Details
The colorscheme after new commit. (35.75 KB, image/png)
2013-08-12 02:23 UTC, Yichao Zhou
Details
The colorscheme before new commit (34.36 KB, image/png)
2013-08-12 02:23 UTC, Yichao Zhou
Details
The original color scheme. (23.34 KB, image/png)
2013-08-12 02:24 UTC, Yichao Zhou
Details
A slighted modified version of original Solarized before the commit. (669 bytes, application/octet-stream)
2013-08-12 02:26 UTC, Yichao Zhou
Details
effect of new version. (41.83 KB, image/png)
2013-08-12 02:27 UTC, Yichao Zhou
Details
Effect of vim, at a slighed modified colorscheme. (45.98 KB, image/png)
2013-08-12 02:28 UTC, Yichao Zhou
Details
New solarized scheme for this kde colorscheme. (43.45 KB, application/octet-stream)
2013-08-12 02:30 UTC, Yichao Zhou
Details
Fix the problem such that Background Intense != Color 1 Intense. (669 bytes, application/octet-stream)
2013-08-12 02:59 UTC, Yichao Zhou
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Wakely 2013-04-29 11:46:56 UTC
If I choose the Solarized color scheme for Konsole then open vim with the following settings:

  set background=dark
  colorscheme solarized

then I get a bright orange colour as the default background.


Reproducible: Always

Steps to Reproduce:
1. Install Solarized colorscheme for vim, from https://github.com/altercation/vim-colors-solarized
2. Edit konsole profile and choose Solarized theme
3. Start vim
Actual Results:  
Bright orange background making vim unreadable.

Expected Results:  
Dark background, based on Solarized theme.

"Color1" should be similar to the "Background" colour, not something completely contrasting.

The "Solarized Dark" scheme at https://github.com/phiggins/konsole-colors-solarized gets this right and is much better than the scheme bundled with Konsole.
Comment 1 Jonathan Wakely 2013-04-29 11:48:35 UTC
Created attachment 79542 [details]
Insane color scheme

This shows the awful combination of using Konsole's Solarized scheme with Vim's Solarized scheme, which should be a joyous and harmonious combination.
Comment 2 Jonathan Wakely 2013-04-29 11:49:40 UTC
Created attachment 79543 [details]
Sane colour scheme

This shows the expected behaviour, using the "Solarized Dark" scheme from https://github.com/phiggins/konsole-colors-solarized with Vim's Solarized scheme.
Comment 3 Kurt Hindenburg 2013-08-11 21:07:03 UTC
*** Bug 323013 has been marked as a duplicate of this bug. ***
Comment 4 Kurt Hindenburg 2013-08-11 21:27:59 UTC
Git commit e162743179475e439e78e5afcbfe254ec0f3ef3e by Kurt Hindenburg.
Committed on 11/08/2013 at 21:23.
Pushed by hindenburg into branch 'master'.

Correct Solarized Dark colors and add a Light version

I don't recall why the original Solarized had a few colors way off.
These versions appear to match other solarized apps.

https://github.com/phiggins/konsole-colors-solarized
FIXED-IN: 2.12

M  +17   -17   data/color-schemes/Solarized.colorscheme
C  +18   -18   data/color-schemes/SolarizedLight.colorscheme [from: data/color-schemes/Solarized.colorscheme - 075% similarity]

http://commits.kde.org/konsole/e162743179475e439e78e5afcbfe254ec0f3ef3e
Comment 5 Yichao Zhou 2013-08-12 01:37:21 UTC
I even prefer the original one. This looks horrible in almost all terminal application if it isn't optimized for this particular color such as ls, eix because many color are so similar.
Comment 6 Yichao Zhou 2013-08-12 01:40:14 UTC
What should be changed mainly is colorscheme of your vim.
Comment 7 Yichao Zhou 2013-08-12 02:23:04 UTC
Created attachment 81649 [details]
The colorscheme after new commit.
Comment 8 Yichao Zhou 2013-08-12 02:23:30 UTC
Created attachment 81650 [details]
The colorscheme before new commit
Comment 9 Yichao Zhou 2013-08-12 02:24:28 UTC
Created attachment 81651 [details]
The original color scheme.
Comment 10 Yichao Zhou 2013-08-12 02:26:15 UTC
Created attachment 81652 [details]
A slighted modified version of original Solarized before the commit.

This should fix all the problem.
Comment 11 Yichao Zhou 2013-08-12 02:27:15 UTC
Created attachment 81653 [details]
effect of new version.
Comment 12 Yichao Zhou 2013-08-12 02:28:15 UTC
Created attachment 81654 [details]
Effect of vim, at a slighed modified colorscheme.
Comment 13 Yichao Zhou 2013-08-12 02:30:15 UTC
Created attachment 81655 [details]
New solarized scheme for this kde colorscheme.

Conclusion: This version has better compatible with other terminal application while still usable in vim.
Comment 14 Yichao Zhou 2013-08-12 02:59:05 UTC
Created attachment 81656 [details]
Fix the problem such that Background Intense != Color 1 Intense.

Sorry for another post.  But this should fix some problem for people like it.
Comment 15 Jonathan Wakely 2013-08-12 09:45:49 UTC
(In reply to comment #6)
> What should be changed mainly is colorscheme of your vim.

I'm using the official Solarized scheme for VIm, written by the original designer of the Solarized pallete, so I don't think that's where the problem was.
Comment 16 Yichao Zhou 2013-08-12 11:27:30 UTC
(In reply to comment #15)
> (In reply to comment #6)
> > What should be changed mainly is colorscheme of your vim.
> 
> I'm using the official Solarized scheme for VIm, written by the original
> designer of the Solarized pallete, so I don't think that's where the problem
> was.

Do your `ls --color=auto` still has beautiful color?
Comment 17 Andrea Scarpino 2014-01-09 23:16:36 UTC
I confirm Yichao's issues. His Solarized version fixed my colors.
Comment 18 Jonathan Wakely 2014-01-09 23:32:38 UTC
The colorscheme in comment 14 is unusable with the official solarized scheme for Vim, it has grey text on a grey background.

If you want to create a different colour scheme don't pretend it's Solarized and expect me to install a new vim scheme to go with it.  Give your konsole and vim scheme a different name, and leave the Solarized scheme for Konsole alone.

(The correct way to solve the problem with the output of 'ls' is to set different LS_COLORS that are compatible with solarized, not to bastardize the solarized scheme!)
Comment 19 Andrea Scarpino 2014-01-09 23:38:07 UTC
Can you provide a LS_COLORS that is compatible with solarized?
Comment 20 Andrea Scarpino 2014-01-09 23:40:43 UTC
BTW, I'm also a vim user and I fixed the orange (with the previous color theme) by calling 'highlight clear' in ~/.vimrc.
Comment 21 Yichao Zhou 2014-01-09 23:44:00 UTC
Well, after using for some time I found my version still has a little problems in some terminal programs, such as kernel's menuconfig and htop.  These problems are not insolvable:  you will need some low contrast colours in order to make the the cursorline to work, while they cause problems in some other terminal programs.

To make this problem worse, you cannot approximate these colours using xterm 256 colour space.  I just want to say that solarized is really not a terminal-friendly colour scheme...

(In reply to comment #18)
> (The correct way to solve the problem with the output of 'ls' is to set
> different LS_COLORS that are compatible with solarized, not to bastardize
> the solarized scheme!)

Could you give a method to make solarized compatible with htop?  Patch its source code?
Comment 22 Jonathan Wakely 2014-01-09 23:50:57 UTC
(In reply to comment #20)
> BTW, I'm also a vim user and I fixed the orange (with the previous color
> theme) by calling 'highlight clear' in ~/.vimrc.

That works, yes, thanks.

I still say the colour scheme in comment 14 is not Solarized. It might be a great colour scheme, but it's not Solarized, so should not replace Konsole's Solarized scheme.
Comment 23 Andrea Scarpino 2014-01-10 00:07:19 UTC
I fixed ls by using dircolors from https://github.com/seebi/dircolors-solarized