Bug 318849 - panel is above a fullscreen app when it is alone on a desktop
Summary: panel is above a fullscreen app when it is alone on a desktop
Status: RESOLVED DUPLICATE of bug 296076
Alias: None
Product: plasma4
Classification: Plasma
Component: panel (show other bugs)
Version: 4.10.2
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-25 13:06 UTC by Alexander
Modified: 2013-06-07 06:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
Screenshot of bug (33.53 KB, image/png)
2013-04-25 13:08 UTC, Alexander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2013-04-25 13:06:47 UTC
Under some conditions a panel overlaps fullscreen windows (e.g. konsole).

Reproducible: Always

Steps to Reproduce:
1. Switch to a free desktop.
2. Open an app that can be switched to the fullscreen mode (i tried konsole, QtCreator and VLC).
3. Switch to another desktop.
4. Do some stuff with the panel (just one click on it is enough).
5. Switch back to the desktop with the fullscreened app.
Actual Results:  
The panel overlaps the fullscreened app.

Expected Results:  
It shouldn't.
Comment 1 Alexander 2013-04-25 13:08:31 UTC
Created attachment 79439 [details]
Screenshot of bug

The screenshot of the bug.
Comment 2 Igor Poboiko 2013-04-25 13:46:31 UTC
Confirmed.
This actually might be related to KWin since AFAIR it decides which window should be above and which window should be below.
Comment 3 Martin Flöser 2013-06-07 06:45:04 UTC

*** This bug has been marked as a duplicate of bug 296076 ***