Bug 318748 - Better User Feedback on Add to (+)/ Remove from (-) Selection indicator
Summary: Better User Feedback on Add to (+)/ Remove from (-) Selection indicator
Status: RESOLVED DUPLICATE of bug 299328
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 2.2
Platform: Chakra Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2013-04-23 08:17 UTC by Richard Llom
Modified: 2013-04-23 10:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Richard Llom 2013-04-23 08:17:56 UTC
This bug is about the "+" / "-" symbols in the upper left corner of file icons in the dolphin file view, with which you can add / remove files to the current selection.

When you hover with the mouse over a file icon the + / - signs pop-up, but it is not visible which action actually is performed, i.e. is the file opened or will it be added to selection? This is not also a problem when you want to work fast with the mouse, but also to new users (ah so it does make a difference if I have the mouse there or there...).

So I propose to add a visual indication, whether the file is opened or the selection is changed.

The visual indication could take place on the +/- sign, on the file icon or both.
I don't know what would be the best visual indication, but here are some ideas:
On file icon:
- inking in green (add) / red (remove)
- desaturation

On +/- sign:
- display a second +/- sign in big and transparent over the whole file icon
- growing in size
- display a desaturated +/- sign in the first place and color it on mouse hover
Comment 1 Frank Reininghaus 2013-04-23 08:32:50 UTC
Thanks for the report. IMHO, this is not a bug, but a wish.

If you click the +/- sign, there is a visual indication: the selection state of the item changes visibly. Why is that not enough?
Comment 2 Christoph Feck 2013-04-23 10:30:37 UTC

*** This bug has been marked as a duplicate of bug 299328 ***
Comment 3 Frank Reininghaus 2013-04-23 10:53:32 UTC
Thanks Christoph. It seems that I misunderstood the report: I thought that this is about the lack of indication *after* the click has happened. But this makes no sense now that I think about it again.