Bug 318709 - Date & Time in System settings doesn't saves NTP-server address
Summary: Date & Time in System settings doesn't saves NTP-server address
Status: RESOLVED INTENTIONAL
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_clock (show other bugs)
Version: 4.10.2
Platform: Ubuntu Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Paul Campbell
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-22 09:06 UTC by Eugene
Modified: 2015-06-11 00:48 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
error information window (27.84 KB, image/png)
2013-04-22 09:07 UTC, Eugene
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eugene 2013-04-22 09:06:14 UTC
Trying to add other time-server in Date & Time applet results nothing. I'm checking the box near the Time Server and entering new server address, then pushing the Save button. But it doesn't saves anything: server address disappears and check box is clears.
 Also system time is differs to several hours instead of real. I've tried to correct it by hand but it changes after some time again to several hours back. Also error window sometimes appears trying to save time settings. Please, see attachment.
Also after I change my timezone to any other, /etc/timezone file clears - it becomes empty. And only dpkg-reconfigure tzdata command helps and writes to file appropriate timezone. And again if to change any settings in Date & Time and apply it clears /etc/timezone again.

Reproducible: Always

Steps to Reproduce:
1. Open System settings - Date & Time applet.
2. Do any changes. For example: enter new time server or change timezone to any other.
3. Save changes.
Actual Results:  
As a result /etc/timezone file becomes empty and system time changes to incorrect (UTC ?) Also any new entered NTP-server  or any chosen from the list doesn't saves in settings.

Expected Results:  
Any changes must be saved. /etc/timezone file must not become empty, it must contain timezone chosen in Date & Time applet. 

Also this report in Launchpad: https://bugs.launchpad.net/ubuntu/+source/kde-workspace/+bug/1168578
Comment 1 Eugene 2013-04-22 09:07:22 UTC
Created attachment 79372 [details]
error information window
Comment 2 Henri 2013-08-16 17:08:23 UTC
Exactly same happens for me in KDE 4.11. Also default time servers don't work. Time goes always back to UTC which is wrong time for me. Only dpkg-reconfigure tzdata command helps. Using Mint 13.
Comment 3 David Edmundson 2015-04-19 16:17:09 UTC
I've removed this combo box because it doesn't work, and can't when using the timedated backend.

So in a sense this is "fixed" though maybe not in the way you'd like. Sorry.
Comment 4 Eugene 2015-04-20 11:33:56 UTC
In KDE 4.14.2 it works for me - saves NTP-server address.