Bug 318666 - [KKeyServer] Incorrect keyQtToSymX/symXToKeyQt for ěščřž (Czech keyboard) keys
Summary: [KKeyServer] Incorrect keyQtToSymX/symXToKeyQt for ěščřž (Czech keyboard) keys
Status: RESOLVED DUPLICATE of bug 375518
Alias: None
Product: kdelibs
Classification: Unclassified
Component: kdeui (show other bugs)
Version: 4.10.2
Platform: Debian unstable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-21 13:13 UTC by David Rosca
Modified: 2021-03-26 16:07 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Workaround for this issue on Czech keyboard (1.50 KB, patch)
2013-04-21 13:14 UTC, David Rosca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Rosca 2013-04-21 13:13:11 UTC
KKeyServer::keyQtToSymX and KKeyServer::symXToKeyQt are returning bad values for ěščřžý keys written on Czech keyboard (upper characters row, under qwerty row).
This leads to global shortcuts Meta+ě, Meta+š, ... not working at all (it is possible to set them in settings and also they are correctly displayed, but doesn't work).

I have workarounded this issue by creating new key translation array for those affected czech keys.

Reproducible: Always

Steps to Reproduce:
1. Assing Meta+ě to some global action
2. Press Meta+ě
Actual Results:  
Nothing happens

Expected Results:  
Action is activated
Comment 1 David Rosca 2013-04-21 13:14:12 UTC
Created attachment 79068 [details]
Workaround for this issue on Czech keyboard
Comment 2 Andrew Crouthamel 2018-11-10 03:21:49 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Andrew Crouthamel 2018-11-21 04:24:47 UTC
Dear Bug Submitter,

This is a reminder that this bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? This bug will be moved back to REPORTED Status for manual review later, which may take a while. If you are able to, please lend us a hand.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Nate Graham 2021-03-26 16:07:34 UTC

*** This bug has been marked as a duplicate of bug 375518 ***