Bug 318307 - Detects enfuse and enblend versions wrong
Summary: Detects enfuse and enblend versions wrong
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-Generic-ExpoBlending (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-13 19:37 UTC by Philip Johnsson
Modified: 2016-07-11 18:44 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.3.0


Attachments
Exposure Blending Import Wizard - screenshot (84.37 KB, image/png)
2013-06-02 17:58 UTC, Philip Johnsson
Details
Exposure Blending GUI with error message - screenshot. (88.99 KB, image/png)
2013-06-02 18:00 UTC, Philip Johnsson
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philip Johnsson 2013-04-13 19:37:35 UTC
When running the expo blending tool the tool detects enfuse 4.1.1 and align_image_stack 2012.0 blending binaries during detection wizard but when in the expo blending tool preview and want to change settings expo blending tool thinks the system is using enfuse 3.x parameters and when clicking detals about preview error it say:

"Cannot run enfuse:

 enfuse: unknown option "--wExposure=0.99"
Try "enfuse --help" for more information."

Doesn't work with the following enfuse 4.1.1 version data:
enfuse --version
enfuse 4.1.1

Copyright (C) 2004-2012 Andrew Mihal.
License GPLv2+: GNU GPL version 2 or later <http://www.gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Andrew Mihal and others.

But works with enfuse 4.0 that gives this version data:
enfuse --version
enfuse 4.0-753b534c819d

Copyright (C) 2004-2009 Andrew Mihal.
License GPLv2+: GNU GPL version 2 or later <http://www.gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Written by Andrew Mihal and others.


Reproducible: Always

Actual Results:  
Error in preview

Expected Results:  
No errors in preview
Comment 1 Soumajyoti 2013-04-16 22:08:50 UTC
This happens because in Enfuse 4.1 the way to set exposure is through --exposure-weight= WEIGHT
whereas in Enfuse 4.0 it is done through --wExposure=WEIGHT and the current expoblending tool has imported the enfuse 4.0 command line tool .
Comment 2 Philip Johnsson 2013-04-17 00:44:45 UTC
(In reply to comment #1)
> This happens because in Enfuse 4.1 the way to set exposure is through
> --exposure-weight= WEIGHT
> whereas in Enfuse 4.0 it is done through --wExposure=WEIGHT and the current
> expoblending tool has imported the enfuse 4.0 command line tool .

Both Enfuse 4.0, 4.1 and 4.1.1 use --exposure-weight=WEIGHT only Enfuse 3.2 use --wExposure=WEIGHT. 

Most likely the problem is how the code in enfusebinary.cpp parse version data to determine if it should call on enfuseVersion4x fuctions in actionthread.cpp that gives 4.x command line compatibility. If enfuseVersion4x fuction isn't met then it use the older syntax parameters.
Comment 3 Soumajyoti 2013-05-07 14:07:36 UTC
Philip, can you please post a screenshot of the point where the error occurs(along with the error preview).
Comment 4 Lachlan 2013-06-01 11:05:39 UTC
I have this problem, and am running Digikam 3.1.0 with Kipi-plugins 3.1.0 on Gentoo Linux, and have enfuse 4.1.1 .

When I try to blend bracketed images, the dialog works fine until I press "preview".  Then in the place where I should have a preview image I get the error message:

"Failed to process preview of bracketed images"

When I click on the "details" button under this error message it brings up a dialog box saying:

Cannot run enfuse:

 enfuse: unknown option "--wExposure=1"
Try "enfuse --help" for more information.
Comment 5 Michal 2013-06-01 11:19:39 UTC
I have the same problem as Lachlan  for the kipi-plugins 3.2.0, enfuse 4.1.1 . 
System is also Gentoo Linux.
Comment 6 Philip Johnsson 2013-06-02 17:58:55 UTC
Created attachment 80263 [details]
Exposure Blending Import Wizard - screenshot
Comment 7 Philip Johnsson 2013-06-02 18:00:04 UTC
Created attachment 80264 [details]
Exposure Blending GUI with error message - screenshot.
Comment 8 Philip Johnsson 2013-06-02 18:09:18 UTC
Might be interesting to know that the Panorama tool from within Digikam runs the right parameters with enfuse 4.1.1 without any errors.
Comment 9 Soumajyoti 2013-06-02 18:21:08 UTC
Panorama tool has its own source codes and its import wizard is different from that of expoBlending. I am working on this  bug (as a part of GSoC) and I would port the panorama plugin in the expoblending tool as well.
Comment 10 Benjamin Girault 2013-06-02 20:53:34 UTC
Panorama tool source code comes from Expoblending actually, so the import wizard is similar. As for enfuse, the Panorama tool do not use it.

Soumajyoti: In Expoblending, enfuse detection is in manager/enfusebinary.*, and use of enfuse in manager/actionthread.*.
Comment 11 Sebastien 2013-06-23 21:18:19 UTC
I have the same problem on ArchLinux.
Depending options, I have also an other error message :

Impossible d'exécuter /usr/bin/enfuse :

 enfuse: unknown option "--HardMask"
Try "enfuse --help" for more information.
Comment 12 urcindalo 2013-06-27 18:54:48 UTC
I have the exact same problem as Sebastien but in Gentoo. The error is triggered with both kipi-plugins 3.1.0 and 3.2.0 with enblend 4.1.1.
Comment 13 Benjamin Girault 2013-07-29 11:33:06 UTC
Git commit 04b067a799a1606550c6bd8e055688e1ad4675ae by Benjamin Girault.
Committed on 29/07/2013 at 11:30.
Pushed by girault into branch 'master'.

Expoblending: Enfuse version bugfix

M  +13   -2    expoblending/manager/enfusebinary.cpp
M  +8    -1    expoblending/manager/enfusebinary.h
M  +1    -1    expoblending/manager/manager.cpp

http://commits.kde.org/kipi-plugins/04b067a799a1606550c6bd8e055688e1ad4675ae
Comment 14 Soumajyoti 2013-07-29 16:51:39 UTC
Ok... I am looking at the fixes.
Comment 15 Benjamin Girault 2013-08-06 18:48:40 UTC
*** Bug 323241 has been marked as a duplicate of this bug. ***
Comment 16 Benjamin Girault 2013-11-07 09:51:28 UTC
*** Bug 327257 has been marked as a duplicate of this bug. ***