Bug 318240 - Keywords stored in IPTC do not show up in thumbnail preview and are not searchable
Summary: Keywords stored in IPTC do not show up in thumbnail preview and are not searc...
Status: RESOLVED WORKSFORME
Alias: None
Product: digikam
Classification: Unclassified
Component: Bundle-Windows (show other bugs)
Version: 3.0.0
Platform: Microsoft Windows Microsoft Windows
: NOR major (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-12 13:34 UTC by boogiedownde
Modified: 2017-08-12 21:23 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.2.0


Attachments
image v1 with IPTC keyword (3.23 MB, image/jpeg)
2013-04-18 20:28 UTC, damien.courousse
Details
image _v2 modified with digikam's editor (2.08 MB, image/jpeg)
2013-04-18 20:31 UTC, damien.courousse
Details
keyword not shown under picture v1 (265.11 KB, image/png)
2013-04-28 18:20 UTC, damien.courousse
Details

Note You need to log in before you can comment on or make changes to this bug.
Description boogiedownde 2013-04-12 13:34:02 UTC
Of all the keywords which are stored in the IPTC (as shown in the metadata sidebar), only some appear below the thumbnails. If I search for a specific keyword, picturs which have the keyword are not found. Therefore, it seems the database does not contain all the keywords which are stored in the pictures. "Image/re-read metadata from image" usually does not help, neither does "Album/re-read metadata from albums". However, for some other pictures in other albums, it does partly work: When I re-read the metadata from an image, SOME keywords show up, but still not all.
In the settings, I checked "write to sidecar files" and "write to sidecar for read-only images only". "Read from sidecar files" is not checked. However, I already experimented with those settings. 

Reproducible: Always

Steps to Reproduce:
1.open digikam
2.choose an album
3.voilà
Actual Results:  
database useless, pictures not searchable

Expected Results:  
what is written in the IPTC (as shown in the metadata-sidebar!) should be written below the corresponging thumbnail and should be searchable.

Windows XP, approx. 20.000 pictures.
I used to store metadata both in the IPTC and in XMP sidecars, so most pictures should contain both.
After trying to re-build the thumbnails, digikam generally seems to become slow and sometimes unresponsive.
Comment 1 damien.courousse 2013-04-15 21:12:25 UTC
Quite the same problem for me. I would like digikam to display IPTC tags below the thumbnails in the main window, or at least an configuration option to do this.

The standard behavior that I experience, is that the IPTC tags do not appear when opening digikam if they have been added by an external tool (for example: shotwell).
However, if you open the photo in the editor and _save a new version_, the tags now appear in the list of keywords. This is not consistent IMHO.

Steps to reproduce: 

1.open another photo tool and tag a photo (should tag the IPTC.application2.keyword field for example, but _not_ the XMP digikam specific tags) ; make sure the tag is stored (in my case, I store tags in the picture file)
2. open digikam
3. go to the album containing the modified photo
4. the tag does not appear below the thumbnail in the list of keywords.

5. open the photo in digikam editor
6. (modify,) save a new version of the photo
7. the tag now appears below the thumbnail

At the beginning, when I started wandering around on the internet searching for a solution, I thought that digikam would only display the XMP.digikam tags below the thumbnails.

However, if I edit the same photo after step 3. above, and for example save a new copy of the modified picture, the IPTC tags appear below the thumbnails. I assume this is because the IPTC keywords have been copied to XMP fields that are digikam-specific.
Comment 2 damien.courousse 2013-04-15 21:14:41 UTC
Sorry : I forgot one important comment. I use digikam as packaged for Debian.
Here is the list of package versions for digikam and its dependencies : 

Versions of packages digikam depends on:
ii  digikam-data            4:2.6.0-1
ii  kde-runtime             4:4.8.4-2
ii  libc6                   2.13-38
ii  libgcc1                 1:4.7.2-5
ii  libgomp1                4.7.2-5
ii  libgphoto2-2            2.4.14-2
ii  libgphoto2-port0        2.4.14-2
ii  libjasper1              1.900.1-13
ii  libjpeg8                8d-1
ii  libkdcraw20             4:4.8.4-1
ii  libkdecore5             4:4.8.4-4
ii  libkdeui5               4:4.8.4-4
ii  libkdewebkit5           4:4.8.4-4
ii  libkexiv2-10            4:4.8.4-1
ii  libkfile4               4:4.8.4-4
ii  libkhtml5               4:4.8.4-4
ii  libkio5                 4:4.8.4-4
ii  libkipi8                4:4.8.4-1
ii  libknotifyconfig4       4:4.8.4-4
ii  libkparts4              4:4.8.4-4
ii  liblcms1                1.19.dfsg-1.2
ii  liblensfun0             0.2.5-2
ii  liblqr-1-0              0.4.1-2
ii  libmarblewidget13       4:4.8.4-3
ii  libnepomuk4             4:4.8.4-4
ii  libopencv-core2.3       2.3.1-11
ii  libopencv-highgui2.3    2.3.1-11
ii  libopencv-imgproc2.3    2.3.1-11
ii  libopencv-legacy2.3     2.3.1-11
ii  libopencv-objdetect2.3  2.3.1-11
ii  libphonon4              4:4.6.0.0-3
ii  libpng12-0              1.2.49-1
ii  libqjson0               0.7.1-7
ii  libqt4-dbus             4:4.8.2+dfsg-11
ii  libqt4-network          4:4.8.2+dfsg-11
ii  libqt4-qt3support       4:4.8.2+dfsg-11
ii  libqt4-sql              4:4.8.2+dfsg-11
ii  libqt4-sql-sqlite       4:4.8.2+dfsg-11
ii  libqt4-xml              4:4.8.2+dfsg-11
ii  libqtcore4              4:4.8.2+dfsg-11
ii  libqtgui4               4:4.8.2+dfsg-11
ii  libqtwebkit4            2.2.1-5
ii  libsolid4               4:4.8.4-4
ii  libsoprano4             2.7.6+dfsg.1-2
ii  libstdc++6              4.7.2-5
ii  libtiff4                3.9.6-11
ii  libx11-6                2:1.5.0-1
ii  phonon                  4:4.6.0.0-3

Versions of packages digikam recommends:
ii  iceweasel [www-browser]  10.0.12esr-1
ii  kipi-plugins             4:2.6.0-1+b2
ii  konqueror [www-browser]  4:4.8.4-2
ii  mplayerthumbs            4:4.8.4-2
ii  w3m [www-browser]        0.5.3-8

Versions of packages digikam suggests:
pn  digikam-doc  <none>

And many thanks for this nice tool !

best regards,
Damien
Comment 3 boogiedownde 2013-04-17 12:01:02 UTC
For me, it's not just that I would like to have the keywords there because it's nicer. In fact, digiKam is more or less useless, because it treats pictures with certain keywords as if those keywords were not there, i.e. I don't find those pictures any more through filters or search.
And maybe I should add: I didn't use any other program to store the keywords, only digiKam.
Comment 4 Marcel Wiesweg 2013-04-18 19:56:06 UTC
sample file for testing?
Comment 5 damien.courousse 2013-04-18 20:28:23 UTC
Created attachment 79011 [details]
image v1 with IPTC keyword

Here is the file to import in Digikam, which contains the IPTC keyword 'lazygal'.
The keyword is not displayed under the thumbnail in the main view of digikam.
I used the editor (F4) to modify it and to create a new file _v2.
Under the thumbnail of _v2, the keyword 'lazygal' is displayed.
Comment 6 damien.courousse 2013-04-18 20:31:15 UTC
Created attachment 79012 [details]
image _v2 modified with digikam's editor

Here is the file that I got after the edition (I did a simple crop, saved into a new version file).
the metadata keywords look the same, but the keyword 'lazygal' is only displayed for this file.
Comment 7 Marcel Wiesweg 2013-04-28 16:54:57 UTC
I cannot reproduce. Both files contain Xmp.dc.subject, which is sufficient for digikam to import the tag. They contain the IPTC keyword additionally, which will not be read as XMP is given preference.
Comment 8 damien.courousse 2013-04-28 18:19:09 UTC
Hello Marcel,

Thanks for tracking this bug.
What version did you use for testing  ?

I do reproduce here, with Digikam 2.6.0 on Debian.
Please find attached below a screen shot showing the problem : 
* I downloaded from this web page the two pictures IMG_5031_v2.JPG and IMG_5031_v1.JPG in a directory Images/test
* I open Digikam, the two images appear in the directory 'test', but Digikam only displays the keyword 'lazygal' below the image _v2 (see the screenshot).

Maybe this is a configuration problem ?

regards,
Damien
Comment 9 damien.courousse 2013-04-28 18:20:41 UTC
Created attachment 79519 [details]
keyword not shown under picture v1
Comment 10 Andrew Goodbody 2013-04-28 19:11:17 UTC
This is not reproducible with 2.9.0 on Debian.
Comment 11 caulier.gilles 2013-04-28 20:49:22 UTC
This is not reproducible for me too using (as Marcel) current implementation from git/master (next 3.2.0).

Take a care that metadata pass through libkexiv2 KDE interface, which is also managed by digiKam team. This one communicate to Exiv2 shared library which really do the job about metadata.

So, i close this file. Re-open if necessary

Gilles Caulier
Comment 12 boogiedownde 2013-05-02 19:33:03 UTC
It would have been helpful to have some possible explanation as to whether this might be a configuration problem...
Comment 13 damien.courousse 2013-05-02 20:16:41 UTC
Following the reports by Gilles and Andrew, I confirm that I cannot reproduce the problem with digikam v3.1.0 in Debian/experimental.

regards,
Damien