Bug 318217 - use different web browser for open a shortcut on the desktop or an other folder to a web page
Summary: use different web browser for open a shortcut on the desktop or an other fold...
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 2.2
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL: http://support.mozilla.org/en-US/kb/c...
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-11 23:47 UTC by orbayo
Modified: 2013-07-26 13:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description orbayo 2013-04-11 23:47:16 UTC
When you change deafult internet web browser, the shortcuts to a web page you have been created, does not work. I think bug is in dolfin+default applications(kde) because when i install nautilus it works.
I try it on fedora 18, open suse 12.2 and kubuntu 12.04.
In fedora and suse you can open link from desktop it works but it does not work in a folder.

Reproducible: Always

Steps to Reproduce:
1.You have konqueror as default web browser, install an other like firefox or chrome. In OpenSuse you have firefox.
2. Open firefox and create a shortcut to a web page on desktop and an  other folder like documents (press "link here"), just like this:
http://support.mozilla.org/en-US/kb/create-desktop-shortcut-website
3. Change default aplication internet web browser.
4. Try to use the shortcut to a web page. Does not work.

Actual Results:  
Sorry - Dolfin:
Could not find the program 'Firefox.desktop' (or konqueror or chromium if its you default web browser)

Expected Results:  
Open shortcut on the desktop and folder to a web page whit program you want as default.

Fedora KDE 4.10.1 Dolfin 2.2
kubuntu KDE 4.8.5 Dolfin 2.0
OpenSUSE KDE 4.8.5 Dolfin 2.0

On ubuntu UNITY 12.04  it works.. but i like KDE!! Please, fix it, thanks for your work.
Comment 1 Frank Reininghaus 2013-04-22 09:06:39 UTC
Thanks for the bug report, but could you please stop constantly changing the 'Platform'? Thanks.
Comment 2 Emmanuel Pescosta 2013-07-26 13:06:28 UTC
Git commit f14352f141024040b615ab152c1b7b53729db9bd by Emmanuel Pescosta.
Committed on 26/07/2013 at 13:05.
Pushed by emmanuelp into branch 'KDE/4.11'.

Don't open .desktop files with http:/https: urls in Dolphin,
open these urls in the default browser instead.
Related: bug 283475
FIXED-IN: 4.11.0
REVIEW: 111674

M  +5    -2    dolphin/src/views/dolphinview.cpp

http://commits.kde.org/kde-baseapps/f14352f141024040b615ab152c1b7b53729db9bd