Bug 318204 - KMix leaks memory after each stream is played
Summary: KMix leaks memory after each stream is played
Status: RESOLVED DUPLICATE of bug 309464
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: 4.3
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-11 20:40 UTC by Martin Holec
Modified: 2013-04-11 21:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot (573.06 KB, image/png)
2013-04-11 20:42 UTC, Martin Holec
Details
screenshot (475.61 KB, image/png)
2013-04-11 20:45 UTC, Martin Holec
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Holec 2013-04-11 20:40:28 UTC
Application: kmix (4.3)
KDE Platform Version: 4.10.1
Qt Version: 4.8.4
Operating System: Linux 3.8.5-201.fc18.x86_64 x86_64
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed:
Listening to failing Bitcoin on: http://www.listentobitcoin.com/
after approx. 90 minutes KMix has eaten 1.5 GB of RAM and took 100 %
closing Firefox solved CPU consumption issue, but 1.5 GB of RAM allocated

I used SIGABRT to manually trigger traceback.

see screenshot below.

-- Backtrace:
Application: KMix (kmix), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
81	T_PSEUDO (SYSCALL_SYMBOL, SYSCALL_NAME, SYSCALL_NARGS)
[Current thread is 1 (Thread 0x7f984a389880 (LWP 1373))]

Thread 2 (Thread 0x7f9833e41700 (LWP 1463)):
#0  0x0000003a286e99ad in poll () at ../sysdeps/unix/syscall-template.S:81
#1  0x0000003a28247d24 in g_main_context_poll (priority=2147483647, n_fds=1, fds=0x7f982c002bb0, timeout=-1, context=0x7f982c0009a0) at gmain.c:3584
#2  g_main_context_iterate (context=context@entry=0x7f982c0009a0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3285
#3  0x0000003a28247e44 in g_main_context_iteration (context=0x7f982c0009a0, may_block=1) at gmain.c:3351
#4  0x0000003a31fa6126 in QEventDispatcherGlib::processEvents (this=0x7f982c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x0000003a31f7680f in QEventLoop::processEvents (this=this@entry=0x7f9833e40cd0, flags=...) at kernel/qeventloop.cpp:149
#6  0x0000003a31f76a98 in QEventLoop::exec (this=0x7f9833e40cd0, flags=...) at kernel/qeventloop.cpp:204
#7  0x0000003a31e78980 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#8  0x0000003a31f5703f in QInotifyFileSystemWatcherEngine::run (this=0xe8ab40) at io/qfilesystemwatcher_inotify.cpp:256
#9  0x0000003a31e7b95c in QThreadPrivate::start (arg=0xe8ab40) at thread/qthread_unix.cpp:338
#10 0x0000003a28e07d15 in start_thread (arg=0x7f9833e41700) at pthread_create.c:308
#11 0x0000003a286f248d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:114

Thread 1 (Thread 0x7f984a389880 (LWP 1373)):
[KCrash Handler]
#6  0x0000003a286e99ad in poll () at ../sysdeps/unix/syscall-template.S:81
#7  0x0000003a28247d24 in g_main_context_poll (priority=2147483647, n_fds=11, fds=0xb63f40, timeout=-1, context=0xaa3940) at gmain.c:3584
#8  g_main_context_iterate (context=context@entry=0xaa3940, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at gmain.c:3285
#9  0x0000003a28247e44 in g_main_context_iteration (context=0xaa3940, may_block=1) at gmain.c:3351
#10 0x0000003a31fa6106 in QEventDispatcherGlib::processEvents (this=0xa63bb0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#11 0x000000331d46a73e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#12 0x0000003a31f7680f in QEventLoop::processEvents (this=this@entry=0x7fff052acf50, flags=...) at kernel/qeventloop.cpp:149
#13 0x0000003a31f76a98 in QEventLoop::exec (this=0x7fff052acf50, flags=...) at kernel/qeventloop.cpp:204
#14 0x0000003a31f7b888 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#15 0x0000003a45842b9a in kdemain () from /lib64/libkdeinit4_kmix.so
#16 0x0000003a28621a05 in __libc_start_main (main=0x400800 <main>, argc=3, ubp_av=0x7fff052ad198, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fff052ad188) at libc-start.c:225
#17 0x0000000000400831 in _start ()

Possible duplicates by query: bug 317733, bug 317437, bug 317171, bug 317026, bug 316366.

Reported using DrKonqi
Comment 1 Martin Holec 2013-04-11 20:42:39 UTC
Created attachment 78820 [details]
screenshot

Screenshot, Firefox open new stream for each bubble on http://www.listentobitcoin.com/

Approximately after 5 seconds each stream is closed.
Comment 2 Martin Holec 2013-04-11 20:45:30 UTC
Created attachment 78821 [details]
screenshot
Comment 3 Jekyll Wu 2013-04-11 21:44:43 UTC

*** This bug has been marked as a duplicate of bug 309464 ***