Bug 318192 - Bookmark editor crash when draging multiple links to a different folder
Summary: Bookmark editor crash when draging multiple links to a different folder
Status: RESOLVED WORKSFORME
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: 4.10.2
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-11 13:38 UTC by Vincent de Phily
Modified: 2018-11-29 09:44 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (9.90 KB, text/plain)
2013-06-18 09:52 UTC, Vincent de Phily
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent de Phily 2013-04-11 13:38:27 UTC
Application: keditbookmarks (4.10.2)
KDE Platform Version: 4.10.2 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.7.9-hardened x86_64
Distribution: "Gentoo Base System release 2.2"

-- Information about the crash:
- What I was doing when the application crashed:

* Open the bookmark editor
* Create a few folders to play around if necessary
* Select multiple links
* Drag-and-drop them to a different bookmark folder

There is no crash if only a single link is moved, or if multiple links are moved within the same folder.

The crash can be reproduced every time.

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Aborted
Using host libthread_db library "/lib64/libthread_db.so.1".
[KCrash Handler]
#6  0x00007f05b57fdb45 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f05b57fefbb in __GI_abort () at abort.c:91
#8  0x00007f05b3099369 in qt_message_output (msgType=<optimized out>, buf=<optimized out>) at global/qglobal.cpp:2323
#9  0x00007f05b30994a4 in qt_message(QtMsgType, const char *, typedef __va_list_tag __va_list_tag *) (msgType=QtFatalMsg, msg=0x7f05b31d09c2 "ASSERT: \"%s\" in file %s, line %d", ap=0x7fffad151d30) at global/qglobal.cpp:2369
#10 0x00007f05b30995da in qFatal (msg=<optimized out>) at global/qglobal.cpp:2552
#11 0x00007f05b5041735 in KBookmark::address (this=0x7fffad151e90) at /home/portagetmp/portage/kde-base/kdelibs-4.10.2/work/kdelibs-4.10.2/kio/bookmarks/kbookmark.cc:489
#12 0x00007f05b55bb16e in MoveCommand::redo() () from /usr/lib64/libkbookmarkmodel_private.so.4
#13 0x00007f05b40f6558 in QUndoCommand::redo (this=0x7f05b63e5b90) at util/qundostack.cpp:208
#14 0x00007f05b40f74d6 in QUndoStack::push (this=0x7f05b63c1068, cmd=0x7f05b63e5b90) at util/qundostack.cpp:583
#15 0x00007f05b55b9370 in CommandHistory::addCommand(QUndoCommand*) () from /usr/lib64/libkbookmarkmodel_private.so.4
#16 0x00007f05b55be6dd in KBookmarkModel::dropMimeData(QMimeData const*, Qt::DropAction, int, int, QModelIndex const&) () from /usr/lib64/libkbookmarkmodel_private.so.4
#17 0x00007f05b5ba119d in BookmarkFolderViewFilterModel::dropMimeData(QMimeData const*, Qt::DropAction, int, int, QModelIndex const&) () from /usr/lib64/libkdeinit4_keditbookmarks.so
#18 0x00007f05b3fcf3cd in QAbstractItemView::dropEvent (this=0x7f05b66c0090, event=0x7fffad152c20) at itemviews/qabstractitemview.cpp:2006
#19 0x00007f05b3bb2c7f in QWidget::event (this=0x7f05b66c0090, event=0x7fffad152c20) at kernel/qwidget.cpp:8576
#20 0x00007f05b3ecfcff in QFrame::event (this=0x7f05b66c0090, e=0x7fffad152c20) at widgets/qframe.cpp:557
#21 0x00007f05b3fd4603 in QAbstractItemView::viewportEvent (this=0x7f05b66c0090, event=0x7fffad152c20) at itemviews/qabstractitemview.cpp:1644
#22 0x00007f05b400bcf7 in QTreeView::viewportEvent (this=0x7f05b66c0090, event=0x7fffad152c20) at itemviews/qtreeview.cpp:1257
#23 0x00007f05b3172d1a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x7f05b66c15e0, event=0x7fffad152c20) at kernel/qcoreapplication.cpp:1056
#24 0x00007f05b3b64e02 in notify_helper (e=0x7fffad152c20, receiver=0x7f05b66c15e0, this=0x7f05b62034d0) at kernel/qapplication.cpp:4558
#25 QApplicationPrivate::notify_helper (this=0x7f05b62034d0, receiver=0x7f05b66c15e0, e=0x7fffad152c20) at kernel/qapplication.cpp:4534
#26 0x00007f05b3b6b9f4 in QApplication::notify (this=<optimized out>, receiver=<optimized out>, e=0x7fffad152c20) at kernel/qapplication.cpp:4348
#27 0x00007f05b4800040 in KApplication::notify (this=0x7fffad155998, receiver=0x7f05b66c15e0, event=0x7fffad152c20) at /home/portagetmp/portage/kde-base/kdelibs-4.10.2/work/kdelibs-4.10.2/kdeui/kernel/kapplication.cpp:311
#28 0x00007f05b3171cf4 in QCoreApplication::notifyInternal (this=0x7fffad155998, receiver=0x7f05b66c15e0, event=<optimized out>) at kernel/qcoreapplication.cpp:946
#29 0x00007f05b3be4ef3 in QX11Data::xdndHandleDrop (this=<optimized out>, xe=<optimized out>, passive=false) at kernel/qdnd_x11.cpp:1181
#30 0x00007f05b3be7f1b in QDragManager::drop (this=0x7f05b6884000) at kernel/qdnd_x11.cpp:1761
#31 0x00007f05b3be8093 in QDragManager::eventFilter (this=0x7f05b6884000, o=0x7f05b68f7220, e=0x7fffad153398) at kernel/qdnd_x11.cpp:1310
#32 0x00007f05b3172dcb in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x7f05b62034d0, receiver=0x7f05b68f7220, event=0x7fffad153398) at kernel/qcoreapplication.cpp:1037
#33 0x00007f05b3b64d78 in QApplicationPrivate::notify_helper (this=0x7f05b62034d0, receiver=0x7f05b68f7220, e=0x7fffad153398) at kernel/qapplication.cpp:4537
#34 0x00007f05b3b6b2e1 in QApplication::notify (this=<optimized out>, receiver=0x7f05b68f7220, e=0x7fffad153398) at kernel/qapplication.cpp:4105
#35 0x00007f05b4800040 in KApplication::notify (this=0x7fffad155998, receiver=0x7f05b68f7220, event=0x7fffad153398) at /home/portagetmp/portage/kde-base/kdelibs-4.10.2/work/kdelibs-4.10.2/kdeui/kernel/kapplication.cpp:311
#36 0x00007f05b3171cf4 in QCoreApplication::notifyInternal (this=0x7fffad155998, receiver=0x7f05b68f7220, event=<optimized out>) at kernel/qcoreapplication.cpp:946
#37 0x00007f05b3b65afe in QApplicationPrivate::sendMouseEvent (receiver=0x7f05b68f7220, event=0x7fffad153398, alienWidget=0x0, nativeWidget=0x7f05b68f7220, buttonDown=0x7f05b45bd4e8 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3171
#38 0x00007f05b3bdbaa9 in QETWidget::translateMouseEvent (this=0x7f05b68f7220, event=<optimized out>) at kernel/qapplication_x11.cpp:4516
#39 0x00007f05b3bda796 in QApplication::x11ProcessEvent (this=0x7fffad155998, event=0x7fffad153b48) at kernel/qapplication_x11.cpp:3718
#40 0x00007f05b3bfeb38 in x11EventSourceDispatch (s=0x7f05b62003e0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#41 0x00007f05afc22abf in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#42 0x00007f05afc22d6c in ?? () from /usr/lib64/libglib-2.0.so.0
#43 0x00007f05afc22e4f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#44 0x00007f05b319c3ae in QEventDispatcherGlib::processEvents (this=0x7f05b62029f0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#45 0x00007f05b3bfe767 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#46 0x00007f05b317017d in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#47 0x00007f05b31704af in QEventLoop::exec (this=0x7f05b68dbae0, flags=...) at kernel/qeventloop.cpp:204
#48 0x00007f05b3be7b81 in QDragManager::drag (this=0x7f05b6884000, o=<optimized out>) at kernel/qdnd_x11.cpp:2028
#49 0x00007f05b3b76855 in QDrag::exec (this=0x7f05b68c6200, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#50 0x00007f05b3fd8c06 in QAbstractItemView::startDrag (this=0x7f05b66a7520, supportedActions=...) at itemviews/qabstractitemview.cpp:3540
#51 0x00007f05b3fd598e in QAbstractItemView::mouseMoveEvent (this=0x7f05b66a7520, event=<optimized out>) at itemviews/qabstractitemview.cpp:1725
#52 0x00007f05b3bb26ff in QWidget::event (this=0x7f05b66a7520, event=0x7fffad154d08) at kernel/qwidget.cpp:8360
#53 0x00007f05b3ecfcff in QFrame::event (this=0x7f05b66a7520, e=0x7fffad154d08) at widgets/qframe.cpp:557
#54 0x00007f05b3fd4603 in QAbstractItemView::viewportEvent (this=0x7f05b66a7520, event=0x7fffad154d08) at itemviews/qabstractitemview.cpp:1644
#55 0x00007f05b400bcf7 in QTreeView::viewportEvent (this=0x7f05b66a7520, event=0x7fffad154d08) at itemviews/qtreeview.cpp:1257
#56 0x00007f05b3172d1a in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x7f05b66ab360, event=0x7fffad154d08) at kernel/qcoreapplication.cpp:1056
#57 0x00007f05b3b64e02 in notify_helper (e=0x7fffad154d08, receiver=0x7f05b66ab360, this=0x7f05b62034d0) at kernel/qapplication.cpp:4558
#58 QApplicationPrivate::notify_helper (this=0x7f05b62034d0, receiver=0x7f05b66ab360, e=0x7fffad154d08) at kernel/qapplication.cpp:4534
#59 0x00007f05b3b6b2e1 in QApplication::notify (this=<optimized out>, receiver=0x7f05b66ab360, e=0x7fffad154d08) at kernel/qapplication.cpp:4105
#60 0x00007f05b4800040 in KApplication::notify (this=0x7fffad155998, receiver=0x7f05b66ab360, event=0x7fffad154d08) at /home/portagetmp/portage/kde-base/kdelibs-4.10.2/work/kdelibs-4.10.2/kdeui/kernel/kapplication.cpp:311
#61 0x00007f05b3171cf4 in QCoreApplication::notifyInternal (this=0x7fffad155998, receiver=0x7f05b66ab360, event=<optimized out>) at kernel/qcoreapplication.cpp:946
#62 0x00007f05b3b65afe in QApplicationPrivate::sendMouseEvent (receiver=0x7f05b66ab360, event=0x7fffad154d08, alienWidget=0x7f05b66ab360, nativeWidget=0x7f05b66f7d20, buttonDown=0x7f05b45bd4e8 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3171
#63 0x00007f05b3bdbaa9 in QETWidget::translateMouseEvent (this=0x7f05b66f7d20, event=<optimized out>) at kernel/qapplication_x11.cpp:4516
#64 0x00007f05b3bda796 in QApplication::x11ProcessEvent (this=0x7fffad155998, event=0x7fffad1554b8) at kernel/qapplication_x11.cpp:3718
#65 0x00007f05b3bfeb38 in x11EventSourceDispatch (s=0x7f05b62003e0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#66 0x00007f05afc22abf in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#67 0x00007f05afc22d6c in ?? () from /usr/lib64/libglib-2.0.so.0
#68 0x00007f05afc22e4f in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#69 0x00007f05b319c3ae in QEventDispatcherGlib::processEvents (this=0x7f05b62029f0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#70 0x00007f05b3bfe767 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#71 0x00007f05b317017d in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#72 0x00007f05b31704af in QEventLoop::exec (this=0x7fffad1558a0, flags=...) at kernel/qeventloop.cpp:204
#73 0x00007f05b3174b0b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#74 0x00007f05b5b8cb0e in kdemain () from /usr/lib64/libkdeinit4_keditbookmarks.so
#75 0x00007f05b57ea5dd in __libc_start_main (main=0x7f05b5fd78f0 <main>, argc=6, ubp_av=0x7fffad156078, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffad156068) at libc-start.c:234
#76 0x00007f05b5fd794d in _start ()

Reported using DrKonqi
Comment 1 Vincent de Phily 2013-06-18 09:52:05 UTC
Created attachment 80605 [details]
New crash information added by DrKonqi

keditbookmarks (4.10.4) on KDE Platform 4.10.4 using Qt 4.8.4

Still relevant as of SC 4.10.4, which contains a fix for similar-looking bug #287038

Attaching a new trace since it seems to have changed slightly.

-- Backtrace (Reduced):
#6  0x00007fe9a9973b45 in __GI_raise (sig=6) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007fe9a9974fbb in __GI_abort () at abort.c:91
[...]
#11 0x00007fe9a91ba3c4 in KBookmarkManager::findByAddress (this=<optimized out>, address=...) at /home/portagetmp/portage/kde-base/kdelibs-4.10.4/work/kdelibs-4.10.4/kio/bookmarks/kbookmarkmanager.cc:526
#12 0x00007fe9a9731187 in MoveCommand::redo() () from /usr/lib64/libkbookmarkmodel_private.so.4
#13 0x00007fe9a826b558 in QUndoCommand::redo (this=0x7fe9aa378d40) at util/qundostack.cpp:208
Comment 2 Christoph Feck 2013-07-07 18:11:43 UTC
This should be fixed with KDE 4.10.4, otherwise please reopen.

*** This bug has been marked as a duplicate of bug 287038 ***
Comment 3 Vincent de Phily 2013-07-08 16:24:40 UTC
Huh ? I commented over 2 weeks ago that this bug was still valid on 4.10.4 and that bug #287038 looked similar but wasn't a duplicate.

I'm running 4.10.5 and can still reproduce the crash every time. Reopening.
Comment 4 Andrew Crouthamel 2018-10-29 23:58:37 UTC
Dear Bug Submitter,

This bug has been stagnant for a long time. Could you help us out and re-test if the bug is valid in the latest version? I am setting the status to NEEDSINFO pending your response, please change the Status back to REPORTED when you respond.

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bug Janitor Service 2018-11-13 14:42:20 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 6 Bug Janitor Service 2018-11-29 09:44:59 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!