Bug 318036 - KMix causes massive KDE startup delays (30 – 45 seconds)
Summary: KMix causes massive KDE startup delays (30 – 45 seconds)
Status: RESOLVED DUPLICATE of bug 317926
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: 4.3
Platform: Archlinux Packages Linux
: NOR critical with 20 votes (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-08 14:00 UTC by modellbaukeller
Modified: 2013-05-21 22:54 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description modellbaukeller 2013-04-08 14:00:38 UTC
After upgrading to 4.10.2, I got the following problem:

On every startup of the desktop, KDE hangs for about 30 – 45 seconds; after that freezing time span, the login sound is played normally, the panel's systemtray icons show up and everything's pretty normal.

Due to former posts, i discovered that this delay is only caused by KMix, so I purged it for testing purpose, and the delay on startup was gone!

As soon as I reinstalled KMix, the startup-delays reappeared immediatly, that's why I blame KMix for this mess.

Reproducible: Always

Steps to Reproduce:
1. Boot a (fresh) system with KMix 4.3 (KDE 4.10.2) installed.
2.
3.
Actual Results:  
After having finished loading the desktop, KDE hangs/freezes for 30 – 45 seconds.


This problem is a global systemwide one, i.e. the creation of new testusers didn't help at all. 
Also, PulseAudio can't be the problem in this case, because it's simply not installed.
Even a fresh installation on another harddrive space didn't help, the problem is here exactly the same.
Comment 1 modellbaukeller 2013-04-15 13:54:05 UTC
New additional information:

This bug only appears, if you start KDE with a new and totally empty session! However, if you stick in the systemsettings to the default settings (i.e. make KDE replay your former session), KMix is working fine without any delays. Pretty strange behaviour…

Any ideas so far?
Comment 2 Chao Feng 2013-04-16 09:29:18 UTC
Which backend are you using? PulseAudio or ALSA or something else?
Comment 3 modellbaukeller 2013-04-16 11:51:19 UTC
Just using ALSA; i also tried installing PulseAudio additionly, but that didn't change things anyway. 

I tried changing phonon-{gstreamer, vlc} too, but this didn't have any affects on this problem either...

As described above, the delays only take place in KDE with KMix installed AND the setting, that you get on every bootup a fresh session. 

Btw.: Sound under GNOME and XFCE is just running fine, so i guess, this problem is only KDE-/KMix-related.
Comment 4 Christian Esken 2013-05-21 22:54:45 UTC

*** This bug has been marked as a duplicate of bug 317926 ***