Bug 317883 - kontact-4.10.1 crashed after I closed it
Summary: kontact-4.10.1 crashed after I closed it
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: 4.10.1
Platform: Gentoo Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-04-05 13:57 UTC by Christian
Modified: 2017-01-07 21:58 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (11.25 KB, text/plain)
2013-04-05 13:59 UTC, Christian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christian 2013-04-05 13:57:19 UTC
Application: kontact (4.10.1)
KDE Platform Version: 4.10.1
Qt Version: 4.8.4
Operating System: Linux 3.7.10-gentoo x86_64
Distribution: "Gentoo Base System release 2.1"

-- Information about the crash:
- What I was doing when the application crashed:

I closed the application using the menu File>Quit.

Unusual behaviour that I had noticed (and why I quit it): One of my IMAP accounts was not updated. So I clicked on "Update this account and subfolders", but nothing seemed to happen. Then I noticed that there was a progress marker 0% for "Updating Drafts..." (one of the folders on the IMAP account). I clicked X on that, but it didn't stop. Then I chose File>Quit. The window disappeared, but the icon in the taskbar was still there. I also right-clicked the icon. The crash message came a few seconds later, together with a second crash message from plasma desktop. (I'll mark the second report as a duplicate of this one.)

-- Backtrace:
Application: Kontact (kontact), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fed3e8e0780 (LWP 26967))]

Thread 4 (Thread 0x7fed23b40700 (LWP 26981)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fed3afd0b0c in scavengerThread (this=0x7fed3ba1f0e0 <WTF::pageheap_memory>) at wtf/FastMalloc.cpp:2495
#2  WTF::TCMalloc_PageHeap::runScavengerThread (context=0x7fed3ba1f0e0 <WTF::pageheap_memory>) at wtf/FastMalloc.cpp:1618
#3  0x00007fed36548f26 in start_thread (arg=0x7fed23b40700) at pthread_create.c:305
#4  0x00007fed3bd894ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 3 (Thread 0x7fed2323f700 (LWP 26982)):
#0  0x00007fed3bd80513 in *__GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fed35735bf6 in g_main_context_poll (n_fds=1, fds=0x7fed1c0029c0, timeout=-1, context=0x7fed1c0009a0, priority=<optimized out>) at gmain.c:3440
#2  g_main_context_iterate (context=0x7fed1c0009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3141
#3  0x00007fed35735d0c in g_main_context_iteration (context=0x7fed1c0009a0, may_block=1) at gmain.c:3207
#4  0x00007fed3d1df72e in QEventDispatcherGlib::processEvents (this=0x7fed1c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fed3d1aedb2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fed3d1af037 in QEventLoop::exec (this=0x7fed2323ede0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fed3d0abcbf in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#8  0x00007fed3d0aed3c in QThreadPrivate::start (arg=0x140d1d0) at thread/qthread_unix.cpp:338
#9  0x00007fed36548f26 in start_thread (arg=0x7fed2323f700) at pthread_create.c:305
#10 0x00007fed3bd894ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fecce6bb700 (LWP 17797)):
#0  0x00007fed3bd7ba6d in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fed35772ef0 in read (__nbytes=16, __buf=0x7fecce6bac10, __fd=<optimized out>) at /usr/include/bits/unistd.h:45
#2  g_wakeup_acknowledge (wakeup=0xe620d60) at gwakeup.c:212
#3  0x00007fed3573573c in g_main_context_check (context=0x7fecc8006b30, max_priority=2147483647, fds=0x7fecc8003640, n_fds=1) at gmain.c:2980
#4  0x00007fed35735b9c in g_main_context_iterate (context=0x7fecc8006b30, block=1, dispatch=1, self=<optimized out>) at gmain.c:3143
#5  0x00007fed35735d0c in g_main_context_iteration (context=0x7fecc8006b30, may_block=1) at gmain.c:3207
#6  0x00007fed3d1df72e in QEventDispatcherGlib::processEvents (this=0x7fecc800c7e0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007fed3d1aedb2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007fed3d1af037 in QEventLoop::exec (this=0x7fecce6badb0, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007fed3d0abcbf in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#10 0x00007fed3d18e69f in QInotifyFileSystemWatcherEngine::run (this=0xec3cd10) at io/qfilesystemwatcher_inotify.cpp:256
#11 0x00007fed3d0aed3c in QThreadPrivate::start (arg=0xec3cd10) at thread/qthread_unix.cpp:338
#12 0x00007fed36548f26 in start_thread (arg=0x7fecce6bb700) at pthread_create.c:305
#13 0x00007fed3bd894ed in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fed3e8e0780 (LWP 26967)):
[KCrash Handler]
#6  0x00007fecdb46e76f in KMail::KMSystemTray::fillFoldersMenu (this=0x1cf70d0, menu=0x5903f10, model=0x13bf130, parentName=..., parentIndex=...) at /tmp/portage/kde-base/kmail-4.10.1/work/kmail-4.10.1/kmail/kmsystemtray.cpp:293
#7  0x00007fecdb46edca in KMail::KMSystemTray::slotContextMenuAboutToShow (this=0x1cf70d0) at /tmp/portage/kde-base/kmail-4.10.1/work/kmail-4.10.1/kmail/kmsystemtray.cpp:279
#8  0x00007fed3d1c4441 in QMetaObject::activate (sender=0x1d20be0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3539
#9  0x00007fed3d1b7f28 in QMetaMethod::invoke (this=0x7fffac9a95a0, object=0x1d20be0, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#10 0x00007fed3d1ba307 in QMetaObject::invokeMethod (obj=0x1d20be0, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#11 0x00007fed36f940b3 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=0x7fed36fa6ea8 "aboutToShow", obj=0x1d20be0) at /usr/include/qt4/QtCore/qobjectdefs.h:434
#12 DBusMenuExporterDBus::AboutToShow (this=<optimized out>, id=<optimized out>) at /tmp/portage/dev-libs/libdbusmenu-qt-0.9.2/work/libdbusmenu-qt-0.9.2/src/dbusmenuexporterdbus_p.cpp:156
#13 0x00007fed36f96297 in DBusMenuExporterDBus::qt_static_metacall (_o=0x14266f0, _c=<optimized out>, _id=7, _a=0x7fffac9a9910) at /tmp/portage/dev-libs/libdbusmenu-qt-0.9.2/work/libdbusmenu-qt-0.9.2_build/src/dbusmenuexporterdbus_p.moc:89
#14 0x00007fed36f9643f in DBusMenuExporterDBus::qt_metacall (this=0x14266f0, _c=QMetaObject::InvokeMetaMethod, _id=7, _a=0x7fffac9a9910) at /tmp/portage/dev-libs/libdbusmenu-qt-0.9.2/work/libdbusmenu-qt-0.9.2_build/src/dbusmenuexporterdbus_p.moc:129
#15 0x00007fed38db8eb2 in QDBusConnectionPrivate::deliverCall (this=0x1d18980, object=0x14266f0, msg=..., metaTypes=..., slotIdx=11) at qdbusintegrator.cpp:951
#16 0x00007fed38dba005 in QDBusConnectionPrivate::activateCall (this=0x1d18980, object=0x14266f0, flags=4080, msg=...) at qdbusintegrator.cpp:863
#17 0x00007fed38dba5c1 in QDBusConnectionPrivate::activateObject (this=0x1d18980, node=..., msg=..., pathStartPos=<optimized out>) at qdbusintegrator.cpp:1447
#18 0x00007fed38dbaa9b in QDBusActivateObjectEvent::placeMetaCall (this=0xe79c1e0) at qdbusintegrator.cpp:1541
#19 0x00007fed3d1c95fe in QObject::event (this=0x14266f0, e=<optimized out>) at kernel/qobject.cpp:1194
#20 0x00007fed3c52fcd4 in notify_helper (e=0xe79c1e0, receiver=0x14266f0, this=0x13f82f0) at kernel/qapplication.cpp:4562
#21 QApplicationPrivate::notify_helper (this=0x13f82f0, receiver=0x14266f0, e=0xe79c1e0) at kernel/qapplication.cpp:4534
#22 0x00007fed3c534a33 in QApplication::notify (this=0x7fffac9ab580, receiver=0x14266f0, e=0xe79c1e0) at kernel/qapplication.cpp:4423
#23 0x00007fed3dc78428 in KApplication::notify (this=0x7fffac9ab580, receiver=0x14266f0, event=0xe79c1e0) at /tmp/portage/kde-base/kdelibs-4.10.1-r1/work/kdelibs-4.10.1/kdeui/kernel/kapplication.cpp:311
#24 0x00007fed3d1b030b in QCoreApplication::notifyInternal (this=0x7fffac9ab580, receiver=0x14266f0, event=0xe79c1e0) at kernel/qcoreapplication.cpp:946
#25 0x00007fed3d1b3c29 in sendEvent (event=0xe79c1e0, receiver=0x14266f0) at kernel/qcoreapplication.h:231
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x13bf670) at kernel/qcoreapplication.cpp:1570
#27 0x00007fed3d1df2f3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#28 postEventSourceDispatch (s=0x1408510) at kernel/qeventdispatcher_glib.cpp:279
#29 0x00007fed357358fa in g_main_dispatch (context=0x13f9340) at gmain.c:2539
#30 g_main_context_dispatch (context=0x13f9340) at gmain.c:3075
#31 0x00007fed35735c58 in g_main_context_iterate (context=0x13f9340, block=1, dispatch=1, self=<optimized out>) at gmain.c:3146
#32 0x00007fed35735d0c in g_main_context_iteration (context=0x13f9340, may_block=1) at gmain.c:3207
#33 0x00007fed3d1df6d6 in QEventDispatcherGlib::processEvents (this=0x13c0b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#34 0x00007fed3c5d4006 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#35 0x00007fed3d1aedb2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#36 0x00007fed3d1af037 in QEventLoop::exec (this=0x7fffac9aa690, flags=...) at kernel/qeventloop.cpp:204
#37 0x00007fed3d660cce in KJob::exec (this=0x1a21020) at /tmp/portage/kde-base/kdelibs-4.10.1-r1/work/kdelibs-4.10.1/kdecore/jobs/kjob.cpp:210
#38 0x00007fecdb47da38 in KMKernel::cleanup (this=0x1930600) at /tmp/portage/kde-base/kmail-4.10.1/work/kmail-4.10.1/kmail/kmkernel.cpp:1323
#39 0x00007fecdb7c9c52 in KMailPart::~KMailPart (this=0x17f33f0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /tmp/portage/kde-base/kmail-4.10.1/work/kmail-4.10.1/kmail/kmail_part.cpp:119
#40 0x00007fecdb7c9d89 in KMailPart::~KMailPart (this=0x17f33f0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /tmp/portage/kde-base/kmail-4.10.1/work/kmail-4.10.1/kmail/kmail_part.cpp:121
#41 0x00007fed3e0d5b2e in KontactInterface::Plugin::~Plugin (this=0x16e8d40, __vtt_parm=<optimized out>, __in_chrg=<optimized out>) at /tmp/portage/kde-base/kdepimlibs-4.10.1/work/kdepimlibs-4.10.1/kontactinterface/plugin.cpp:91
#42 0x00007fed207e2b3f in KMailPlugin::~KMailPlugin (this=0x16e8d40, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /tmp/portage/kde-base/kmail-4.10.1/work/kmail-4.10.1/kontact/plugins/kmail/kmail_plugin.cpp:159
#43 0x00007fed207e2b89 in KMailPlugin::~KMailPlugin (this=0x16e8d40, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /tmp/portage/kde-base/kmail-4.10.1/work/kmail-4.10.1/kontact/plugins/kmail/kmail_plugin.cpp:163
#44 0x00007fed3e50f00f in Kontact::MainWindow::~MainWindow (this=0x15affa0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /tmp/portage/kde-base/kontact-4.10.1/work/kontact-4.10.1/kontact/src/mainwindow.cpp:294
#45 0x00007fed3e50f1c9 in Kontact::MainWindow::~MainWindow (this=0x15affa0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /tmp/portage/kde-base/kontact-4.10.1/work/kontact-4.10.1/kontact/src/mainwindow.cpp:296
#46 0x00007fed3d1c9638 in QObject::event (this=0x15affa0, e=<optimized out>) at kernel/qobject.cpp:1175
#47 0x00007fed3c5809db in QWidget::event (this=0x15affa0, event=0xe4f6020) at kernel/qwidget.cpp:8845
#48 0x00007fed3c93feb3 in QMainWindow::event (this=0x15affa0, event=0xe4f6020) at widgets/qmainwindow.cpp:1478
#49 0x00007fed3dd791d7 in KXmlGuiWindow::event (this=0x15affa0, ev=0xe4f6020) at /tmp/portage/kde-base/kdelibs-4.10.1-r1/work/kdelibs-4.10.1/kdeui/xmlgui/kxmlguiwindow.cpp:126
#50 0x00007fed3c52fcd4 in notify_helper (e=0xe4f6020, receiver=0x15affa0, this=0x13f82f0) at kernel/qapplication.cpp:4562
#51 QApplicationPrivate::notify_helper (this=0x13f82f0, receiver=0x15affa0, e=0xe4f6020) at kernel/qapplication.cpp:4534
#52 0x00007fed3c534a33 in QApplication::notify (this=0x7fffac9ab580, receiver=0x15affa0, e=0xe4f6020) at kernel/qapplication.cpp:4423
#53 0x00007fed3dc78428 in KApplication::notify (this=0x7fffac9ab580, receiver=0x15affa0, event=0xe4f6020) at /tmp/portage/kde-base/kdelibs-4.10.1-r1/work/kdelibs-4.10.1/kdeui/kernel/kapplication.cpp:311
#54 0x00007fed3d1b030b in QCoreApplication::notifyInternal (this=0x7fffac9ab580, receiver=0x15affa0, event=0xe4f6020) at kernel/qcoreapplication.cpp:946
#55 0x00007fed3d1b3c29 in sendEvent (event=0xe4f6020, receiver=0x15affa0) at kernel/qcoreapplication.h:231
#56 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x13bf670) at kernel/qcoreapplication.cpp:1570
#57 0x00007fed3d1df2f3 in sendPostedEvents () at kernel/qcoreapplication.h:236
#58 postEventSourceDispatch (s=0x1408510) at kernel/qeventdispatcher_glib.cpp:279
#59 0x00007fed357358fa in g_main_dispatch (context=0x13f9340) at gmain.c:2539
#60 g_main_context_dispatch (context=0x13f9340) at gmain.c:3075
#61 0x00007fed35735c58 in g_main_context_iterate (context=0x13f9340, block=1, dispatch=1, self=<optimized out>) at gmain.c:3146
#62 0x00007fed35735d0c in g_main_context_iteration (context=0x13f9340, may_block=1) at gmain.c:3207
#63 0x00007fed3d1df6d6 in QEventDispatcherGlib::processEvents (this=0x13c0b30, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#64 0x00007fed3c5d4006 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#65 0x00007fed3d1aedb2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#66 0x00007fed3d1af037 in QEventLoop::exec (this=0x7fffac9ab510, flags=...) at kernel/qeventloop.cpp:204
#67 0x00007fed3d1b3f25 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#68 0x0000000000403b29 in main (argc=1, argv=0x7fffac9abba8) at /tmp/portage/kde-base/kontact-4.10.1/work/kontact-4.10.1/kontact/src/main.cpp:219

Reported using DrKonqi
Comment 1 Christian 2013-04-05 13:59:51 UTC
Created attachment 78656 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.10.1 using Qt 4.8.4

- What I was doing when the application crashed:

I had right-clicked the symbol of Kontact in the notification area. Nothing happened, probably because Kontact was closing. Actually, it crashed - the report of that is under bug 317883.

-- Backtrace (Reduced):
#6  count (this=<optimized out>) at ../../include/QtCore/../../src/corelib/tools/qvector.h:259
[...]
#8  0x00007f26bd97d1a2 in DBusMenuImporter::slotMenuAboutToShow (this=0x8f73320) at /tmp/portage/dev-libs/libdbusmenu-qt-0.9.2/work/libdbusmenu-qt-0.9.2/src/dbusmenuimporter.cpp:508
[...]
#10 0x00007f26c01e3f28 in QMetaMethod::invoke (this=0x7fff66f6b5a0, object=0x8f46c70, connectionType=Qt::DirectConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
[...]
#12 0x00007f26bd97c231 in invokeMethod (val9=..., val8=..., val7=..., val6=..., val5=..., val4=..., val3=..., val2=..., val1=..., val0=..., member=0x7f26bd98bea8 "aboutToShow", obj=<optimized out>) at /usr/include/qt4/QtCore/qobjectdefs.h:434
#13 DBusMenuImporter::updateMenu (this=<optimized out>) at /tmp/portage/dev-libs/libdbusmenu-qt-0.9.2/work/libdbusmenu-qt-0.9.2/src/dbusmenuimporter.cpp:438
Comment 2 Christian 2013-04-06 18:41:01 UTC
These should be two separate bugs. But DrKonqi put both crash traces into this bug 317883. (See bug 317884 for that behaviour of DrKonqi.)

As I indicated using DrKonqi, the crash that ended up in "Comment 1" may be a duplicate of or related to bug 241562. But the bug in the "Description" is different and I hadn't found any duplicates on that.
Comment 3 Denis Kurz 2016-09-24 19:19:18 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kontact (version 5.0 or later, as part of KDE Applications 15.08 or later), it gets closed in about three months.
Comment 4 Denis Kurz 2017-01-07 21:58:02 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.