Bug 317631 - Cantor crashed when restarting backend
Summary: Cantor crashed when restarting backend
Status: RESOLVED DUPLICATE of bug 328185
Alias: None
Product: cantor
Classification: Applications
Component: general (show other bugs)
Version: 0.3
Platform: Ubuntu Linux
: NOR crash
Target Milestone: ---
Assignee: Alexander Rieder
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-31 09:53 UTC by محمد النقيب
Modified: 2013-11-29 00:44 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description محمد النقيب 2013-03-31 09:53:57 UTC
Application: cantor (0.3)
KDE Platform Version: 4.9.5
Qt Version: 4.8.3
Operating System: Linux 3.5.0-17-generic i686
Distribution: Linux Mint 14 Nadia

-- Information about the crash:
clicked restart backend
used with backend sage 5.8
Linux Mint 14.1

-- Backtrace:
Application: Cantor (cantor), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb4d8b980 (LWP 18026))]

Thread 2 (Thread 0xa729db40 (LWP 18046)):
#0  0xb53dd64a in g_main_context_query () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb53ddc5e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb53de1db in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb2f4aaba in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#4  0xb5403303 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb54b2d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#6  0xb5d98d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb4d8b980 (LWP 18026)):
[KCrash Handler]
#7  0xb60d29c8 in QObject::connect (sender=0x8949340, signal=0xb1775c24 "2statusChanged(Cantor::Expression::Status)", receiver=0x89a0060, method=0xb1775be8 "1currentExpressionChangedStatus(Cantor::Expression::Status)", type=Qt::AutoConnection) at kernel/qobject.cpp:2551
#8  0xb176b1ea in runFirstExpression (this=0x89a0060) at ../../../../src/backends/sage/sagesession.cpp:227
#9  SageSession::runFirstExpression (this=0x89a0060) at ../../../../src/backends/sage/sagesession.cpp:222
#10 0xb60cfed6 in QMetaObject::activate (sender=0x88b40f8, m=0xb7290ca8 <Cantor::Expression::staticMetaObject>, local_signal_index=2, argv=0xbff8da58) at kernel/qobject.cpp:3547
#11 0xb72738d5 in Cantor::Expression::statusChanged (this=this@entry=0x88b40f8, _t1=_t1@entry=Cantor::Expression::Interrupted) at ./expression.moc:124
#12 0xb7273914 in Cantor::Expression::setStatus (this=0x88b40f8, status=Cantor::Expression::Interrupted) at ../../../src/lib/expression.cpp:149
#13 0xb176ce4d in SageExpression::interrupt (this=0x88b40f8) at ../../../../src/backends/sage/sageexpression.cpp:71
#14 0xb176af1d in SageSession::interrupt (this=0x89a0060) at ../../../../src/backends/sage/sagesession.cpp:242
#15 0xb176af9a in SageSession::logout (this=0x89a0060) at ../../../../src/backends/sage/sagesession.cpp:82
#16 0xb10e7dbd in CantorPart::restartBackend (this=0x899a3c0) at ../../src/cantor_part.cpp:373
#17 0xb60cfed6 in QMetaObject::activate (sender=0x8939be8, m=0xb6f993b8 <QAction::staticMetaObject>, local_signal_index=1, argv=0xbff8dc68) at kernel/qobject.cpp:3547
#18 0xb661e10d in QAction::triggered (this=this@entry=0x8939be8, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#19 0xb661e3ac in QAction::activate (this=0x8939be8, event=QAction::Trigger) at kernel/qaction.cpp:1257
#20 0xb6b1a2d0 in trigger (this=<optimized out>) at ../../include/QtGui/../../src/gui/kernel/qaction.h:218
#21 QToolButton::nextCheckState (this=0x89dcb10) at widgets/qtoolbutton.cpp:1144
#22 0xb6a44ee7 in QAbstractButtonPrivate::click (this=this@entry=0x89dcb28) at widgets/qabstractbutton.cpp:530
#23 0xb6a451e6 in QAbstractButton::mouseReleaseEvent (this=0x89dcb10, e=0xbff8e3b4) at widgets/qabstractbutton.cpp:1123
#24 0xb6b1a36d in QToolButton::mouseReleaseEvent (this=0x89dcb10, e=0xbff8e3b4) at widgets/qtoolbutton.cpp:718
#25 0xb667e6df in QWidget::event (this=0x89dcb10, event=0xbff8e3b4) at kernel/qwidget.cpp:8371
#26 0xb6a445a2 in QAbstractButton::event (this=0x89dcb10, e=0xbff8e3b4) at widgets/qabstractbutton.cpp:1082
#27 0xb6b1ba4d in QToolButton::event (this=0x89dcb10, event=0xbff8e3b4) at widgets/qtoolbutton.cpp:1160
#28 0xb662539c in QApplicationPrivate::notify_helper (this=0x865c278, receiver=0x89dcb10, e=0xbff8e3b4) at kernel/qapplication.cpp:4562
#29 0xb662a892 in QApplication::notify (this=0x865c278, receiver=0x89dcb10, e=0xbff8e3b4) at kernel/qapplication.cpp:4105
#30 0xb7535ec1 in KApplication::notify (this=0xbff8ebb4, receiver=0x89dcb10, event=0xbff8e3b4) at ../../kdeui/kernel/kapplication.cpp:311
#31 0xb60b778e in QCoreApplication::notifyInternal (this=0xbff8ebb4, receiver=0x89dcb10, event=0xbff8e3b4) at kernel/qcoreapplication.cpp:915
#32 0xb6626206 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#33 QApplicationPrivate::sendMouseEvent (receiver=0x89dcb10, event=0xbff8e3b4, alienWidget=0x89dcb10, nativeWidget=0x8870148, buttonDown=0xb6fb6d14 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3173
#34 0xb66b1a75 in QETWidget::translateMouseEvent (this=0x8870148, event=0xbff8e7dc) at kernel/qapplication_x11.cpp:4622
#35 0xb66b0705 in QApplication::x11ProcessEvent (this=0xbff8ebb4, event=0xbff8e7dc) at kernel/qapplication_x11.cpp:3737
#36 0xb66dbdc4 in x11EventSourceDispatch (s=0x865bdb0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#37 0xb53dd9e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb53ddd80 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#39 0xb53dde61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#40 0xb60e9981 in QEventDispatcherGlib::processEvents (this=0x8639ef0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#41 0xb66db9aa in QGuiEventDispatcherGlib::processEvents (this=0x8639ef0, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#42 0xb60b626c in QEventLoop::processEvents (this=this@entry=0xbff8ead8, flags=...) at kernel/qeventloop.cpp:149
#43 0xb60b6561 in QEventLoop::exec (this=0xbff8ead8, flags=...) at kernel/qeventloop.cpp:204
#44 0xb60bbcba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#45 0xb6622fc4 in QApplication::exec () at kernel/qapplication.cpp:3823
#46 0x0804febe in main (argc=1, argv=0xbff8ec84) at ../../src/main.cpp:88

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-11-29 00:44:21 UTC

*** This bug has been marked as a duplicate of bug 328185 ***