Bug 317624 - Application: Amarok (amarok), signal: Segmentation fault
Summary: Application: Amarok (amarok), signal: Segmentation fault
Status: RESOLVED DUPLICATE of bug 290706
Alias: None
Product: amarok
Classification: Applications
Component: general (show other bugs)
Version: 2.6.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-31 00:33 UTC by hoyos
Modified: 2013-03-31 13:34 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description hoyos 2013-03-31 00:33:42 UTC
Application: amarok (2.6.0)
KDE Platform Version: 4.9.5
Qt Version: 4.8.3
Operating System: Linux 3.5.0-26-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:

Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe921d2c780 (LWP 6769))]

Thread 2 (Thread 0x7fe90310f700 (LWP 6771)):
#0  0x00007fe91e687303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fe9190e1d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe9190e21e2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe90acf04a6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fe919105645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fe91abd7e9a in start_thread (arg=0x7fe90310f700) at pthread_create.c:308
#6  0x00007fe91e692cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fe921d2c780 (LWP 6769)):
[KCrash Handler]
#6  Phonon::Gstreamer::Pipeline::setState (this=0x0, state=GST_STATE_NULL) at ../../gstreamer/pipeline.cpp:236
#7  0x00007fe8f920e4c4 in Phonon::Gstreamer::MediaObject::requestState (this=this@entry=0x2404fe0, state=Phonon::ErrorState) at ../../gstreamer/mediaobject.cpp:849
#8  0x00007fe8f92121bc in qt_static_metacall (_a=0x25e4760, _id=20, _o=<optimized out>, _c=<optimized out>) at ./moc_mediaobject.cpp:133
#9  Phonon::Gstreamer::MediaObject::qt_static_metacall (_o=0x2404fe0, _c=<optimized out>, _id=20, _a=0x25e4760) at ./moc_mediaobject.cpp:107
#10 0x00007fe91f00443e in QObject::event (this=0x2404fe0, e=<optimized out>) at kernel/qobject.cpp:1195
#11 0x00007fe91f9d0e9c in QApplicationPrivate::notify_helper (this=this@entry=0x2146d50, receiver=receiver@entry=0x2404fe0, e=e@entry=0x25e4440) at kernel/qapplication.cpp:4562
#12 0x00007fe91f9d530a in QApplication::notify (this=0x7fffa30f93a0, receiver=0x2404fe0, e=0x25e4440) at kernel/qapplication.cpp:4423
#13 0x00007fe92173f1f6 in KApplication::notify (this=0x7fffa30f93a0, receiver=0x2404fe0, event=0x25e4440) at ../../kdeui/kernel/kapplication.cpp:311
#14 0x00007fe91efef56e in QCoreApplication::notifyInternal (this=0x7fffa30f93a0, receiver=receiver@entry=0x2404fe0, event=event@entry=0x25e4440) at kernel/qcoreapplication.cpp:915
#15 0x00007fe91eff33f1 in sendEvent (event=0x25e4440, receiver=0x2404fe0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1fd41f0) at kernel/qcoreapplication.cpp:1539
#17 0x00007fe91f01da63 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=0x2146240) at kernel/qeventdispatcher_glib.cpp:279
#19 0x00007fe9190e1ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fe9190e1de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fe9190e1ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fe91f01dbf6 in QEventDispatcherGlib::processEvents (this=0x1fd5ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007fe91fa75c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007fe91eff389f in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:1102
#25 0x00007fe91fa22d1f in QWidgetPrivate::show_helper (this=this@entry=0x25f9bc0) at kernel/qwidget.cpp:7580
#26 0x00007fe91fa22ec2 in QWidget::setVisible (this=0x2145a80, visible=<optimized out>) at kernel/qwidget.cpp:7773
#27 0x00007fe920d34cf8 in App::continueInit() () from /usr/lib/libamaroklib.so.1
#28 0x00007fe920d35867 in App::App() () from /usr/lib/libamaroklib.so.1
#29 0x0000000000408ddd in ?? ()
#30 0x00007fe91e5c076d in __libc_start_main (main=0x402290, argc=1, ubp_av=0x7fffa30f9508, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffa30f94f8) at libc-start.c:226
#31 0x000000000040b805 in _start ()

The crash can be reproduced every time.

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fee7832c780 (LWP 5784))]

Thread 2 (Thread 0x7fee59912700 (LWP 5786)):
#0  0x00007fee74c87303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fee6f6e1d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fee6f6e21e2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fee612f04a6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fee6f705645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fee711d7e9a in start_thread (arg=0x7fee59912700) at pthread_create.c:308
#6  0x00007fee74c92cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fee7832c780 (LWP 5784)):
[KCrash Handler]
#6  Phonon::Gstreamer::Pipeline::setState (this=0x0, state=GST_STATE_NULL) at ../../gstreamer/pipeline.cpp:236
#7  0x00007fee4aecd4c4 in Phonon::Gstreamer::MediaObject::requestState (this=this@entry=0x1167b40, state=Phonon::ErrorState) at ../../gstreamer/mediaobject.cpp:849
#8  0x00007fee4aed11bc in qt_static_metacall (_a=0x1195510, _id=20, _o=<optimized out>, _c=<optimized out>) at ./moc_mediaobject.cpp:133
#9  Phonon::Gstreamer::MediaObject::qt_static_metacall (_o=0x1167b40, _c=<optimized out>, _id=20, _a=0x1195510) at ./moc_mediaobject.cpp:107
#10 0x00007fee7560443e in QObject::event (this=0x1167b40, e=<optimized out>) at kernel/qobject.cpp:1195
#11 0x00007fee75fd0e9c in QApplicationPrivate::notify_helper (this=this@entry=0xea9d50, receiver=receiver@entry=0x1167b40, e=e@entry=0x1348f30) at kernel/qapplication.cpp:4562
#12 0x00007fee75fd530a in QApplication::notify (this=0x7ffff7c82710, receiver=0x1167b40, e=0x1348f30) at kernel/qapplication.cpp:4423
#13 0x00007fee77d3f1f6 in KApplication::notify (this=0x7ffff7c82710, receiver=0x1167b40, event=0x1348f30) at ../../kdeui/kernel/kapplication.cpp:311
#14 0x00007fee755ef56e in QCoreApplication::notifyInternal (this=0x7ffff7c82710, receiver=receiver@entry=0x1167b40, event=event@entry=0x1348f30) at kernel/qcoreapplication.cpp:915
#15 0x00007fee755f33f1 in sendEvent (event=0x1348f30, receiver=0x1167b40) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#16 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0xd371f0) at kernel/qcoreapplication.cpp:1539
#17 0x00007fee7561da63 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#18 postEventSourceDispatch (s=0xea9240) at kernel/qeventdispatcher_glib.cpp:279
#19 0x00007fee6f6e1ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#20 0x00007fee6f6e1de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#21 0x00007fee6f6e1ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#22 0x00007fee7561dbf6 in QEventDispatcherGlib::processEvents (this=0xd38ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#23 0x00007fee76075c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#24 0x00007fee755f389f in QCoreApplication::processEvents (flags=...) at kernel/qcoreapplication.cpp:1102
#25 0x00007fee76022d1f in QWidgetPrivate::show_helper (this=this@entry=0xeb2820) at kernel/qwidget.cpp:7580
#26 0x00007fee76022ec2 in QWidget::setVisible (this=0x135ed90, visible=<optimized out>) at kernel/qwidget.cpp:7773
#27 0x00007fee77334cf8 in App::continueInit() () from /usr/lib/libamaroklib.so.1
#28 0x00007fee77335867 in App::App() () from /usr/lib/libamaroklib.so.1
#29 0x0000000000408ddd in ?? ()
#30 0x00007fee74bc076d in __libc_start_main (main=0x402290, argc=1, ubp_av=0x7ffff7c82878, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff7c82868) at libc-start.c:226
#31 0x000000000040b805 in _start ()

Possible duplicates by query: bug 317377, bug 317157, bug 317098, bug 317026, bug 315869.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2013-03-31 13:34:27 UTC
Known bug in the phonon-backend-gstreamer. As a workaround, you can sue the phonon-backend-vlc instead.

And please, upgrade your Amarok, current is 2.7: http://kubuntu.org/news/amarok-27

*** This bug has been marked as a duplicate of bug 290706 ***