Bug 317195 - cannot display formulas
Summary: cannot display formulas
Status: RESOLVED DOWNSTREAM
Alias: None
Product: calligracommon
Classification: Applications
Component: text-layout (show other bugs)
Version: 2.6.1
Platform: Fedora RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Calligra Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-22 14:49 UTC by Symeon Huang
Modified: 2013-03-23 16:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
stdout text of command fc-cache -fv (2.43 KB, text/plain)
2013-03-23 12:30 UTC, Symeon Huang
Details
stdout text of calligrastage (6.52 KB, text/plain)
2013-03-23 12:31 UTC, Symeon Huang
Details
screenshot of formula with abnormal symbols in calligrastage (3.34 KB, image/jpeg)
2013-03-23 12:32 UTC, Symeon Huang
Details
screenshot of formula with normal symbols in libreoffice-presentation (3.85 KB, image/jpeg)
2013-03-23 12:32 UTC, Symeon Huang
Details
This ODP file is converted from M$ document. (503.06 KB, application/vnd.oasis.opendocument.presentation)
2013-03-23 14:32 UTC, Symeon Huang
Details
Original M$ file. (620.00 KB, application/vnd.ms-powerpoint)
2013-03-23 14:33 UTC, Symeon Huang
Details
calligrastage (2.6.2) output opening sample document (70.90 KB, text/plain)
2013-03-23 14:51 UTC, Rex Dieter
Details
proof it works in calligra (111.79 KB, image/png)
2013-03-23 14:53 UTC, Camilla Boemann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Symeon Huang 2013-03-22 14:49:22 UTC
I installed LibreOffice 4.0 and Calligra 2.6.1 on my Fedora 18 x86_64 machine.
I've copied symbol and its related fonts files into the fonts directory.
While LibreOffice can display normally, Calligra shows only rectangulars instead of symbols.

Reproducible: Always

Steps to Reproduce:
1. Make a MS Office document which contains formulas and symbols by MS Office Suite.
2. Open it by Calligra.
Actual Results:  
All the symbols become rectangular shapes.

Expected Results:  
Display symbols normally just like LibreOffice does.
Comment 1 Camilla Boemann 2013-03-23 10:35:00 UTC
i think you have maybe just forgot to install the font. copying the files over is not enough
I'm pretty sure it works, but please attach a testfile if you still cant get it to work
Comment 2 Camilla Boemann 2013-03-23 10:35:38 UTC
fc-cache -fv

is the command to be run
Comment 3 Symeon Huang 2013-03-23 12:30:37 UTC
Created attachment 78311 [details]
stdout text of command fc-cache -fv
Comment 4 Symeon Huang 2013-03-23 12:31:29 UTC
Created attachment 78312 [details]
stdout text of calligrastage
Comment 5 Symeon Huang 2013-03-23 12:32:09 UTC
Created attachment 78313 [details]
screenshot of formula with abnormal symbols in calligrastage
Comment 6 Symeon Huang 2013-03-23 12:32:40 UTC
Created attachment 78314 [details]
screenshot of formula with normal symbols in libreoffice-presentation
Comment 7 Symeon Huang 2013-03-23 12:34:34 UTC
I've tried the command you mentioned above. Still, not fixed.
I've uploaded the standard output of calligrastage and "fc-cache -fv" command and related screenshots.

P.S. I've installed full suite of calligra.
Comment 8 Camilla Boemann 2013-03-23 12:42:44 UTC
well you have not installed the fonts (the fc-cache output shows it) - it's a local issue - sorry but I don't have time to help you (i'm busy) - try getting help from your distribution or search the internet - it's not calligra specific - most packaging of  libreoffice installs it's own copy of  fonts

calligra (or rather Qt) uses the system

you may have to copy fonts from a windows installation or at least install mscorefonts package
Comment 9 Symeon Huang 2013-03-23 14:32:42 UTC
Created attachment 78316 [details]
This ODP file is converted from M$ document.
Comment 10 Symeon Huang 2013-03-23 14:33:37 UTC
Created attachment 78317 [details]
Original M$ file.
Comment 11 Symeon Huang 2013-03-23 14:36:31 UTC
Sorry to disturb you. But the problem still exists even though I installed almost all symbol fonts.

I've asked folks on IRC #fedora-kde , they suggest me to upload my presentation files so you could reproduce the problem.

Actually, the problem maybe more about formula rather than symbols.
Comment 12 Rex Dieter 2013-03-23 14:51:30 UTC
Created attachment 78318 [details]
calligrastage (2.6.2) output opening sample document

in particular, warnings about
 Unknown Calligra MimeType  "application/vnd.oasis.opendocument.formula"
is likely the concern here
Comment 13 Rex Dieter 2013-03-23 14:52:55 UTC
Fwiw, I have all matter of symbol fonts available and installed too, but seems to me that's not relevant here (imo)
Comment 14 Camilla Boemann 2013-03-23 14:53:57 UTC
Created attachment 78319 [details]
proof it works in calligra

As you can see on this link it works without a problem for me
Comment 15 Camilla Boemann 2013-03-23 15:08:55 UTC
it has all the symptoms of missing font to me

it is an emf or wmf image so there is not even talk about a formula
Comment 16 Rex Dieter 2013-03-23 16:51:40 UTC
OK, I think I found the root cause, and it's related to our fedora packaging. :(

When kformula was removed/disabled from calligra, our packaging scripts omitted kformulapart.desktop , since it apparently referenced a non-existent,
X-KDE-Library=kformulapart

I don't quite fully understand it, but installing that missing file makes things work (again).
Comment 17 Camilla Boemann 2013-03-23 16:54:16 UTC
ok thanks, it sounds really weird indeed