Bug 317094 - Patch to allow build on arm
Summary: Patch to allow build on arm
Status: RESOLVED FIXED
Alias: None
Product: kst
Classification: Unclassified
Component: general (show other bugs)
Version: 2.0.7
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: kst
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-20 17:49 UTC by Gwyn Ciesla
Modified: 2013-08-13 12:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Patch for ARM (9.65 KB, patch)
2013-03-20 17:49 UTC, Gwyn Ciesla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gwyn Ciesla 2013-03-20 17:49:02 UTC
This is the patch Rex Dieter crafted to allow building on ARM.

Reproducible: Always
Comment 1 Gwyn Ciesla 2013-03-20 17:49:53 UTC
Created attachment 78247 [details]
Patch for ARM
Comment 2 Gwyn Ciesla 2013-08-12 18:48:45 UTC
This patch is now out of date for 2.0.7.

Is there a long-term solution to this issue?

http://doc.qt.digia.com/4.6/qtglobal.html#qreal-typedef
http://kojipkgs.fedoraproject.org//work/tasks/8508/5688508/build.log
Comment 3 Rex Dieter 2013-08-12 19:13:50 UTC
Looks like the code is hosted @ http://websvn.kde.org/branches/work/kst/portto4/kst/ 

I can rebase the patch and submit to reviewboard.kde.org this time.  (and lacking feedback there, just commit it)
Comment 4 Rex Dieter 2013-08-12 19:44:08 UTC
Also, looks like 2.0.7 includes at least some of the qreal vs float fixes already, resubmitting build to koji to get a fresh build.log
Comment 5 Rex Dieter 2013-08-13 12:57:33 UTC
http://websvn.kde.org/?view=revision&revision=1362914

Dunno why the svn hooks didn't automatically close this, so...