Bug 317052 - ppa:kubuntu-ppa/backports : QXIMInputContext on QGraphicsView locks in _xcb_conn_wait
Summary: ppa:kubuntu-ppa/backports : QXIMInputContext on QGraphicsView locks in _xcb_c...
Alias: None
Product: kwin
Classification: Plasma
Component: aurorae (show other bugs)
Version: 4.10.1
Platform: Ubuntu Linux
: NOR normal
Target Milestone: ---
Assignee: KWin default assignee
Depends on:
Reported: 2013-03-19 23:57 UTC by V字龍(Vdragon)
Modified: 2013-04-30 21:30 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:

Screenshot when hang... (26.42 KB, image/jpeg)
2013-03-20 00:00 UTC, V字龍(Vdragon)
Another hang screenshot (47.26 KB, image/jpeg)
2013-03-20 00:02 UTC, V字龍(Vdragon)
Backtrace01 (107.75 KB, image/jpeg)
2013-03-20 00:03 UTC, V字龍(Vdragon)
Backtrace02 (123.76 KB, image/jpeg)
2013-03-20 00:03 UTC, V字龍(Vdragon)
Backtrace03 (113.07 KB, image/jpeg)
2013-03-20 00:04 UTC, V字龍(Vdragon)
Backtrace04 (112.74 KB, image/jpeg)
2013-03-20 00:04 UTC, V字龍(Vdragon)
Another backtrace on my real machine. (1.01 MB, image/jpeg)
2013-03-20 01:05 UTC, V字龍(Vdragon)
Final backtrace (917.62 KB, image/jpeg)
2013-03-20 01:18 UTC, V字龍(Vdragon)
kwin gdb backtrace (34.66 KB, text/plain)
2013-03-20 01:45 UTC, V字龍(Vdragon)

Note You need to log in before you can comment on or make changes to this bug.
Description V字龍(Vdragon) 2013-03-19 23:57:13 UTC
Login to KDE and tried to execute any GUI application then it freezes.

Reproducible: Always

Steps to Reproduce:
1. Login to KDE
2. Launch any application (e.g. Dolphin)
3. Wait 5 sec.
Actual Results:  
* The whole screen hangs, only mouse cursur is movable.
* It still able to switch to diffrent terminals
* kwin --replace and any GUI application will hang if executed after this hang until the original kwin is killed

Expected Results:  
* application launches normally

System: Ubuntu 12.10 x86 32bit with ppa:kubuntu-ppa/backports enabled

1. switch to TTY terminal and login
2. send SIGKILL signal to terminate kwin (SIGTERM is not sufficient)
    pkill --signal SIGKILL kwin
3. run another terminal emulator in TTY terminal
    env DISPLAY=:0 konsole
4. Switch back to X terminal, execute following command in the Konsole window
     kwin &
5. redo 1~4 if the problem persists.

Other details
* It seems that this issue is not related to graphic hardware...
* ppa-purge the kubuntu-ppa/backports to downgrade everything back to quantal-updates seems to solve this issue too.
Comment 1 V字龍(Vdragon) 2013-03-20 00:00:51 UTC
Created attachment 78222 [details]
Screenshot when hang...
Comment 2 V字龍(Vdragon) 2013-03-20 00:02:57 UTC
Created attachment 78223 [details]
Another hang screenshot
Comment 3 V字龍(Vdragon) 2013-03-20 00:03:28 UTC
Created attachment 78224 [details]
Comment 4 V字龍(Vdragon) 2013-03-20 00:03:59 UTC
Created attachment 78225 [details]
Comment 5 V字龍(Vdragon) 2013-03-20 00:04:35 UTC
Created attachment 78226 [details]
Comment 6 V字龍(Vdragon) 2013-03-20 00:04:57 UTC
Created attachment 78227 [details]
Comment 7 Thomas Lübking 2013-03-20 00:32:57 UTC
kwriteconfig --file kwinrc --group Style --key PluginLib kwin3_oxygen

The backtrace ends in XIM, accessed by the (Graphicsview) from the aurorae decoration, so please check (see above) whether this happens with the oxygen decoration as well (and where the backtrace ends)

The bug might be in Qt or XIM in this case.
Comment 8 V字龍(Vdragon) 2013-03-20 01:05:53 UTC
Created attachment 78228 [details]
Another backtrace on my real machine.
Comment 9 Thomas Lübking 2013-03-20 01:12:58 UTC
Same backtrace, please try the oxygen decoration.

You can btw pipe the gdb output into a file using tee:

gdb 2>&1 | tee gdb.log
attach <pid>
detach quit

less gdb.log
Comment 10 V字龍(Vdragon) 2013-03-20 01:18:35 UTC
Created attachment 78229 [details]
Final backtrace
Comment 11 V字龍(Vdragon) 2013-03-20 01:19:34 UTC
I can't reproduce the issue with the oxygen decoration.
Comment 12 V字龍(Vdragon) 2013-03-20 01:24:35 UTC
Anyway thanks for the debugging tips ;)
I quite prefer Plastik decoration since its more like Windows UI.
Comment 13 Thomas Lübking 2013-03-20 01:28:56 UTC
If you can, please dump an ASCII backtrace as suggested above for further investigations. Copytyping symbols from a screenshot is less than ideal ;-)
Comment 14 V字龍(Vdragon) 2013-03-20 01:45:04 UTC
Created attachment 78230 [details]
kwin gdb backtrace

Here you are ;)
Comment 15 Thomas Lübking 2013-03-20 02:03:37 UTC
Were other aurorae decorations affected in 4.9?

(It smells like a conflict between XIM and QGraphicsView or maybe just a XIM bug or a package mismatch due to the ppa)

See same bug for Emacs on RedHat (from 2008)

(You could try one of the plenty dekorator themes imitating windows)
Comment 16 V字龍(Vdragon) 2013-03-20 12:22:08 UTC
(In reply to comment #15)
> Were other aurorae decorations affected in 4.9?
How can I tell the decoration uses aurorae or not?

I currently tried another aurorae-like decoration and it also triggers the issue...
Comment 17 Thomas Lübking 2013-03-20 12:47:52 UTC
If you got an aurorae theme from kde-look (GHNS, "get more decorations") - ie. NOT a "smaragd" or "dekorator" theme nor QtCurve, Bespin or Skulpture.

I don't think there's atm another stock aurorae decoration than plastik (since 4.10, was not aurorae in 4.9)
Comment 18 V字龍(Vdragon) 2013-04-30 21:30:08 UTC
I decided to close this bug because I can't reproduce it lately, It may probably be a random issue from Ubuntu/Kubuntu.