Bug 317029 - amarok crashed on shutdown computer
Summary: amarok crashed on shutdown computer
Status: RESOLVED DUPLICATE of bug 285951
Alias: None
Product: amarok
Classification: Unclassified
Component: general (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-19 14:26 UTC by Lewkow Brigitte
Modified: 2013-03-19 17:20 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lewkow Brigitte 2013-03-19 14:26:47 UTC
Application: amarok (2.5.0)
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-39-generic x86_64
Distribution: Ubuntu 12.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I wanted to shutdown the computer. That's made a while. i don't know if it is relevant but i was using aqualung for listening some tracks!

-- Backtrace:
Application: Amarok (amarok), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fb4a61047c0 (LWP 2782))]

Thread 11 (Thread 0x7fb4853a4700 (LWP 2798)):
#0  0x00007fb4a29f3313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb49ae4e35f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#2  0x00007fb49ae3f76c in pa_mainloop_poll () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#3  0x00007fb49ae3fdd9 in pa_mainloop_iterate () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#4  0x00007fb49ae3fe90 in pa_mainloop_run () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#5  0x00007fb49ae4e30f in ?? () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#6  0x00007fb496293d18 in ?? () from /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
#7  0x00007fb49f10ce9a in start_thread (arg=0x7fb4853a4700) at pthread_create.c:308
#8  0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#9  0x0000000000000000 in ?? ()

Thread 10 (Thread 0x7fb477dbc700 (LWP 2826)):
#0  0x00007fb49d5ee828 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fb49d5eef5b in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb49d5ef164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb4a338a426 in QEventDispatcherGlib::processEvents (this=0x7fb470000900, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fb4a3359c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb4a3359ed7 in QEventLoop::exec (this=0x7fb477dbbd90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fb4a3258fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fb4a33399ff in QInotifyFileSystemWatcherEngine::run (this=0x19343c0) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb4a325bfcb in QThreadPrivate::start (arg=0x19343c0) at thread/qthread_unix.cpp:298
#9  0x00007fb49f10ce9a in start_thread (arg=0x7fb477dbc700) at pthread_create.c:308
#10 0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 9 (Thread 0x7fb475b4e700 (LWP 2844)):
#0  0x00007fb49d62a33e in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fb49d62a5c9 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb49d5ef02a in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb49d5ef164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fb4a338a426 in QEventDispatcherGlib::processEvents (this=0x7fb4680008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#5  0x00007fb4a3359c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#6  0x00007fb4a3359ed7 in QEventLoop::exec (this=0x7fb475b4ddc0, flags=...) at kernel/qeventloop.cpp:204
#7  0x00007fb4a3258fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#8  0x00007fb4a325bfcb in QThreadPrivate::start (arg=0x1af93c0) at thread/qthread_unix.cpp:298
#9  0x00007fb49f10ce9a in start_thread (arg=0x7fb475b4e700) at pthread_create.c:308
#10 0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 8 (Thread 0x7fb46ffff700 (LWP 2848)):
#0  0x00007fb4a29f3313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb49d5ef036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb49d5ef164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb4a338a426 in QEventDispatcherGlib::processEvents (this=0x7fb4640008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fb4a3359c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb4a3359ed7 in QEventLoop::exec (this=0x7fb46fffedc0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fb4a3258fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fb4a325bfcb in QThreadPrivate::start (arg=0x1b2fdc0) at thread/qthread_unix.cpp:298
#8  0x00007fb49f10ce9a in start_thread (arg=0x7fb46ffff700) at pthread_create.c:308
#9  0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 7 (Thread 0x7fb46effd700 (LWP 2855)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb4a325c4db in wait (time=18446744073709551615, this=0x1b9dbb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1b9dd10, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb4a06a20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1b9d090, th=0x1b9e130) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fb4a06a49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1b9dde0, th=0x1b9e130) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fb4a06a384f in ThreadWeaver::ThreadRunHelper::run (this=0x7fb46effcde0, parent=0x1b9d090, th=0x1b9e130) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fb4a06a38db in ThreadWeaver::Thread::run (this=0x1b9e130) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fb4a325bfcb in QThreadPrivate::start (arg=0x1b9e130) at thread/qthread_unix.cpp:298
#8  0x00007fb49f10ce9a in start_thread (arg=0x7fb46effd700) at pthread_create.c:308
#9  0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7fb46d957700 (LWP 2894)):
#0  0x00007fb4a29f3313 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fb49d5ef036 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fb49d5ef164 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fb4a338a426 in QEventDispatcherGlib::processEvents (this=0x7fb4540008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fb4a3359c82 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fb4a3359ed7 in QEventLoop::exec (this=0x7fb46d956d90, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fb4a3258fa7 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fb4a33399ff in QInotifyFileSystemWatcherEngine::run (this=0x1df2120) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fb4a325bfcb in QThreadPrivate::start (arg=0x1df2120) at thread/qthread_unix.cpp:298
#9  0x00007fb49f10ce9a in start_thread (arg=0x7fb46d957700) at pthread_create.c:308
#10 0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7fb46cd2e700 (LWP 2917)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb4a325c4db in wait (time=18446744073709551615, this=0x1b9dbb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1b9dd10, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb4a06a20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1b9d090, th=0x1df4c80) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fb4a06a49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1b9dde0, th=0x1df4c80) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fb4a06a384f in ThreadWeaver::ThreadRunHelper::run (this=0x7fb46cd2dde0, parent=0x1b9d090, th=0x1df4c80) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fb4a06a38db in ThreadWeaver::Thread::run (this=0x1df4c80) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fb4a325bfcb in QThreadPrivate::start (arg=0x1df4c80) at thread/qthread_unix.cpp:298
#8  0x00007fb49f10ce9a in start_thread (arg=0x7fb46cd2e700) at pthread_create.c:308
#9  0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fb453fff700 (LWP 2918)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb4a325c4db in wait (time=18446744073709551615, this=0x1b9dbb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1b9dd10, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb4a06a20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1b9d090, th=0x1f177f0) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fb4a06a49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1b9dde0, th=0x1f177f0) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fb4a06a384f in ThreadWeaver::ThreadRunHelper::run (this=0x7fb453ffede0, parent=0x1b9d090, th=0x1f177f0) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fb4a06a38db in ThreadWeaver::Thread::run (this=0x1f177f0) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fb4a325bfcb in QThreadPrivate::start (arg=0x1f177f0) at thread/qthread_unix.cpp:298
#8  0x00007fb49f10ce9a in start_thread (arg=0x7fb453fff700) at pthread_create.c:308
#9  0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fb4537fe700 (LWP 2919)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb4a325c4db in wait (time=18446744073709551615, this=0x1b9dbb0) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0x1b9dd10, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00007fb4a06a20eb in ThreadWeaver::WeaverImpl::blockThreadUntilJobsAreBeingAssigned (this=0x1b9d090, th=0x1f1aa50) at ../../../threadweaver/Weaver/WeaverImpl.cpp:365
#4  0x00007fb4a06a49db in ThreadWeaver::WorkingHardState::applyForWork (this=0x1b9dde0, th=0x1f1aa50) at ../../../threadweaver/Weaver/WorkingHardState.cpp:71
#5  0x00007fb4a06a384f in ThreadWeaver::ThreadRunHelper::run (this=0x7fb4537fdde0, parent=0x1b9d090, th=0x1f1aa50) at ../../../threadweaver/Weaver/Thread.cpp:87
#6  0x00007fb4a06a38db in ThreadWeaver::Thread::run (this=0x1f1aa50) at ../../../threadweaver/Weaver/Thread.cpp:142
#7  0x00007fb4a325bfcb in QThreadPrivate::start (arg=0x1f1aa50) at thread/qthread_unix.cpp:298
#8  0x00007fb49f10ce9a in start_thread (arg=0x7fb4537fe700) at pthread_create.c:308
#9  0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#10 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb4527fc700 (LWP 2945)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fb49f6e6222 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fb49f6e6259 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fb49f10ce9a in start_thread (arg=0x7fb4527fc700) at pthread_create.c:308
#4  0x00007fb4a29feccd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb4a61047c0 (LWP 2782)):
[KCrash Handler]
#6  0x00007fb4a33735dd in QObject::~QObject (this=0x2737930, __in_chrg=<optimized out>) at kernel/qobject.cpp:820
#7  0x00007fb4a3373e69 in QObject::~QObject (this=0x2737930, __in_chrg=<optimized out>) at kernel/qobject.cpp:940
#8  0x00007fb4a4fa702e in qDeleteAll<QList<Collections::Collection*>::const_iterator> (end=..., begin=...) at /usr/include/qt4/QtCore/qalgorithms.h:322
#9  qDeleteAll<SmartPointerList<Collections::Collection> > (c=...) at /usr/include/qt4/QtCore/qalgorithms.h:330
#10 CollectionManager::~CollectionManager (this=0x185c770, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:137
#11 0x00007fb4a4fa7209 in CollectionManager::~CollectionManager (this=0x185c770, __in_chrg=<optimized out>) at ../../src/core-impl/collections/support/CollectionManager.cpp:145
#12 0x00007fb4a4fa54b6 in CollectionManager::destroy () at ../../src/core-impl/collections/support/CollectionManager.cpp:107
#13 0x00007fb4a50da4cf in App::~App (this=0x7fff1786d8d0, __in_chrg=<optimized out>) at ../../src/App.cpp:248
#14 0x0000000000408e5a in main (argc=3, argv=0x7fff1786fd58) at ../../src/main.cpp:303

This bug may be a duplicate of or related to bug 285951.

Possible duplicates by query: bug 316512, bug 314531, bug 309501, bug 307008, bug 306089.

Reported using DrKonqi
Comment 1 Myriam Schweingruber 2013-03-19 17:20:10 UTC
Did you read the suggestions given by the KDE crash manager? Apparently not, else you would have seen that this has been reported numerous times already.

Please upgrade your Amarok, this is fixed since quite some time now. See also http://kubuntu.org/news/amarok-27

*** This bug has been marked as a duplicate of bug 285951 ***