Bug 316945 - crash on data opening - detailed snapshot analyze
Summary: crash on data opening - detailed snapshot analyze
Status: RESOLVED FIXED
Alias: None
Product: kgraphviewer
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1.1
Platform: Archlinux Packages Linux
: VHI crash (vote)
Target Milestone: ---
Assignee: Gaël de Chalendar (aka Kleag)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-18 05:36 UTC by Ivan
Modified: 2014-04-03 20:59 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: http://commits.kde.org/kgraphviewer/d89f4aabece1f5fa55194a4f2eeaac664789ae80


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan 2013-03-18 05:36:20 UTC
+++ This bug was initially created as a clone of Bug #316307 +++

kgraphviewer 2.1.1 archlinux x86_64

sampla data attached bug 316307

Reproducible: Always

Steps to Reproduce:
open attached data and 

Actual Results:  
program crash

Expected Results:  
show graph

bug 316307 comment 14
Comment 1 Milian Wolff 2013-03-20 11:29:17 UTC
Potentially an ABI/API break in Graphviz, I'm unsure yet but couldn't find an easy fix yet :(
Comment 2 Ivan 2013-03-21 05:00:46 UTC
the qwt is a good alternative to graphviz http://qwt.sourceforge.net/
Comment 3 Milian Wolff 2013-03-21 11:45:37 UTC
Huh? Since when can Qwt do graphs like this: http://graphviz.org/Gallery.php ? I cannot find anything like that in the qwt gallery.
Comment 4 Ivan 2013-03-21 12:19:17 UTC
Shure it can't :( But possible it's not required for valgrind analyzer. Anyway I understood now what happens. tnx
Comment 5 Reimar Döffinger 2014-03-26 21:42:59 UTC
That is not a kgraphviewer bug.
Previous kgraphviewer versions supported only libgraph. Unfortunately graphviz introduced a libcgraph with functions that have the same name but different behaviour, which is about as bad an idea as it gets.
If like in bug 316307 both end up being loaded by some program it results in a huge mess and random crashes.
This should now be kind of fixed due to kgraphviewer git linking against and using libcgraph itself.
Comment 6 Reimar Döffinger 2014-04-03 20:59:23 UTC
Unless someone can still reproduce such an issue I'll assume that this has been fixed by the new cgraph support.