Bug 316551 - Adding a podcast channel with the context menu adds ALL podcast subscriptions multiple times.
Summary: Adding a podcast channel with the context menu adds ALL podcast subscriptions...
Status: RESOLVED DUPLICATE of bug 318782
Alias: None
Product: amarok
Classification: Unclassified
Component: Podcast (show other bugs)
Version: 2.7-git
Platform: Other Linux
: NOR major (vote)
Target Milestone: 2.8
Assignee: Amarok Developers
URL:
Keywords: regression, release_blocker
Depends on:
Blocks:
 
Reported: 2013-03-11 16:35 UTC by Myriam Schweingruber
Modified: 2013-04-24 11:49 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Myriam Schweingruber 2013-03-11 16:35:22 UTC
I wanted to add a podcast channel to the playlist by using the context menu -> Add to playlist.

This adds ALL the podcast channels multiple times, so isntead of having roughly 15 episodes I ended up with 80'000 tracks. The total amount of episodes in all subscriptions I currently have is about 350...
The same problem happens with the "Add to playlist" function in the pop-Up-Dropper.
Adding the same channel by drag and drop works fine.
Comment 1 Matěj Laitl 2013-03-12 08:00:04 UTC
Ralf, this is caused by your recent cleanups of Playlist, Podcast and Collection views, models and delegates, especially the removal of weird static actions handling.

Please have a look at this.

Note that this is reproducible also in Saved Playlists, not just podcasts.
Comment 2 Matěj Laitl 2013-04-24 11:49:35 UTC
Let's make bug 318782 the master one for this problem.

*** This bug has been marked as a duplicate of bug 318782 ***