Bug 316466 - krita 2.6.1: crash when clicking outside of a selection (similar to bug 315476 on Linux)
Summary: krita 2.6.1: crash when clicking outside of a selection (similar to bug 31547...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Tools (show other bugs)
Version: 2.6.1
Platform: Microsoft Windows Microsoft Windows
: NOR crash
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-10 12:24 UTC by Silvio Grosso
Modified: 2013-03-26 10:45 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Silvio Grosso 2013-03-10 12:24:23 UTC
Windows 7 - 64 bit (Windows home edition version)
Krita 2.6.1




Reproducible: Sometimes

Steps to Reproduce:
1. Open no matter what image (jpeg, tif etc)
2. Apply no matter what selection (circle, rectangle etc)
3. Click outside the area just selected: Krita 2.6.1  quite often crashes!
Actual Results:  
Krita 2.6.1 crashes as soon as you click outside a selection.
This occurs quite on random!
Sometimes Krita does not crash at all. Nevetheless, this crash occurs quite often with many different images.

I have tried to reproduce this same crash on Kubuntu 13.04 - Raring BUT (Kde 4.10.1) - ISO BUILDS, with VirtualBox
 Krita 2.6.1 does NOT crash on Linux with the same images... :-(
This in order to try to reproduce bug: 315476 on Linux.

Expected Results:  
Krita 2.6.1 should not crash on random on Windows 7 (64 bit) while clicking outside a selection

I have recorded a video on Windows 7 with all minimal steps to crash Krita 2.61.
I have attached the same image which crashes Krita 2.6.1 on Windows 7 (BUT *many* other images crash Krita as well !)
I have attached the LOG file for the crash which I have created on Windows through DbgView (Sysinternals Suite).

You can downlaod these 3 files from here (they are compressed as a Zip folder):
https://dl.dropbox.com/u/3095134/BUGS_REPORT/KRITA_2.6.1_CRASH_REPORT.zip
Comment 1 Halla Rempt 2013-03-10 14:26:47 UTC
Thanks for the report! With this report we've finally managed to reproduce. Sven and I are sitting together at the calligra sprint and sven says "I know what the problem is!"
Comment 2 Halla Rempt 2013-03-10 14:38:21 UTC
Git commit 6e866e189ffa40d46360cd7b07f97af1690e1986 by Boudewijn Rempt.
Committed on 10/03/2013 at 15:35.
Pushed by rempt into branch 'master'.

Don't try to add or remove an empty selection
Related: bug 315476

M  +7    -1    krita/image/kis_pixel_selection.cpp

http://commits.kde.org/calligra/6e866e189ffa40d46360cd7b07f97af1690e1986
Comment 3 Sven Langkamp 2013-03-10 14:55:01 UTC
Git commit c44a679961d441a543e240b13b5fd875e41d1da4 by Sven Langkamp.
Committed on 10/03/2013 at 15:52.
Pushed by langkamp into branch 'master'.

deselect when selecting an empty selection
Related: bug 315476

M  +5    -0    krita/ui/tool/kis_selection_tool_helper.cpp

http://commits.kde.org/calligra/c44a679961d441a543e240b13b5fd875e41d1da4
Comment 4 Halla Rempt 2013-03-26 10:45:55 UTC
Git commit 665bd4f2735899c7b465694910e069fb3997f718 by Boudewijn Rempt, on behalf of Sven Langkamp.
Committed on 10/03/2013 at 15:52.
Pushed by rempt into branch 'calligra/2.6'.

deselect when selecting an empty selection
Related: bug 315476

M  +5    -0    krita/ui/tool/kis_selection_tool_helper.cpp

http://commits.kde.org/calligra/665bd4f2735899c7b465694910e069fb3997f718