Bug 316459 - Mouse Cursor Does Not Blank Out
Summary: Mouse Cursor Does Not Blank Out
Status: RESOLVED FIXED
Alias: None
Product: kscreensaver
Classification: Miscellaneous
Component: general (show other bugs)
Version: 4.10.1
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: kscreensaver bugs tracking
URL:
Keywords:
: 316979 319388 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-03-10 11:32 UTC by eli
Modified: 2016-07-02 15:10 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.12.2
Sentry Crash Report:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description eli 2013-03-10 11:32:05 UTC
The mouse cursor remains visible after the screen saver is triggered on and it does not disappear.

Reproducible: Always
Comment 1 MichaelS 2013-03-14 18:45:38 UTC
Same problem under Arch Linux (x86_64) where this bug occurs since kde 4.10.0
Comment 2 wvvelzen 2013-05-07 21:14:31 UTC
Same here with fresh install of openSUSE 12.3 x86_64
Selected screen saver = "Blank Screen" (kblankscrn.kss)
Comment 3 Janet 2013-05-21 03:40:59 UTC
The problem also still exists in KDE SC 4.10.3 (Debian Sid here), though it is marked as fixed here: Bug 311571. Bug 319388 too seems to be a duplicate and maybe Bug 316979.
Comment 4 Tanja Schulte 2013-07-06 11:52:28 UTC
4.10.4 too... The cursor is visible on every screensaver and on the lock screen too :(.
Comment 5 Jekyll Wu 2013-07-06 13:47:26 UTC
*** Bug 316979 has been marked as a duplicate of this bug. ***
Comment 6 Jekyll Wu 2013-07-06 13:47:29 UTC
*** Bug 319388 has been marked as a duplicate of this bug. ***
Comment 7 LTHR 2013-09-05 07:17:54 UTC
The same problem with gentoo/amd64/kde 4.10.5/nvidia 310.40
Comment 8 Wolfgang Bauer 2014-01-08 08:59:49 UTC
Git commit c1761755915ab59f418b801a6901230f67877047 by Wolfgang Bauer.
Committed on 08/01/2014 at 08:29.
Pushed by wbauer into branch 'KDE/4.11'.

Screenlocker: don't set the mouse cursor when grabbing the mouse

Setting the cursor to ArrowCursor when calling XGrabPointer() prevents
the Screen savers from blanking the mouse cursor.
With this change they can blank the mouse cursor again.
Related: bug 311571
FIXED-IN: 4.11.6
REVIEW: 114841

M  +1    -1    ksmserver/screenlocker/ksldapp.cpp

http://commits.kde.org/kde-workspace/c1761755915ab59f418b801a6901230f67877047
Comment 9 Jekyll Wu 2014-01-09 04:02:27 UTC
There will not be 4.11.6 for KDE SC as a whole.
Comment 10 Wolfgang Bauer 2014-01-09 18:12:11 UTC
(In reply to comment #9)
> There will not be 4.11.6 for KDE SC as a whole.
But shouldn't it be 4.12.2 then?

According to http://techbase.kde.org/Schedules/KDE4/4.11_Release_Schedule#Tuesday.2C_February_4.2C_2014:_KDE_Workspaces_4.11.6_release kde-workspace 4.11.6 will be released on Feb. 4th together with KDE SC 4.12.2.
Comment 11 Wolfgang Bauer 2014-01-14 16:58:10 UTC
Changed FIXED-IN to 4.12.2, as kde-workspace 4.11.6 is not released yet together with KDE SC 4.12.1, but it will be released on Jan. 4th together with KDE SC 4.12.2.
Comment 12 rob 2015-01-13 20:21:27 UTC
If this was fixed in 4.12, it broke again in 4.13.  it's still broken in 4.14 on Mint 17.1 KDE.
Comment 13 Wolfgang Bauer 2015-01-15 15:11:09 UTC
(In reply to rob from comment #12)
> If this was fixed in 4.12, it broke again in 4.13.  it's still broken in
> 4.14 on Mint 17.1 KDE.

No, this is still fixed.

But the fix doesn't work for OpenGL screensavers, as Qt's OpenGL widget (QGLWidget) apparently explicitely sets a standard mousepointer.
See bug#334762.