Bug 316269 - Fade effect causes other animations to flicker
Summary: Fade effect causes other animations to flicker
Status: RESOLVED WORKSFORME
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-07 01:23 UTC by Mike Vaughn
Modified: 2018-08-25 15:45 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
System Settings Popup (47.98 KB, image/jpeg)
2013-10-12 18:47 UTC, KdeBugs
Details
qdbus org.kde.kwin KWin supportInformation.log (4.91 KB, text/x-log)
2013-10-13 00:35 UTC, KdeBugs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Vaughn 2013-03-07 01:23:53 UTC
When the Fade effect is enabled, there's a flicker in the animation for other effects (Glide, Sheet, Scale In). Perhaps this could be resolved by, when another animation effect is enabled, only applying the Fade effect to the window types that other animations don't get used for?
Comment 1 Thomas Lübking 2013-03-07 12:25:00 UTC
Please post or attach the output of
qdbus org.kde.kwin /KWin supportInformation

Also elaborate on "flicker" is there a sudden opactiy "jump" or is it constant switching between different opacities, does the window judder or expose old frames or ... ;-)
Comment 2 Mike Vaughn 2013-03-07 14:22:01 UTC
(In reply to comment #1)
> Please post or attach the output of
> qdbus org.kde.kwin /KWin supportInformation

http://pastebin.com/ZDePw40G
 
> Also elaborate on "flicker" is there a sudden opactiy "jump" or is it
> constant switching between different opacities, does the window judder or
> expose old frames or ... ;-)

Sorry that wasn't very clear. Yeah, there's an opacity "jump" -- about halfway through the glide animation, the opacity drops to 0% opacity for ~1 frame, then jumps back up to ~50% opacity for the rest of the glide animation. I'm guessing what's happening is both the fade and glide animations are starting at the same time, the fade finishes first, then the opacity resets for the completion of the glide.
Comment 3 Thomas Lübking 2013-03-07 14:40:53 UTC
Does it also happen if you deactivate "OpenGL 2.0 shaders" in "kcmshell4 kwincompositing", 3rd tab?
Comment 4 Mike Vaughn 2013-03-07 15:58:10 UTC
(In reply to comment #3)
> Does it also happen if you deactivate "OpenGL 2.0 shaders" in "kcmshell4
> kwincompositing", 3rd tab?

Yes it does.
Comment 5 Martin Flöser 2013-03-07 16:16:20 UTC
I guess the other effects do not install a grab role?
Comment 6 Thomas Lübking 2013-03-07 16:31:32 UTC
even if - it should be perfectly fine to combine scale ("In") and fade (and is here)

for glide, gliding out could become an issue (if fade and glide times mismatch, the window is faded out and then the fade effect skips with the glide effect finishing on the unfaded window)

If effects start to hold an animation grab the outcome will just be some sort of random (first effect that matches)

-> Either the animation times for the closing effects need to be coordinated (since even "set" could not cover the latter case as the animation has to be canceled at some point it does not know) or i'll have to look for a smart way to "set" the value but keep the reference only during the actual animation (for closing events) but we'll likely need a new function (the effect might indeed want to keep the window for a while)
Comment 7 KdeBugs 2013-10-12 18:47:07 UTC
Created attachment 82805 [details]
System Settings Popup
Comment 8 KdeBugs 2013-10-12 18:47:47 UTC
I'm using Arch x64 with KDE 4.11.2 

I noticed in the 'System Setting's when the 'Fade' is enabled, the small black popup windows that give a description of each section that appears when you hover your mouse over a section, and you move the mouse off one the sections and move it to another section, as the the black popup fades the window will jitter/shake slightly, personally I can really see the shaking of these popup windows, this also needs to be fixed. It might also shake and flicker as it's appearing, but I noticed it more when it's fading out.

Please see the attached screen shot; 'system-settings.jpg, you'll notice the popup window for the 'Shortcut and Gestures', that's the popup I was referring to that shakes.
Comment 9 Thomas Lübking 2013-10-12 20:00:17 UTC
Doesn't happen here - and please do not hijack bugs.

File a new one and attach the output of "qdbus org.kde.kwin /KWin supportInformation" there

Also check whether it happes with blurring disabled and whether it happens with blurring enabled but "saver intermediate blur results" disabled (blur settings, only checkbox)
Comment 10 KdeBugs 2013-10-12 20:40:43 UTC
I though my reply was relevant since I'm also experiencing a flicker issue with the Effects...

Not trying to hijack, just making a reply instead of a new report if it was something related is all...

I'm assuming;  "qdbus org.kde.kwin /KWin supportInformation" is a command, if so doesn't do anything here...

THANKS
Comment 11 Thomas Lübking 2013-10-12 21:13:30 UTC
Yes, but this is likely a dupe of bug #321897 - i suspect you to observe bug #307112 but can't say w/o requested info (yes, konsole command)

You however do not see this here, since glide or sheet etc. are for sure not invoked when showing this popup.
Comment 12 KdeBugs 2013-10-12 21:36:16 UTC
qdbus in Arch seems to be pointing to the wrong /path so I'm waiting back on a bug report for that to see how this is to be fixed before I run the command...

Blur does not change anything, it's the 'Fade' effect that is causing the shaking/flicker, if I disable 'Fade' it goes away, and always comes back with 'Fade' enabled...

THANKS
Comment 13 Thomas Lübking 2013-10-12 22:20:15 UTC
try "qdbus-qt4"
Comment 14 KdeBugs 2013-10-13 00:35:31 UTC
Created attachment 82812 [details]
qdbus org.kde.kwin KWin supportInformation.log
Comment 15 KdeBugs 2013-10-13 00:36:02 UTC
"qdbus-qt4" worked, log attached...

THANKS
Comment 16 Thomas Lübking 2013-10-13 08:20:50 UTC
I don't want to sound rude either, but please, once more, stay away from this bug.

It's not yours because that item is not supposed to trigger other animations, so there's no conflict - and the moment this one is confirmed to be a dupe, it will be closed as such and then your issue is lost.
Comment 17 Salvo "LtWorf" Tomaselli 2016-08-08 21:13:48 UTC
What's the status of this?

I just had to disable the fade effect because the whole screen was flickering and it was awful.
Comment 18 Vlad Zahorodnii 2018-08-25 15:45:31 UTC
The Glide effect, the Sheet effect, and the Scale effect(it superseded the Scale in effect) install grab roles. The log out screen has been added to the blacklist of the fade effect. Thus, I mark this bug as resolved.