Bug 316141 - KMix becomes unusably slow after a while
Summary: KMix becomes unusably slow after a while
Status: RESOLVED DUPLICATE of bug 309464
Alias: None
Product: kmix
Classification: Unclassified
Component: general (show other bugs)
Version: 4.3
Platform: Archlinux Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Christian Esken
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-04 21:24 UTC by Christian Muehlhaeuser
Modified: 2013-10-02 23:48 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Muehlhaeuser 2013-03-04 21:24:16 UTC
When KMix runs for a while - say two days or so - the entire GUI becomes pretty much unusable. Clicking the dock-icon takes a good 3 seconds to show the mixer window, using the mouse-wheel over the icon also results in a 2 to 3 seconds delay. After killing kmix and restarting it everything's back to normal. Happens since the KDE 4.10 release.

Reproducible: Always

Steps to Reproduce:
1. Keep kmix running for a while
Actual Results:  
Every GUI event seems to be delayed by 2 to 3 seconds (keeps getting worse the longer it runs)

Expected Results:  
KMix shouldn't become slower the longer it runs
Comment 1 Darin Miller 2013-04-20 00:24:53 UTC
I have 3 laptops that exhibit the same behavior. The slow or "stuttery" behavior can be duplicated by putting the system to sleep.  Awake the system and use the sound volume control keys.

To exaggerate the stutter, in the ~.kde/share/config/kmixrc file, set VolumePercentageStep=1
Comment 2 Rex Dieter 2013-04-20 05:45:06 UTC
It generally gets slower due to (apparently oxygen-related) kmix memory leak, bug #309464
Comment 3 Christoph Feck 2013-07-20 12:23:49 UTC
Can you confirm it is fixed in KDE 4.11 RC1?
Comment 4 Darin Miller 2013-07-25 02:42:23 UTC
4.11 RC1 fixed my laptops. Thanks!
Comment 5 Christoph Feck 2013-10-02 23:48:40 UTC

*** This bug has been marked as a duplicate of bug 309464 ***