Bug 316112 - Calligra Sheets crashed on selection of a "Recent Colour" when setting the background of a cell
Summary: Calligra Sheets crashed on selection of a "Recent Colour" when setting the ba...
Status: RESOLVED DUPLICATE of bug 313984
Alias: None
Product: calligrasheets
Classification: Applications
Component: general (show other bugs)
Version: 2.6.0
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Calligra Sheets (KSpread) Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-04 12:50 UTC by Darren Edale
Modified: 2013-03-04 13:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Darren Edale 2013-03-04 12:50:01 UTC
Application: calligrasheets (2.6.0)
KDE Platform Version: 4.10.00
Qt Version: 4.8.3
Operating System: Linux 3.5.0-25-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed:

I was changing the background colour of a single cell using the "Cell format" dialogue. I clicked on the "choose colour" button and used the "recent colours" feature of the standard KDE colour dialogue. On clicking the desired colour, the crash occurred. The only odd thing that I noticed was that my most recently selected colour (pale yellow, if that helps identify which entry in the dialogue I clicked) was repeated several times in the recent colours palette, even though I had only used the colour once (i.e. the last time I used the KDE colour dialogue was to choose this colour for some other cells a few minutes previously and at that time I selected the colour using the HSV block, which is how it came to be in the recent colours list in the first place).

During my current desktop session, Calligra Sheets is the only application that has used the KDE colour dialogue.

-- Backtrace:
Application: Calligra Sheets (calligrasheets), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f6de391b7c0 (LWP 15675))]

Thread 2 (Thread 0x7f6dbcbc7700 (LWP 15680)):
#0  0x00007f6ddd8d105d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f6db0183060) at pthread_mutex_unlock.c:290
#2  0x00007f6ddd43be51 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f6ddd3fec5c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f6ddd3feea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f6de18c9c46 in QEventDispatcherGlib::processEvents (this=0x7f6db01ba220, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f6de189a2ef in QEventLoop::processEvents (this=this@entry=0x7f6dbcbc6cd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f6de189a578 in QEventLoop::exec (this=0x7f6dbcbc6cd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f6de179bb40 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f6de187a9df in QInotifyFileSystemWatcherEngine::run (this=0x2a9f900) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f6de179eb1c in QThreadPrivate::start (arg=0x2a9f900) at thread/qthread_unix.cpp:338
#11 0x00007f6dd620c764 in ?? () from /usr/lib/nvidia-current-updates/libGL.so.1
#12 0x00007f6ddd8cde9a in start_thread (arg=0x7f6dbcbc7700) at pthread_create.c:308
#13 0x00007f6de3226cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#14 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f6de391b7c0 (LWP 15675)):
[KCrash Handler]
#6  0x0000000000000006 in ?? ()
#7  0x00007f6de278963e in QAbstractItemView::mouseReleaseEvent (this=0x3196b20, event=0x7ffff53fe980) at itemviews/qabstractitemview.cpp:1789
#8  0x00007f6dde6187b7 in KColorCells::mouseReleaseEvent (this=0x3196b20, e=0x7ffff53fe980) at ../../kdeui/colors/kcolordialog.cpp:455
#9  0x00007f6de22cd850 in QWidget::event (this=0x3196b20, event=0x7ffff53fe980) at kernel/qwidget.cpp:8371
#10 0x00007f6de267cb66 in QFrame::event (this=0x3196b20, e=0x7ffff53fe980) at widgets/qframe.cpp:557
#11 0x00007f6de278859b in QAbstractItemView::viewportEvent (this=0x3196b20, event=0x7ffff53fe980) at itemviews/qabstractitemview.cpp:1644
#12 0x00007f6de189b706 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=<optimized out>, receiver=0x3253db0, event=0x7ffff53fe980) at kernel/qcoreapplication.cpp:1025
#13 0x00007f6de227de6c in QApplicationPrivate::notify_helper (this=this@entry=0x81f510, receiver=receiver@entry=0x3253db0, e=e@entry=0x7ffff53fe980) at kernel/qapplication.cpp:4558
#14 0x00007f6de2282b6b in QApplication::notify (this=<optimized out>, receiver=0x3253db0, e=0x7ffff53fe980) at kernel/qapplication.cpp:4105
#15 0x00007f6de2dd0ba8 in KoApplication::notify(QObject*, QEvent*) () from /usr/lib/libkomain.so.11
#16 0x00007f6de189b59e in QCoreApplication::notifyInternal (this=0x7ffff5400b40, receiver=0x3253db0, event=0x7ffff53fe980) at kernel/qcoreapplication.cpp:915
#17 0x00007f6de227ecd3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#18 QApplicationPrivate::sendMouseEvent (receiver=0x3253db0, event=0x7ffff53fe980, alienWidget=0x3253db0, nativeWidget=0x2bab840, buttonDown=0x7f6de2d5a308 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3173
#19 0x00007f6de22fc554 in QETWidget::translateMouseEvent (this=this@entry=0x2bab840, event=event@entry=0x7ffff53ff100) at kernel/qapplication_x11.cpp:4622
#20 0x00007f6de22fb44f in QApplication::x11ProcessEvent (this=0x7ffff5400b40, event=0x7ffff53ff100) at kernel/qapplication_x11.cpp:3737
#21 0x00007f6de2322fa2 in x11EventSourceDispatch (s=0x8236b0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#22 0x00007f6ddd3feab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#23 0x00007f6ddd3fede8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#24 0x00007f6ddd3feea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#25 0x00007f6de18c9c46 in QEventDispatcherGlib::processEvents (this=0x75a2a0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#26 0x00007f6de2322c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#27 0x00007f6de189a2ef in QEventLoop::processEvents (this=this@entry=0x7ffff53ff4e0, flags=...) at kernel/qeventloop.cpp:149
#28 0x00007f6de189a578 in QEventLoop::exec (this=0x7ffff53ff4e0, flags=...) at kernel/qeventloop.cpp:204
#29 0x00007f6de2736428 in QDialog::exec (this=0x2f46e30) at dialogs/qdialog.cpp:554
#30 0x00007f6dcba58546 in Calligra::Sheets::CellToolBase::cellStyle() () from /usr/lib/libcalligrasheetscommon.so.11
#31 0x00007f6dcb999b5c in ?? () from /usr/lib/libcalligrasheetscommon.so.11
#32 0x00007f6de18b0f8f in QMetaObject::activate (sender=0x2307440, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7ffff53ff6b0) at kernel/qobject.cpp:3547
#33 0x00007f6de2277a32 in QAction::triggered (this=this@entry=0x2307440, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#34 0x00007f6de2277c20 in QAction::activate (this=0x2307440, event=<optimized out>) at kernel/qaction.cpp:1257
#35 0x00007f6de263c51f in QAbstractButtonPrivate::click (this=this@entry=0x2b72f30) at widgets/qabstractbutton.cpp:530
#36 0x00007f6de263c7cc in QAbstractButton::mouseReleaseEvent (this=0x2b72e50, e=0x7ffff53fff70) at widgets/qabstractbutton.cpp:1123
#37 0x00007f6de26f699a in QToolButton::mouseReleaseEvent (this=<optimized out>, e=<optimized out>) at widgets/qtoolbutton.cpp:718
#38 0x00007f6de22cd850 in QWidget::event (this=0x2b72e50, event=0x7ffff53fff70) at kernel/qwidget.cpp:8371
#39 0x00007f6de227de9c in QApplicationPrivate::notify_helper (this=this@entry=0x81f510, receiver=receiver@entry=0x2b72e50, e=e@entry=0x7ffff53fff70) at kernel/qapplication.cpp:4562
#40 0x00007f6de2282b6b in QApplication::notify (this=<optimized out>, receiver=0x2b72e50, e=0x7ffff53fff70) at kernel/qapplication.cpp:4105
#41 0x00007f6de2dd0ba8 in KoApplication::notify(QObject*, QEvent*) () from /usr/lib/libkomain.so.11
#42 0x00007f6de189b59e in QCoreApplication::notifyInternal (this=0x7ffff5400b40, receiver=0x2b72e50, event=0x7ffff53fff70) at kernel/qcoreapplication.cpp:915
#43 0x00007f6de227ecd3 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#44 QApplicationPrivate::sendMouseEvent (receiver=0x2b72e50, event=0x7ffff53fff70, alienWidget=0x2b72e50, nativeWidget=0x2b5e500, buttonDown=0x7f6de2d5a308 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3173
#45 0x00007f6de22fc554 in QETWidget::translateMouseEvent (this=this@entry=0x2b5e500, event=event@entry=0x7ffff54006f0) at kernel/qapplication_x11.cpp:4622
#46 0x00007f6de22fb44f in QApplication::x11ProcessEvent (this=0x7ffff5400b40, event=0x7ffff54006f0) at kernel/qapplication_x11.cpp:3737
#47 0x00007f6de2322fa2 in x11EventSourceDispatch (s=0x8236b0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#48 0x00007f6ddd3feab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007f6ddd3fede8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#50 0x00007f6ddd3feea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#51 0x00007f6de18c9c46 in QEventDispatcherGlib::processEvents (this=0x75a2a0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#52 0x00007f6de2322c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#53 0x00007f6de189a2ef in QEventLoop::processEvents (this=this@entry=0x7ffff5400ac0, flags=...) at kernel/qeventloop.cpp:149
#54 0x00007f6de189a578 in QEventLoop::exec (this=0x7ffff5400ac0, flags=...) at kernel/qeventloop.cpp:204
#55 0x00007f6de189f738 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#56 0x00007f6de351c4dd in kdemain () from /usr/lib/kde4/libkdeinit/libkdeinit4_calligrasheets.so
#57 0x00007f6de315476d in __libc_start_main (main=0x4006a0, argc=2, ubp_av=0x7ffff5400c58, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffff5400c48) at libc-start.c:226
#58 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 313984.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-03-04 13:45:33 UTC

*** This bug has been marked as a duplicate of bug 313984 ***