Bug 316044 - Double click on a lesson name should open the lesson
Summary: Double click on a lesson name should open the lesson
Status: RESOLVED FIXED
Alias: None
Product: ktouch
Classification: Unclassified
Component: general (show other bugs)
Version: 2.0.0
Platform: Chakra Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Sebastian Gottfried
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-02 22:28 UTC by Fabian
Modified: 2013-04-03 08:59 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian 2013-03-02 22:28:01 UTC
Currently to start a lesson one has first to select the lesson in the list on the left, and then click on the "Start lesson" button. It would be nice if it could be started via a double click on the name. Another nicety would be adding acellerator keys: up/down to move in the lesson list, enter to start the lesson.

Reproducible: Always

Steps to Reproduce:
1. Double click on the lesson name.
Actual Results:  
nothing happens

Expected Results:  
The lesson starts.
Comment 1 Sebastian Gottfried 2013-03-06 17:20:10 UTC
Git commit 07297bc6bd2a6511cf80814f6ec27915f7e3ce10 by Sebastian Gottfried.
Committed on 06/03/2013 at 18:07.
Pushed by gottfried into branch 'master'.

allow selection confirmation in lists per double click

Now it's possible to start training on a lesson or selecting a different
user profile with a simple double click on the list item if one doesn't
like to do the extra click on the confirmation buttons in these forms.

M  +6    -1    src/qml/LessonSelector.qml
M  +4    -2    src/qml/ListItem.qml
M  +6    -1    src/qml/ProfileSelector.qml

http://commits.kde.org/ktouch/07297bc6bd2a6511cf80814f6ec27915f7e3ce10
Comment 2 Sebastian Gottfried 2013-04-03 08:59:11 UTC
I'm closing this ticket as fixed now since the main request is implemented by now. The keyboard navigation part is already tracked by Bug 316058, but won't be implemented anytime soon for the there explained issues.