Bug 315976 - Plasma crashed trying to copy a file to temporarily-unavailable NFS mount
Summary: Plasma crashed trying to copy a file to temporarily-unavailable NFS mount
Status: RESOLVED DUPLICATE of bug 241562
Alias: None
Product: plasma4
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-01 19:24 UTC by Jon Dubovsky
Modified: 2013-03-02 02:13 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Dubovsky 2013-03-01 19:24:43 UTC
Application: plasma-desktop (0.4)
KDE Platform Version: 4.9.4
Qt Version: 4.8.3
Operating System: Linux 3.5.0-22-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
In Dolphin, I highlighted a ~35 MB file from my home directory, pressed control-C to copy it, opened a new tab in Dolphin with ctrl-T, selected from the left-hand "Devices" list an NFS-mounted drive.  The directory of that drive appeared, then I pressed ctrl-V to paste that file.  The target NFS box happens to be right next to me and I heard it spinning up a drive (presumably the target of this operation).  I noticed within a few seconds that I wasn't seeing a copy progress dialog, so clicked on Dolphin to get ready to hit refresh on the directory.  Then I noticed that Dolphin was unresponsive: I couldn't change tabs, couldn't select files, etc.  After about 30 seconds Plasma crashed and I got this error submit dialog.

-- Backtrace:
Application: Plasma Desktop Shell (plasma-desktop), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcd5b628780 (LWP 2634))]

Thread 5 (Thread 0x7fcd3b2c0700 (LWP 2636)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fcd54c0dcd7 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#2  0x00007fcd54c0dd09 in ?? () from /usr/lib/x86_64-linux-gnu/libQtScript.so.4
#3  0x00007fcd4f2a6e9a in start_thread (arg=0x7fcd3b2c0700) at pthread_create.c:308
#4  0x00007fcd5af13cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#5  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fcd33298700 (LWP 2637)):
#0  0x00007fcd5af08303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fcd4eba7d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcd4eba7ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcd57bb6c16 in QEventDispatcherGlib::processEvents (this=0x7fcd2c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#4  0x00007fcd57b872bf in QEventLoop::processEvents (this=this@entry=0x7fcd33297dd0, flags=...) at kernel/qeventloop.cpp:149
#5  0x00007fcd57b87548 in QEventLoop::exec (this=0x7fcd33297dd0, flags=...) at kernel/qeventloop.cpp:204
#6  0x00007fcd57a88b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#7  0x00007fcd57b679af in QInotifyFileSystemWatcherEngine::run (this=0x30e9b10) at io/qfilesystemwatcher_inotify.cpp:248
#8  0x00007fcd57a8baec in QThreadPrivate::start (arg=0x30e9b10) at thread/qthread_unix.cpp:338
#9  0x00007fcd4f2a6e9a in start_thread (arg=0x7fcd33298700) at pthread_create.c:308
#10 0x00007fcd5af13cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#11 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fcd322d5700 (LWP 2638)):
#0  0x00007fcd5af068bd in read () at ../sysdeps/unix/syscall-template.S:82
#1  0x00007fcd4ebe415f in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcd4eba7914 in g_main_context_check () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcd4eba7d22 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fcd4eba7ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fcd57bb6c16 in QEventDispatcherGlib::processEvents (this=0x7fcd240008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fcd57b872bf in QEventLoop::processEvents (this=this@entry=0x7fcd322d4dd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fcd57b87548 in QEventLoop::exec (this=0x7fcd322d4dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fcd57a88b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fcd57b679af in QInotifyFileSystemWatcherEngine::run (this=0x3131720) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fcd57a8baec in QThreadPrivate::start (arg=0x3131720) at thread/qthread_unix.cpp:338
#11 0x00007fcd4f2a6e9a in start_thread (arg=0x7fcd322d5700) at pthread_create.c:308
#12 0x00007fcd5af13cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fcd2b7fe700 (LWP 2643)):
#0  0x00007fcd5af08303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007fcd4eba7d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fcd4eba81e2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fcd303234a6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fcd4ebcb645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fcd4f2a6e9a in start_thread (arg=0x7fcd2b7fe700) at pthread_create.c:308
#6  0x00007fcd5af13cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fcd5b628780 (LWP 2634)):
[KCrash Handler]
#6  0x00007fcd5827fbd4 in KJob::isAutoDelete (this=this@entry=0x5d6fc60) at ../../kdecore/jobs/kjob.cpp:361
#7  0x00007fcd5827ff38 in KJob::emitResult (this=0x5d6fc60) at ../../kdecore/jobs/kjob.cpp:320
#8  0x00007fcd3ed64ed9 in StatusNotifierItemJob::contextMenuReady (this=0x5d6fc60, menu=0x45f49d0) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:53
#9  0x00007fcd57b9df5f in QMetaObject::activate (sender=0x5c26810, m=<optimized out>, local_signal_index=<optimized out>, argv=0x7fffec021e50) at kernel/qobject.cpp:3547
#10 0x00007fcd3ed60ccf in StatusNotifierItemSource::contextMenuReady (this=<optimized out>, _t1=0x45f49d0) at ./statusnotifieritemsource.moc:123
#11 0x00007fcd3ed60cf9 in StatusNotifierItemSource::contextMenuReady (this=<optimized out>) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:363
#12 0x00007fcd3ed63ddd in qt_static_metacall (_a=<optimized out>, _id=<optimized out>, _o=<optimized out>, _c=<optimized out>) at ./statusnotifieritemsource.moc:65
#13 StatusNotifierItemSource::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./statusnotifieritemsource.moc:58
#14 0x00007fcd57b9df5f in QMetaObject::activate (sender=0x5c57b40, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#15 0x00007fcd4fd2209c in DBusMenuImporter::slotMenuAboutToShow() () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#16 0x00007fcd57b9df5f in QMetaObject::activate (sender=0x45f49d0, m=<optimized out>, local_signal_index=<optimized out>, argv=0x0) at kernel/qobject.cpp:3547
#17 0x00007fcd57b90987 in QMetaMethod::invoke (this=this@entry=0x7fffec0225f0, object=object@entry=0x45f49d0, connectionType=Qt::DirectConnection, connectionType@entry=Qt::AutoConnection, returnValue=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1664
#18 0x00007fcd57b92d5c in QMetaObject::invokeMethod (obj=0x45f49d0, member=<optimized out>, type=Qt::AutoConnection, ret=..., val0=..., val1=..., val2=..., val3=..., val4=..., val5=..., val6=..., val7=..., val8=..., val9=...) at kernel/qmetaobject.cpp:1179
#19 0x00007fcd4fd20e79 in DBusMenuImporter::updateMenu() () from /usr/lib/x86_64-linux-gnu/libdbusmenu-qt.so.2
#20 0x00007fcd3ed608e6 in StatusNotifierItemSource::contextMenu (this=0x5c26810, x=<optimized out>, y=<optimized out>) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemsource.cpp:466
#21 0x00007fcd3ed65863 in StatusNotifierItemJob::start (this=0x5d6fc60) at ../../../../../plasma/generic/dataengines/statusnotifieritem/statusnotifieritemjob.cpp:43
#22 0x00007fcd57b9d43e in QObject::event (this=0x5d6fc60, e=<optimized out>) at kernel/qobject.cpp:1195
#23 0x00007fcd56f2fe9c in QApplicationPrivate::notify_helper (this=this@entry=0x2459fc0, receiver=receiver@entry=0x5d6fc60, e=e@entry=0x42d06c0) at kernel/qapplication.cpp:4562
#24 0x00007fcd56f3430a in QApplication::notify (this=0x24365e0, receiver=0x5d6fc60, e=0x42d06c0) at kernel/qapplication.cpp:4423
#25 0x00007fcd588411d6 in KApplication::notify (this=0x24365e0, receiver=0x5d6fc60, event=0x42d06c0) at ../../kdeui/kernel/kapplication.cpp:311
#26 0x00007fcd57b8856e in QCoreApplication::notifyInternal (this=0x24365e0, receiver=receiver@entry=0x5d6fc60, event=event@entry=0x42d06c0) at kernel/qcoreapplication.cpp:915
#27 0x00007fcd57b8c3f1 in sendEvent (event=0x42d06c0, receiver=0x5d6fc60) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#28 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x23b01f0) at kernel/qcoreapplication.cpp:1539
#29 0x00007fcd57bb6a63 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#30 postEventSourceDispatch (s=0x2454e20) at kernel/qeventdispatcher_glib.cpp:279
#31 0x00007fcd4eba7ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#32 0x00007fcd4eba7de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#33 0x00007fcd4eba7ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#34 0x00007fcd57bb6bf6 in QEventDispatcherGlib::processEvents (this=0x23b1ad0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#35 0x00007fcd56fd4c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#36 0x00007fcd57b872bf in QEventLoop::processEvents (this=this@entry=0x7fffec023610, flags=...) at kernel/qeventloop.cpp:149
#37 0x00007fcd57b87548 in QEventLoop::exec (this=0x7fffec023610, flags=...) at kernel/qeventloop.cpp:204
#38 0x00007fcd57b8c708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#39 0x00007fcd5b21a035 in kdemain (argc=1, argv=0x7fffec023908) at ../../../../plasma/desktop/shell/main.cpp:120
#40 0x00007fcd5ae4176d in __libc_start_main (main=0x4006a0 <main(int, char**)>, argc=1, ubp_av=0x7fffec023908, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7fffec0238f8) at libc-start.c:226
#41 0x00000000004006d1 in _start ()

Possible duplicates by query: bug 310158, bug 309667, bug 309555, bug 308739, bug 308551.

Reported using DrKonqi
Comment 1 Christoph Feck 2013-03-02 02:13:13 UTC

*** This bug has been marked as a duplicate of bug 241562 ***