Bug 315945 - When locking session via a keyboard shortcut, the locker gets current keyboard layout
Summary: When locking session via a keyboard shortcut, the locker gets current keyboar...
Status: RESOLVED DUPLICATE of bug 319935
Alias: None
Product: ksmserver
Classification: Unclassified
Component: ui (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Lubos Lunak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-03-01 11:08 UTC by Victor Varvaryuk
Modified: 2013-08-18 08:47 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Varvaryuk 2013-03-01 11:08:36 UTC
If I, for example, have an open Google Chrome window with Russian keyboard layout active and press Meta+L (which is set on my machine to lock session) the session is locked, but the current keyboard layout for Chrome is active.
Moreover, if a press Alt+Shift to change keyboard layout, the password field loses focus.

Reproducible: Always
Comment 1 David Edmundson 2013-03-03 15:05:36 UTC
Locking is not done by LightDM moving.
Comment 2 ttrovo 2013-08-10 17:50:43 UTC
>Status UNCONFIRMED
I do CONFIRM this but. And this problem is still unsolved.
It still exists on latest Kubuntu (13.04, raring) with KDE 4.10.5 (Qt: 4.8.4).

Probably it's a duplicate of bug #319935.
Comment 3 Jekyll Wu 2013-08-18 08:47:12 UTC

*** This bug has been marked as a duplicate of bug 319935 ***