Bug 315878 - crashed when on an inline note - clicked out of the popup
Summary: crashed when on an inline note - clicked out of the popup
Status: RESOLVED DUPLICATE of bug 313984
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: 0.16.0
Platform: Archlinux Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-27 22:15 UTC by Serena
Modified: 2013-02-27 22:41 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Serena 2013-02-27 22:15:42 UTC
Application: okular (0.16.0)
KDE Platform Version: 4.10.00
Qt Version: 4.8.4
Operating System: Linux 3.7.9-1-ARCH x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
I was editing an inline note (there was a newline in the end).
I accidentally clicked out of the popup (i'm not sure whether it was on the note or directly on the pdf file, but it was probably on the note)

The crash can be reproduced some of the time.

-- Backtrace:
Application: Okular (okular), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[KCrash Handler]
#5  0x00007f3951b6b618 in QAbstractItemView::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
#6  0x00007f39522c84a7 in KColorCells::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libkdeui.so.5
#7  0x00007f39516b3a49 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#8  0x00007f3951a5ed36 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#9  0x00007f3951b6a57b in QAbstractItemView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
#10 0x00007f3950c6d816 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#11 0x00007f395166415c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#12 0x00007f3951668e6b in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#13 0x00007f3952382426 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#14 0x00007f3950c6d6ae in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#15 0x00007f3951664fcb in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#16 0x00007f39516dfad4 in ?? () from /usr/lib/libQtGui.so.4
#17 0x00007f39516de861 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#18 0x00007f3951704a22 in ?? () from /usr/lib/libQtGui.so.4
#19 0x00007f394cf0b845 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#20 0x00007f394cf0bb78 in ?? () from /usr/lib/libglib-2.0.so.0
#21 0x00007f394cf0bc34 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#22 0x00007f3950c9bb66 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#23 0x00007f395170469e in ?? () from /usr/lib/libQtGui.so.4
#24 0x00007f3950c6c3ff in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#25 0x00007f3950c6c688 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#26 0x00007f3951b18758 in QDialog::exec() () from /usr/lib/libQtGui.so.4
#27 0x00007f39418da29e in ?? () from /usr/lib/kde4/okularpart.so
#28 0x00007f39419150db in ?? () from /usr/lib/kde4/okularpart.so
#29 0x00007f39516b3a30 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
#30 0x00007f3951a5ed36 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
#31 0x00007f394190633d in ?? () from /usr/lib/kde4/okularpart.so
#32 0x00007f3950c6d816 in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#33 0x00007f395166415c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#34 0x00007f3951668e6b in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
#35 0x00007f3952382426 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
#36 0x00007f3950c6d6ae in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
#37 0x00007f3951664fcb in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&, bool) () from /usr/lib/libQtGui.so.4
#38 0x00007f39516dfad4 in ?? () from /usr/lib/libQtGui.so.4
#39 0x00007f39516de861 in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
#40 0x00007f3951704a22 in ?? () from /usr/lib/libQtGui.so.4
#41 0x00007f394cf0b845 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#42 0x00007f394cf0bb78 in ?? () from /usr/lib/libglib-2.0.so.0
#43 0x00007f394cf0bc34 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#44 0x00007f3950c9bb66 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#45 0x00007f395170469e in ?? () from /usr/lib/libQtGui.so.4
#46 0x00007f3950c6c3ff in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#47 0x00007f3950c6c688 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
#48 0x00007f3950c71328 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
#49 0x00000000004082be in ?? ()
#50 0x00007f39501eba15 in __libc_start_main () from /usr/lib/libc.so.6
#51 0x0000000000408f09 in _start ()

Possible duplicates by query: bug 313984.

Reported using DrKonqi
Comment 1 Albert Astals Cid 2013-02-27 22:41:34 UTC

*** This bug has been marked as a duplicate of bug 313984 ***