Bug 315598 - Proxy settings ignored in incognito mode
Summary: Proxy settings ignored in incognito mode
Status: RESOLVED FIXED
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1
Platform: Ubuntu Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-21 21:10 UTC by ro.ggi
Modified: 2013-08-21 13:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ro.ggi 2013-02-21 21:10:48 UTC
Proxy settings are not used in incognito mode. I noticed this by using privoxy web configuration http://config.privoxy.org

Reproducible: Always
Comment 1 Andrea Diamantini 2013-02-24 10:05:20 UTC
That's right! Unfortunately to have a working incognito mode, we need to use Qt classes instead of KIO. This loose kde magic facilities to set proxy, manage cookies and network cache.
Cookies and cache are not a problem because they are something we don't want to mix or take care in incognito mode.
Proxy support has to be implemented. (or kio needs improvements to right support incognito mode, allowing all its free magic).
Comment 2 ro.ggi 2013-03-02 11:31:00 UTC
Ok, KIO support for incognito mode would be the best solution. I have made a request for it https://bugs.kde.org/show_bug.cgi?id=316006
Comment 3 Andrea Diamantini 2013-06-10 09:54:14 UTC
Git commit 7330968510ffd83ab208ae0ffa8febe49c4dbcdb by Andrea Diamantini.
Committed on 10/06/2013 at 11:50.
Pushed by adjam into branch 'master'.

Link custom rekonq QNAM to KDE proxy settings

This is a first attempt to link our needed QNAM to KDE proxy settings.
It will try to fix proxy problems when used.

Oh... I also added some new error strings in case of proxy problems :)
Related: bug 304378

M  +1    -0    src/CMakeLists.txt
M  +4    -2    src/icons/icondownloader.cpp
A  +73   -0    src/webtab/knetworkaccessmanager.cpp     [License: GPL (v2/3)]
A  +46   -0    src/webtab/knetworkaccessmanager.h     [License: GPL (v2/3)]
M  +2    -1    src/webtab/networkaccessmanager.cpp
M  +32   -0    src/webtab/webpage.cpp

http://commits.kde.org/rekonq/7330968510ffd83ab208ae0ffa8febe49c4dbcdb
Comment 4 ro.ggi 2013-08-21 13:18:11 UTC
Now Rekonq supports proxy in privacy mode browsing. Thanks to all who has looked into this!